Skip navigation
This discussion is archived

New post re Aperture 3 "processing" - for ever

7790 Views 16 Replies Latest reply: Mar 25, 2010 7:54 AM by Alan Goodall RSS
1 2 Previous Next
Alan Goodall Level 1 Level 1 (130 points)
Currently Being Moderated
Feb 15, 2010 10:33 AM
Further to my earlier post on the huge 'Aperture hanging... thread"..

By watching the Aperture 3 Activity window I see that each time it fairly zips through 'Processing 'n' of 'n' items - BUT - mine hangs when it reaches about 120. These are all large (110 MB files)

So, Each time it has hung I did a quit Process from the Activity window (NOTForce quit in case I lost all that had been processed. (It takes ages to quit) _ - then re-opened Aperture and started off again. However, as I write it hung again on the last part - 67 of 77!) Repeated the process and it hung on 3 of 10, 4 of 6 and even 1 of 2 and finally 0 of 1. After several tries I cannot get the last one processed! I have heard of the law of diminishing returns but this seems crazy!

This is a library of 174 GB on an external WB Firewire 800. My smallest library of 5.4 GB processed Ok eventually. However, my largest one - of 633 Gb - which is on my 1 TB iMac internal drive has hung so many times that I will now leave that until Apple provide a fix SOON!
iMac 3.06 GHz, MacBook Pro Duo 2.4 GHz, Powerbook G4, Mac OS X (10.6)
  • LanceK713 Calculating status...
    Currently Being Moderated
    Feb 15, 2010 11:39 AM (in response to Alan Goodall)
    Try repairing your library. Close Aperture, then launch your library from finder while holding Option + Command, then select Repair. It helped me.

    You might also try holding Shift when you launch Aperture. This prevents generation of thumbnails. I think there is where my installation was getting hung up, due to some corruption in the library.
    iMac, MacBook Pro, Mac OS X (10.5.1)
  • Robert Rogers Level 2 Level 2 (345 points)
    Currently Being Moderated
    Feb 15, 2010 1:29 PM (in response to Alan Goodall)
    I have a 750GB iphoto library and could not import it via A3. I finally made a duplicate of my drive and decided to import the library and leave it in its current position and although we are at about 24 hours things seem to be importing. Probably better to leave IPhoto as is and move pictures and folders in as I need them. Just a thought,
    2X 2.26 Quad Core Nehalem 16GB mem, Mac OS X (10.6), ATA HD 4870 video card
  • gavinthain Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 15, 2010 1:55 PM (in response to Alan Goodall)
    My Library is 216Gb. Totally fed up with this.
    My symptoms - Aperture3 launches, opens after about 30 seconds ish, then consumes all free RAM, and creates MASSIVE swap file - like GB's... kills iMac. Have to Hard Reboot.
    Tried creating a new library, and importing upgraded library.
    This works, then when I relaunch Aperture it dies again.
    Processing... gets to 5 of 20 (whatever that means) and then goes into this crazy memory leak.
    I'm now going to try importing again but renaming the Thumbnails and Previews folders in the Library package. Lets see if that makes any difference what so ever.
    This must be a code bug, too many people are getting this issue!!!
    iMac 24" (White), Mac OS X (10.5.7), 216Gb Library on 1Tb Drobo FW800
  • Matthew Bergsma Level 3 Level 3 (600 points)
    Currently Being Moderated
    Feb 15, 2010 2:11 PM (in response to Alan Goodall)
    Are you using referenced or managed masters?
    Mac pro 3.2x8, macbook pro 2.4, Mac OS X (10.6.2)
  • martinizer Calculating status...
    Currently Being Moderated
    Feb 16, 2010 9:39 AM (in response to Alan Goodall)
    Launching while holding the shift key worked for me. No more hanging or crashing.
    macbook pro, Mac OS X (10.5.8)
  • wallrat1975 Calculating status...
    Currently Being Moderated
    Feb 22, 2010 12:03 PM (in response to Alan Goodall)
    This worked for me too! My problem was identical to yours. It would process "x of y" then just freeze, eventually sitting at "0 of 1". 32bit solved it, even allowed face detection to run and finish.

    MacBook Pro 15.4, Mac OS X (10.6.2)
  • Gobucky Calculating status...
    Currently Being Moderated
    Mar 25, 2010 6:22 AM (in response to Alan Goodall)
    I had similar problems. 80 GB library. Continual processing. Ran the 32-bit solution and it appeared to work. Processed everything. Ran face detection and finished successfully all 35,000 pictures. Shut down Aperture and restarted in 64 bit mode. Now it hangs on processing 4 of 21 items and 1 of 28 thumbnails for faces. I dont understand how it could be needing to do this since I did no work in the program after the rebuild and the processing finished. Any tips? Run through the 32 bit solution one more time? I'm desparate.
    iMac G5, Mac OS X (10.6.2)
  • imigra Level 2 Level 2 (220 points)
    Currently Being Moderated
    Mar 25, 2010 6:45 AM (in response to Alan Goodall)
    I am guessing that a library of 633Gb on your internal iMac system drive is not a very good idea. That together with the system and some more stuff makes that things are probably so fragmented that a simple write to the Library database takes forever, let alone writing to the Thumbnail files (depending on the size of your projects), sometimes broken up into thousands of bits and pieces. OSX is fairly fragmentation resistant, but I think that incremental writing to a file fragments it if there's no contiguous free space available right at the end of the file, and with the disk filling up, this becomes worse over time. You might find temporary solace in a full defrag of your system drive, but consider getting a fast external drive. Get one with firewire 800 and eSata (you next system might have it), and/or USB 3 (they're starting to show up). Firewire 800 is as fast as the iMac goes, but I've found it to be fast for Aperture, and it's always better no to have the rest of your system come to a halt because the disk system can't keep up with the fragmentation.
    imac 24" 2.8, Mac OS X (10.6.2)
1 2 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.