Skip navigation
This discussion is archived

10.6.3 mouse cursor freezing

10242 Views 11 Replies Latest reply: Jun 10, 2010 7:45 AM by rohanww RSS
justletmepickoneffs Calculating status...
Currently Being Moderated
Mar 31, 2010 8:40 PM
hey

just wondering if anyone is having any issues wince upgrading to 10.6.3.

i am having an issue where my mouse cursor freezes, and i lose mouse control altogther. seems to ae most when i am using firefox.

i have the last old style 15inch macbook pro just before the unibody update. and has a multi touchtrack pad.

it's so ******* annoying losing a cursor randomly.
mbp last before unibody, Mac OS X (10.6.3)
  • lostfound Calculating status...
    Currently Being Moderated
    Apr 1, 2010 11:16 PM (in response to justletmepickoneffs)
    Hi have the exact same problem. With the exact same model.

    I also have a problem with typing.

    Going into sleep mode and turning it up again will often resolve the problem. I don't like to do that everytime it happens..

    *****
    Macbook Pro 4.1, Mac OS X (10.6.3)
  • lostfound Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 1, 2010 11:20 PM (in response to justletmepickoneffs)
    Macbook Pro 4.1, Mac OS X (10.6.3)
  • Wm Graham Calculating status...
    Currently Being Moderated
    Apr 2, 2010 5:56 AM (in response to justletmepickoneffs)
    My cursor is also freezing, and this is a new issue after installing 10.6.3. I can recover only after holding restart button. Operates normally for a short while, then freezes while typing.
    687 MHz PowerPC G4, Mac OS X (10.4.10)
  • PatrickGT Calculating status...
    Currently Being Moderated
    Apr 3, 2010 3:33 AM (in response to justletmepickoneffs)
    The same here after updating to 10.6.3

    Mouse cursor freezes for about 5 sec every 1 - 2 hours. No matter what kind of software I am using.

    Here is similar thread

    http://discussions.apple.com/thread.jspa?threadID=2382651&start=0&tstart=0

    Hope Apple will do something with this.. It is quite annoying.
    MacBook Pro(4,1) 2.4GHz (Early 2008)<4GB RAM, 500GB HDD>, Mac OS X (10.6.3), [TC 500GB]+[iPod Shuffle 3gen blue 2GB]
  • msmo1 Level 2 Level 2 (240 points)
    Currently Being Moderated
    Apr 24, 2010 10:32 AM (in response to justletmepickoneffs)
    I have been having this problem since the update. I have repaired permissions, but that has not fixed the problem. I saw the suggestion to reset PRAM on restarting, and I will try that next time. Are others still having this problem? (I noticed no recent posts.)
    MacBook Pro 2.4 GHz, Mac OS X (10.6.1)
  • msmo1 Level 2 Level 2 (240 points)
    Currently Being Moderated
    Apr 25, 2010 4:46 PM (in response to msmo1)
    There is a post on this issue on the MacBook Pro board:

    http://discussions.apple.com/thread.jspa?threadID=2386414&tstart=15

    One poster solved the freezing problem by using the OSX 6.3.1.1 update of April 12th:

    http://support.apple.com/kb/DL1017
    MacBook Pro 2.4 GHz, Mac OS X (10.6.3)
  • Michael Paul Calculating status...
    Currently Being Moderated
    May 17, 2010 10:02 PM (in response to justletmepickoneffs)
    My problem is similar but slightly more messed up; not only does my mouse go out, but so does the keyboard. Worse, the entire screen freezes--the clock never changes as the minutes go by. The remedy is a hard reset. It's happened twice today, 4 times in the past 15 days.

    Really starting to get sick of this, considering this is a CLEAN install of Snow Leopard I just performed about a month and a half ago. Overall, I'm really disappointed with Snow Leopard. My wife's Mac Mini (a Snow Leopard upgrade, not clean install) reboots randomly. Twice in the past 15 days alone.

    Further, there's no error message upon reboot that says "oh hey, looks like you were forced to restart... here's some diagnostics to send to Apple." Nothing.

    Not a happy customer.

    Message was edited by: Michael Paul
    24" iMac, Mac OS X (10.6.3)
  • rohanww Calculating status...
    Currently Being Moderated
    Jun 10, 2010 7:45 AM (in response to Michael Paul)
    i have the same problem on my new mbpro. sometimes it even freezes on the login screen! I had to hard reboot 4 times and was about to give up till it started working again just now. pretty sure its a software problem in the 10.3.3 cos the mouse works fine when i boot from disk utility and repair permissions. only the problem keeps reoccuring
    what is going on apple!!!!
    macbook, Mac OS X (10.6.3)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.