Skip navigation
This discussion is archived

Mac Pro early 2008 boots to black screen

1921 Views 1 Reply Latest reply: Apr 11, 2010 5:03 PM by rdirkmatt RSS
dannyobrien Calculating status...
Currently Being Moderated
Apr 10, 2010 12:38 PM
Four times out of five, on average, the Mac boots to a black screen -- a 30" Cinema Display.

I believe the computer is booting all the way up, because I have the front power button set to put the computer to sleep, and when I manually power down the machine using the power button, the Mac will go to sleep first.

Also, the Mac will go into Firewire disk mode when connected to my MacBook.

The "boot-to-black-screen" occurs from cold or warm boots.

I've tried both 10.5 and 10.6 OS -- no difference, results the same on both.

Here's what I've tried:

Reinstalling and updating OS both 10.5 and 10.6
Diskwarrior
PRAM zap
Pulling all USB and firewire peripherals off the computer (except the Apple Wired Keyboard that shipped with the PC) -- Mac promptly booted to black screen, so peripherals are not the issue.
Changing displays (in this case, a Samsung 17") -- same result

I have tried booting to the Apple Hardware Test on my commercial Leopard DVD and Snow Leopard DVD, but the machine will not boot to this (the Leopard disk will boot the AHT on other Macs). I no longer have the original CDs that shipped with the Mac.

I've suspected the video card, but according to other posts, apparently this is not the cause.

I'm now suspecting a motherboard firmware issue.

Before this, the Mac Pro was having a related issue pertaining to VMWare Fusion, wherein the Mac would occasionally not wake from sleep, logging a VMWare Fusion kernel crash.

For the moment, I'm not shutting down the Mac Pro, just turning off the Cinema Display. I've left this computer running for up to two months without a reboot, so I'm confident that it will stay up and remain stable.
Mac Pro early 2008, Mac OS X (10.6.3), MacPro 2008, 8-core 2.8, 14 GB RAM, ATI 2600
  • rdirkmatt Calculating status...
    Currently Being Moderated
    Apr 11, 2010 5:03 PM (in response to dannyobrien)
    I'll watch to see if you get an answer. I have a late 2008 Mac Book Pro 15 with the same problem. It boots xp good every time. But I often need to use external monitor to gain control of the OSX boot. It gives tone, shows gray, shows apple and gear the short blue and then strait to black and front LED seems to indicate sleep. Very frustrating. Happens on both use best graphics and conserve battery display settings. Tried the reset pram, safe boot, save boot verbose. All no good.
    MacBook Pro Late 2008, Mac OS X (10.6.3), bootcamp xp sp3

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.