Skip navigation

iPad getting wrong IP address from router?

44877 Views 24 Replies Latest reply: Sep 9, 2013 11:18 AM by Design Ninja RSS
1 2 Previous Next
Golfboy Level 1 Level 1 (0 points)
Currently Being Moderated
Apr 10, 2010 12:34 PM
Greetings, all.

I have a Netgear 11g router and connect just fine with my wireless laptops - IP addresses on the laptops are in the expected range (192.161.1.2-50 DHCP provided). All internet works fine.

So now I've just bought an iPad. It sees my named network, connects via DHCP successfully but the IP address listed by the iPad is not what I expected! It reflects 169.254.235.xxx (which is not the external ip, either).

I've tried many of the tricks listed on this site - Am broadcasting only 11g... have tried hardcoding static addresses... am a foot away from router... have done a refresh/reboots... but nothing works. Even tho the wireless connection appears in the menu bar, no apps can access the internet.

Help me Obi-wan. Why am I getting a different IP address than what I have enabled? You're my only hope.
ipad, Other OS, ipad
  • SteveCWatkins Level 1 Level 1 (60 points)
    Currently Being Moderated
    Apr 10, 2010 1:10 PM (in response to Golfboy)
    I'm nit totally sure about this, but it seems to me that the range you're getting is a default, placeholder IP range that the device defaults to if it is unable to negotiate an address from the DHCP server. Usually if i'm having trouble getting a DHCP address, it's due to RF interference of some kind. Try changing channels on your router (instead of Auto, try 1, 6, or 11). Or the router may just require a power cycle (unplug it, count to 30, plug it back in). After the power cycle, tell the ipad to "forget this network", and then try reconnecting.
    iPhone 3GS, iPad 32gb WiFi, iPhone OS 3.1.3
  • ninja_pimp Level 1 Level 1 (15 points)
    Currently Being Moderated
    Apr 10, 2010 1:11 PM (in response to Golfboy)
    that 169...means its not getting a real IP address
    bounce your router (reboot it)
    for whatever reason the ipad can't connect to the router hence it gets 169

    i would say its an issue with the router.

    will ipad connect to another wifi? if yes, then its your router!
    Intel i7Core 965, Windows 7
  • coppertrail Level 1 Level 1 (45 points)
    Currently Being Moderated
    Apr 10, 2010 1:45 PM (in response to ninja_pimp)
    This is what you'll get (at least in Windows) when your client can't obtain an IP address from the DHCP server. If you are getting this address, I'm willing to bet that you have no internet connectivity. You could manually enter your newtork settings and give the device a static IP address outside of your router's DHCP range of addresses.
    iPad WiFi 64 GB, Windows XP Pro
  • DMangus Level 1 Level 1 (70 points)
    Currently Being Moderated
    Apr 10, 2010 6:25 PM (in response to Golfboy)
    See if you have MAC address filtering on your router. Seems strange that your DHCP server is correctly giving out ip addresses to your other devices but not your iPad.

    Also, VERY long shot but make sure you are connecting to the right SSID, neighbors router might not give out an ip to your device
    Apple, iPhone OS 3.1.3
  • Biggerbyte Calculating status...
    Currently Being Moderated
    Apr 11, 2010 6:16 PM (in response to Golfboy)
    It is NOT a problem with your router, folks. I had this with my iPad before taking it back, and I have always had this issue with my iPhone. There is some sort of incompatibilty issue if you set your router to something other than a single standard. My phone can either show it is connected, but with this weird ip address, or show connected with no ip address at all. In both instances, I have no Internet access. Resetting network settings in the phone, and a hard reset corrects all of the above until it happens again. With some routers, however, nothing I try allows me to get Internet access, in spite if the fact that my phone says I have wifi. When I saw the iPad having the same behavior, it went back to the store without hesitation. Yes, I could set my home network to single band, but I need dual band in my home... I'm not willing to put up with this, especially when I have zero issues with all of my non-Apple devices.
    Dell XPS 420, Windows Vista
  • javabean161 Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 15, 2010 9:02 AM (in response to DMangus)
    The MAC filtering tip worked for me. Turns out I saw a MAC address on my network which I didn't recognize and filtered it out of the network. Later when I came back to use this network about a week later I was getting connected to the network with the correct SSID but the wrong IP address ranges.

    The iPad was reporting an IP address of 192.168.1.3 when the network was really running 192.168.0.xxx.

    Checked the router, found the MAC filter and removed it, then renewed the lease on the iPad and got a valid IP address. Weird way for the iPad to behave - I would have expected that it wouldn't have connected in the first place.

    Thanks for the thought.
    iPad, iPhone OS 3.1.3
  • Fusionizer Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 24, 2010 2:47 PM (in response to javabean161)
    This is definitely NOT your router.

    I have two iPads in my hands. Both brand new. I also have two iPhone 3GSs in my hands. Both iPhones connect to my wireless without problem as does one of the iPads. The other iPad gets the 169...ip and will not connect.

    The iPad that will not connect works fine at my house, as do the other devices. Riddle me this one Batman.
    MacBook Pro, Mac OS X (10.6.3), iPhone 3GS iPad
  • Fusionizer Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 24, 2010 2:54 PM (in response to Fusionizer)
    I rebooted the router and it works fine now. Isn't that the first thing I should have tried : )
    MacBook Pro, Mac OS X (10.6.3), iPhone 3GS iPad
  • ArmyOfOne33W Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 25, 2010 10:29 AM (in response to Fusionizer)
    One other thing I can suggest is to use a static IP. Its very easy to setup. I use MAC filtering and static IPS for all devices on my Airport Extreme. My iPad never has a problem connecting this way. Its very simple to turn off DHCP and go to each computer/device and set its IP address to a static one.
    24" iMac, 15" MacBook Pro, iPhone, iPad 64G - 3g, Mac OS X (10.6.3)
  • mminardo Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 17, 2010 6:35 PM (in response to Golfboy)
    You should also triple check that your password is typed in correctly. The device will not give you an error message but appear to connect to the network and take on the fake 169 IP address. Once the correct password was entered connection was successful.
    MacBook Pro, Mac OS X (10.6.4)
  • JimHdk Level 7 Level 7 (21,750 points)
    Currently Being Moderated
    Sep 17, 2010 8:35 PM (in response to mminardo)
    mminardo wrote:
    You should also triple check that your password is typed in correctly. The device will not give you an error message but appear to connect to the network and take on the fake 169 IP address. Once the correct password was entered connection was successful.


    This is incorrect. If an incorrect password is entered you will receive an error message indicating that a connection to the network could not be made. The 169.xxx IP address is a self-assigned IP address. This occurs when an IP address cannot be obtained from the router via DHCP. The purpose of the self-assigned unique IP address is to permit local networking of computers without requiring a DHCP server. This technique is used by the Windows and Mac operating systems.

    Of course, as you suggest, a password should be carefully checked for correctness with the realization that these passwords are case-sensitive.
    IPad 64GB, iPhone OS 3.1.3
  • jdube Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 28, 2010 2:35 AM (in response to mminardo)
    My problem was wrong password,I have no idea why it appears connected when it is not.
    ipad
  • oisee Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 5, 2011 9:13 AM (in response to Golfboy)
    Looks like I figured it out why iPad is so unpredictably stubborn sometimes. And I have found a real solution (not such pseudo-solutions as "turn off autobright" or "autofill").

    The reason of getting 169.x.x.x ip is that router's DHCP-server is too slow for the jumpy iPad, and the server cannot give the iPad a correct ip (something like 192.168.0.x) quickly. So the jumpy iPad makes decision to get itself a 169.x.x.x.

    The reason why router can't manage to do it is: it's busy with other tasks.

    *And that is why the full router-reset can help for a while.* When the router's RAM gets busy with junk tasks results in DHCP low performance, so it's too slow for iPad's DHCP client. And that's why getting new modern AirPort Extreme helps too.

    *So, the real solution is:* speed-up the DHCP-server on your good old router (installing latest firmware), OR just set up another DHCP-server in your subnet.

    For example, I have a NAS (DNS-323), and i just turned on its DHCP-server and the 169-problem was just gone. It (DHCP-server) runs so fast, even for the jumpy iPad.

    The subnet config is: good old router D-Link DI-642 192.168.0.1 (with DHCP-server's range: 192.168.0.100-199), NAS D-Link DNS-323 192.168.0.100 (with DHCP-server's range: 192.168.0.200-254).

    So, now iPad just gets its ip from the fastest (second) DHCP server: 192.168.0.200.

    You can set up second DHCP-server on your macBook or somewhere/somewhat else.
    macBook, Mac OS X (10.6.7), 2.1
1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.