Skip navigation
This discussion is archived

Bootcamp 3.1 wont install

42969 Views 45 Replies Latest reply: Apr 15, 2010 8:27 AM by SaltyDogLLC RSS
  • damnidunno Calculating status...
    Currently Being Moderated
    Feb 10, 2010 8:14 PM (in response to ericandrews)
    the installer keeps crashing on me as well.
    macbook pro 13" late 2009, Windows 7
  • ericandrews Calculating status...
    Currently Being Moderated
    Feb 16, 2010 2:20 PM (in response to ericandrews)
    I gave up on trying to do the update and stated from a fresh Win7 install...

    1) Backed up and Blew away existing Windows 7 x64 Partition in Boot Camp
    2) Created new partition in BootCamp and Reinstalled Windows 7 Pro x64
    3) Installed BootCamp 3.0 from Snow Leopard Disk
    4) Ran Bootcamp 3.1 updater - NO ERRORS this time
    5) Reconfigured Refit to Boot Win7 as Primary OS
    6) Restored all Apps and Data back to Windows

    Can you run Windows 7 as the only OS on the MacBook system? i.e. NO bootcamp?
    13.3" MacBook Pro, Mac OS X (10.6.2), Windows 7 in Bootcamp as primary OS
  • Kittenmommy Level 3 Level 3 (645 points)
    Currently Being Moderated
    Feb 16, 2010 2:22 PM (in response to ericandrews)
    ericandrews wrote:


    3) Installed BootCamp 3.0 from Snow Leopard Disk


    That's the part I can't get to work. When I insert my Snow Leopard disk, it asks if I want to use it to install OS X over a network onto another computer. It doesn't show me a Boot Camp installer or any way to run it.
    MacBook 2.2GHz Intel Core Duo processor (white), Mac OS X (10.6.1), 120GB HD, SuperDrive, 1GB RAM, 1TB external HD
  • ssn637 Level 1 Level 1 (30 points)
    Currently Being Moderated
    Feb 21, 2010 2:02 PM (in response to jlpek17)
    jlpek17

    Salut
    I tried to create a stand-alone .msi executable of the 32-bit version of Boot Camp V3.1 according to your instructions, but when attempting a clean installation I received an error message that a .dll file could not be found within the Bootcamp.cab archive. Upon restarting, I noted that the BootCamp folder was not present under Program Files. The RealTek drivers were also installed, although my MacBook Pro uses the Cirrus Audio hardware. So I went back to installing V 3.0 and then updating to 3.1, after having deleted all the drivers in the V 3.0 folders (except for Apple Software Update). The RealTek drivers are still listed under Installed Programs, but at least everything seems to work.
    I guess the best thing to do is wait until a retail DVD version of Mac OS X 10.3 becomes available and see if a standalone installer is available.
    MacBook Pro Unibody 13", Mac OS X (10.6.2), Boot Camp Windows 7 Ultimate
  • ssn637 Level 1 Level 1 (30 points)
    Currently Being Moderated
    Feb 22, 2010 12:16 AM (in response to ssn637)
    jlpek17

    You mentioned in your post that a method is available to perform a selective installation of the Boot Camp drivers, so that we could for example skip installation of the RealTek drivers. Could you please let us know how to do this? Then I could run the BootCamp V3.1 x86 update using this procedure and disregard those drivers which aren't needed.
    Merci beaucoup pour ton assistance!
    MacBook Pro Unibody 13", Mac OS X (10.6.1), Boot Camp Windows 7 Ultimate
  • ssn637 Level 1 Level 1 (30 points)
    Currently Being Moderated
    Feb 22, 2010 2:23 AM (in response to ssn637)
    I was able to modify the BootCamp.msi file created using jlpek17's procedure using a utility called Orca, which I found by doing a bit of googling. I simply deleted the installation sequence lines from the appropriate table using the editor, leaving only those drivers which applied to my system. However, after running the modified installer the BootCamp.exe file in Program Folders had not been updated to V3.0.1. I had to manually replace the files from the Source Folder (Program Files & system32) to the Windows directory prior to restarting and everything worked just fine!
    Thanks for your help!
    MacBook Pro Unibody 13", Mac OS X (10.6.1), Boot Camp Windows 7 Ultimate
  • jlpek17 Calculating status...
    Currently Being Moderated
    Feb 22, 2010 3:47 PM (in response to ssn637)
    Hi,

    If you use my method in order to create the bootcamp 3.1 standalone installer you could see that you new BootCamp.msi is very large (more than 200mo). It's normal because all the drivers are included.

    But if you would not install all this drivers :

    (0 - Use my previous method to make a standalone installer of Bootcamp 3.1)

    1 - Do an administrative install of The bootcamp 3.0 from your Snow Leopard CD according from my previous post but without the use of the *.msp file.

    2 - Then, you can grab from it the new Bootcamp.msi (Ver 3.0)

    3 - Replace the Bootcamp.msi (0) by this new one (2)

    4 - Delete the Administrative Install of BootCamp 3.0 that you create (1)

    PS : If you look at the version in the bootcamp aplication you will see that you have 3.0 but in fact you have the 3.1.
    If you are not sure, you can check that with right click on bootcamp *.sys files in the "bootcamp" and "Windows/system32/" directory.
    I'm prety sure that the "about bootcamp" windows is a picture store in the bootcamp.msi

    4'- After that you have to install all your drivers (for my iMac 27 I have 10 drivers + Intel Chipset Drivers; for my iMac 24 I have 8 drivers + Intel Chipset Drivers)
    iMac 27, Mac OS X (10.6.2)
  • ssn637 Level 1 Level 1 (30 points)
    Currently Being Moderated
    Feb 23, 2010 5:35 AM (in response to jlpek17)
    Thanks again for all your help, jlpek17!

    I have copied the BootCamp.exe and System32 (.dll and Apple*.exe) files left over in the SOURCE directory and overwritten those installed originally from the BootCamp.msi program (which is indeed around 280 MB once it's been patched with the .msp updater) just to be on the safe side. But otherwise I'm very grateful to you for having offered your solution for a stand-alone Boot Camp V3.1 installation.
    MacBook Pro Unibody 13", Mac OS X (10.6.1), Boot Camp Windows 7 Ultimate
  • jlpek17 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 23, 2010 9:49 AM (in response to ssn637)
    Hi,

    After you create an administrative Install of Bootcamp the *.msi file it's just an "address book" which say where are the files to install and where it have to copy (here the "bootcamp" and "windows/sytem32" directory) but it contains also some non-important resources such as jpeg for the installer or the "about bootcamp"directory and the *.reg file in order to register the bootcamp services.

    So I think use my second method (BootCamp 3.1 standalone installer without the drivers) is safe and regular.

    I think that Apple don't do much in order to say "Windows 7 compatible" : The only problem it has before is the Magic Mouse stop react ; and the Optical Audio-Out which was always On. But if you just install the new "Broadcom Apple Bluetooth Driver" and new "Cirrus Audio Driver" this problem disappeared.

    For my iMac27 I did :

    1 - I installed BootCamp 3.0 from Snow Leopard Disk from my iMac_27
    2 - After reboot I Copy all the drivers which was newly installed in "Windows/System32/DriverStore/FileReposotory" Class the directory by Date and you will know wich was just installed so you could not be wrong"
    3 - Match all the drivers which really used and delete other (pay attention to certain because it's tricky ; a lot are useless because windows has it's own)
    3 - Then I installed BootCamp 3.1 Update
    4 - Re-do (2) and (3) and check and replace which are updated like "Cirrus Audio Drivers for example"
    5 - Then reinstall Windows 7 with my BootCamp 3.1 Standalone Installer and More Up To Date Drivers
    6 - I Think my system approach the perfection and it has because Snow Leopard it's very good optimized
    iMac 27, Mac OS X (10.6.2)
  • TheDomo Calculating status...
    Currently Being Moderated
    Feb 24, 2010 4:52 PM (in response to junkboxjayy)
    In Conclusion to my problem which has been the most asked question it seems but no real straight up answers that were simple were given.

    I was running Windows 7 on my 21' iMac (Late 2009) Bootcamp 3.0 and I could not update it via Software Update or direct download. I read on here it need to be extracted via Windows RAR clicking .MSP (But you must UNINSTALL Remote Login Programs like "BackToMyPC" or "LogMeIn" anything remote controlling software.)

    I found even some Verizon FiOs software was not helping me. Once that was done. I restarted in Windows. opened the MSP file and hit repair it did not ask for update of anykind.( Just said Repair or Remove) It installed the drivers, restarted it and magically. It was now 3.1

    1. Uninstall Remote Controlling Software (May Include FiOs software) restart after.
    2. Found it easier to Open with WinRAR and open the .MSP File.
    3. Opened file and hit Repair
    4. Restarted and It was done.

    Conclusion: The Audio and network issues were fixed thanks to everyone who helped in pieces.. It was confusing as heck.. to read everyones explanations... but it helped a lot with every other few posts being easy to understand.


    Message was edited by: TheDomo

    Message was edited by: TheDomo
    MacBook 3GHZ, Mac OS X (10.4.11)
  • mattnotley2004 Calculating status...
    Currently Being Moderated
    Mar 2, 2010 5:33 PM (in response to junkboxjayy)
    I had trouble installing BootCamp 3.1 on ALL our Mac's running Windows 7. Nothing would happen. The installer wouldn't even load.

    After reading this forum... I uninstalled all remote control programs (Radmin, BackToMyPC, LogMeIn) and rebooted the computers. This time the installation worked perfectly!

    I'm running BootCamp 3.1 no problems!
    Apple MacBook - 13-inch: White, Mac OS X (10.5.7), 2.4GHz Intel Core 2 Duo, 2 GB memory, 160GB hard drive
  • klankrno Calculating status...
    Currently Being Moderated
    Mar 4, 2010 9:33 AM (in response to Squash Willy)
    Squash Willy wrote:
    We successfully installed Boot Camp 3.1 to multiple iMacs running Windows XP/Leopard by uninstalling LogMeIn and running the downloaded exe update program.

    The error message we had before we had before the install was "Boot Camp Update Installer has encountered a problem and needs to close."


    Same Here. However please note that you may have to manually "uninstall" the LogMeIn video driver.
    Macbook Pro, Windows Vista
  • sharptastic Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 12, 2010 4:06 PM (in response to junkboxjayy)
    Hi there,

    I have a late 2007 white MacBook, 2.4GHz, with 2GB of RAM.

    I just managed to fix the issue of Bootcamp 3.1 constantly appearing in Software Update on my Windows 7 64-bit machine. After I had successfully installed Bootcamp 3.0 (by right-clicking on the Bootcamp64 installer on my Snow Leopard install disk and selecting "Troubleshoot compatibility), I originally used the standalone updater for 3.1 which I downloaded from http://support.apple.com/kb/DL979. I think this is what caused my issue, as whenever Software Update would run it would not detect that I had 3.1 installed.

    This solved the issue for me:

    - Uninstall Bootcamp from Add/Remove Programs
    - Install Bootcamp 3.0 from the OS X install disc and reboot
    - Run Software Update to install Bootcamp 3.1, NOT THE STANDALONE INSTALLER

    After doing this, Bootcamp 3.1 no longer appears when I run Software Update.

    Hope that helps someone!
    Macbook (White, 2.4GHz, late 2007), Mac OS X (10.6.2), Intel GMA X3100 Graphics, Mini-DVI display out
  • Mangid Calculating status...
    Currently Being Moderated
    Apr 7, 2010 12:34 AM (in response to ihsd)
    I can confirm that extra display drivers cause the 3.1 install to crash @ startup. I had a couple of Live Mesh drivers, unisntalling these allows the 3.1 install on my Mac Pro

    --
    Mangid
    IPhone/MacBook Pro, iPhone OS 3.1.3
  • tbharber Calculating status...
    Currently Being Moderated
    Apr 10, 2010 3:40 PM (in response to junkboxjayy)
    I had this issue as well and lIke others have mentioned the problem was the logmein display drivers. Uninstalling the program was not enough. After that you must go into the device manager to uninstall the logmein display driver manually. After doing this the install worked perfect.
    Macbook, Mac OS X (10.4.6)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.