Skip navigation
This discussion is archived

New 27" iMac - No AirPort card installed

17782 Views 15 Replies Latest reply: Jul 23, 2010 10:19 AM by dr_zoidberg RSS
1 2 Previous Next
digitalformula Calculating status...
Currently Being Moderated
Nov 22, 2009 12:47 AM
I just got my brand new 27" iMac today - big day for me as I'm switching to Mac from PC/Windows ...

Anyway, powered on and the AirPort card doesn't seem to be installed - the status thing, which I've managed to show, says "No AirPort card installed".

I'm aware that a couple of other people seem to have had the same issue and that it appears to be either the AirPort card being completely missed at build time or it not being seated properly. Re it not being seated properly, is this something I can check myself without blowing the warranty? I'm in IT so I'm comfortable doing it but not if my warranty will go out the window ...

What's the deal here? Is this a problem at the Apple factory that is common on the 27" iMacs? Does anyone know if Apple is aware of it?

With Apple supposedly being so awesome I'm pretty disappointed about this as I'm sure the vendor I got it from will say sure we can fix it but you've got to send it away ... after <24 hrs ownership.
27" iMac, Mac OS X (10.6.1)
  • Michael Lafferty Level 6 Level 6 (16,080 points)
    Currently Being Moderated
    Nov 22, 2009 6:38 PM (in response to digitalformula)
    If you purchased your machine from an authorized Apple dealer, there is no reason for them to facilitate the repair by shipping it to Apple for service. They can deal with the issue in their facility, and are reimbursed for such warranty service by Apple.

    Without the required special tools, experience and appropriate documentation, you should NOT attempt to remove the thin glass panel, a step which is required to to gain access to internal components such as your AirPort card and antenna.
    PowerBook G4 12 inch 1.5 GHz 1280 meg 80 gig SuperDrive, Mac OS X (10.4.11), coupled with a UMA-capable Nokia 7510 Supernova and T-Mobile HotSpotâ„¢ @Home
  • Abdoul Calculating status...
    Currently Being Moderated
    Jan 13, 2010 7:23 AM (in response to digitalformula)
    Hi i had the same problem but worse i bough my new iMac from the apple store in london the new 27'' i didn't open my iMac because i was traveling to Dubai so i took it with me and i had the same problem no airport card installed so i am not sure what to do now do i have to bring it to apple again or can i solve the problem online or with an update? please help!!
    iMac 27", Mac OS X (10.6.2)
  • Davoid Calculating status...
    Currently Being Moderated
    Mar 16, 2010 7:49 AM (in response to digitalformula)
    I also received an iMac 27 inch unit yesterday sans Airport. I purchased it from the online Apple store. A call to Apple Care and 20 minutes later I received an RMA# and prepaid FedEx shipping label via email. While Apple may have some quality control issues in Shanghai, customer service is still very good. Once the Airport deficient iMac enters the FedEx shipping system, Apple will be notified and a replacement will be shipped FedEx Express. I just dropped off the network challenged iMac at FedEx a few minutes ago. We'll see what happens from here.
    iMac 27 inch, Mac OS X (10.6.2)
  • Ull Calculating status...
    Currently Being Moderated
    Mar 30, 2010 7:43 AM (in response to digitalformula)
    My 27'' iMac Had the same issue. I've repaired my myself - one of the connectors became loose ( flat black ribbon). I am a final year engineering student so for me it was an easy fix. Hope that doesn't void Apple warranty. I tried my best not to leave sights of my presence inside =))))
    MacBook Pro 17", 27" iMac i7, Mac OS X (10.6.2), iPhone 2G 3.1.3, iPhone 3GS 3.1.3
  • steve.vid Calculating status...
    Currently Being Moderated
    Apr 12, 2010 2:32 PM (in response to digitalformula)
    I too had the same problem. Purchased my IMac 27" from the Apple online store.



    On start up no airport icon showing and no option for it when I went into network, but in system profiler all the info was there for the card, soft ware revisions etc.



    After 2 calls with the support teams, during which I had to wipe my hard drive and re install the operating software (as apparently this can sometime sort out the issue) I was told that it looked like I was only the third customer this person had ever dealt with that had had this problem.



    I am now waiting for a RMA and details for the pick up of my faulty IMac and another 2 weeks for the replacement as I opted for the 2.8 processor and 2TB hard drive.



    Absolutely gutted!!
    MAc Book Pro, Mac OS X (10.4.8)
  • DaRat Calculating status...
    Currently Being Moderated
    Apr 16, 2010 4:48 AM (in response to digitalformula)
    I just got my 27" iMac yesterday, and it claims that no Airport Card is installed. I'm vaguely comforted that other people have seen the same issue.

    I'm not pleased in the slightest, but I am hoping that a software update to 10.6.3 will fix the issue. I really don't want to send the machine back and wait 2-3 weeks to get a new one.
    iMac 27", Mac OS X (10.6.2)
  • DaRat Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 16, 2010 5:04 AM (in response to DaRat)
    Going to 10.6.3 didn't help. So, for me, it's a hardware issue.
    iMac 27, Mac OS X (10.6.3)
  • Wesley Sutton Calculating status...
    Currently Being Moderated
    Apr 17, 2010 11:33 AM (in response to DaRat)
    Received a refurb 27" i7 this morning. Opened it, turn it on - no airport found. Call to Apple and they tried to resolve via downloading 10.6.3 over ethernet. No dice. Escalated to senior account rep who tried booting with install DVD, no dice. Wanted me to drive it an hour and a half to the nearest Apple store, which I declined. Finally put me through to another rep who has offered to have me ship back and they would replace - only that one isn't in stock so I'd get the next model up. I asked to explain what that might be, since there isn't a next model up from this one...she seemed perplexed then said they'd make sure it was an I7, but didn't currently have. Might ship a new one. Waiting to see...
    PowerMac G5 Dual 1.8/ iMac G5 20" 2.1/ iBook G4 1.42 14", Mac OS X (10.5.8)
  • Ron in Berkshire Calculating status...
    Currently Being Moderated
    May 4, 2010 2:25 PM (in response to Wesley Sutton)
    Wow. I'm in the same boat! I received my iMac i7 27" today and have exactly the same issue. No airport card recognised. I am shipping mine back. Hopefully, they'll sort something out for me.
    MacBook Pro 2008, Mac OS X (10.6.3), 4 GB RAM 2.5GHz Intel
  • imactopher Calculating status...
    Currently Being Moderated
    Jun 4, 2010 2:38 PM (in response to digitalformula)
    Looks like this issue has hit its fair share of people. Spoke to Apple support today about the same issue. Brand new iMac 27' 2.8 quad core with 8gb of ram and I opened the box only to find my airport card was not recognized by OSX. After performing several support steps, the staff let me know that this was indeed a hardware related issue - I am not advocating this is everyone'e issue just mine.

    Here is what we did to troubleshoot and determine it was hardware related.
    Open system profiler / go to network and look at airport - if all you see is "software versions" your hardware is not recognized. You will need to reboot the system and clear the SMC. To do this do the following:
    Unplug everything from your iMac and wait 60 seconds with absolutely nothing connected to it. After that, plug in your power cable and press the power button down, letting it go after 2 seconds. Immediately after the power button is let go - hold down option + apple + p + r you will hear 2 "bong" sounds, then let go of the keys and boot. If your hardware does not show up you will need to boot to the OSX install DVD to get a "clean" install of OSX.

    Boot to OSX DVD
    Insert DVD
    Shut down system
    Power on system - hold down C key until you hear a chime then let go. System will boot to OSX install.
    Once you pass all the prompts by selecting defaults, you will come to "Install MAC OSX" asking you to select the disk where you want to install. DO NOT CLICK INSTALL. Open Utilities / System profiler. If you still do not see anything under Airport other than software, your Airport card is bad or at the very least not showing up in the OS. If you do see the airport card there, you will need to reinstall the OS to have it recognize the card.

    Hope that helps!
    iMac 27', Mac OS X (10.6.3)
  • J Beau Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jun 5, 2010 12:56 PM (in response to imactopher)
    I just got an iMac 27" two weeks ago, and because of this thread I decided to check out the AirPort utility to see what happens. I get a message which says, "Airport Utility was unable to find any AirPort wireless devices..."

    I am assuming that because I get this message-- and the fact that the computer has been working properly with my WiFi router since minute one-- that means that I do have an AirPort card and it seems to be working properly. Is this correct? -J. Beau
    iMac dual quad i5, Mac OS X (10.6.3)
  • app_atti Calculating status...
    Currently Being Moderated
    Jul 2, 2010 11:17 AM (in response to digitalformula)
    Seems like this is a common problem. Got my new imac yesterday. Cannot connect to our home Airport Express network. imac says "No Airport Card Installed". Shows up in system profiler but not in internet connect. Will try checking airport and/or reloading OS from disk. Then I guess I'll stop payment on CC and complain loudly to Apple until they fix it. Wonder how many hoops I'll have to jump through and how many hours I'll have to spend on the phone this time!.

    Message was edited by: app_atti
    imac, Mac OS X (10.6.4)
1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.