Skip navigation

2.4GHz Core i5 - Frequent hangs in multiple apps, no console message

150044 Views 441 Replies Latest reply: Dec 18, 2011 3:37 PM by Del Lardo RSS
1 2 3 ... 30 Previous Next
iRuney Calculating status...
Currently Being Moderated
Apr 21, 2010 8:08 AM
So, here's what I'm experiencing. It's pretty easy to describe because I haven't been able to find any common element, which is why I am here.

These are *the facts*:

~ (added) I forgot the most important part! My old C2D was working flawlessly, and there's nothing on this new laptop that wasn't on my C2D, except the security update that was released a short while ago.

~ I get fairly frequent beach balls, in multiple applications. These far exceed (in both frequency and duration) what would be considered normal, and what was normal on my 2.4GHz C2D.

~ I get fairly frequent system hangs, originating in multiple applications (which usually starts as a beach ball). In this scenario, everything literally stops, excepting my mouse cursor will still move. I have no visual feedback from anything on the screen at all, and the laptop does not appear to accept or queue any keyboard, trackpad or mouse input.

~ I have not seen any consistent console error message associated with this. In fact, oftentimes there are no messages in the last several minutes prior to and following the phenomenon.

~ I freshly installed the machine upon receipt, and later realized that it had actually only performed an archive and install. I have reset the PRAM, performed a disk repair, and ran a full Cocktail. I have also ran Techtool Deluxe and the hardware test, all with no errors. None of these seemed to have any affect at all.

~ I have tried picking and choosing applications to have running, and to have closed. I have tried turning off the hard disk sleep. I have tried turning off the automatic graphics switching. None had any affect.

~ My resource usage when this occurs varies from very little, to very much. CPU and RAM, at the least, don't appear to be related.

Alright. Now that we have the facts out of the way, let's get to some more obscure *observation and speculation*:

~ This seems to occur in greater frequency when: playing World of Warcraft, shortly after waking from sleep, or when performing large file transfers. However, it also occurs when none of the above are true. Could this indicate that it is related to the hard drive?

~ It almost seemed like this was related to specific software, but as I noted above, I've tried every combination of apps imaginable, and the problem persists.

~ I have seen on two occasions, an error message in console that is generated by different applications (notably Safari and Mail), called INSERT-HANG-DETECTED. If I get the error again I'll post it here, but the error is already out of my logs. In any event, it has not occurred with regularity, but I thought it was worth mentioning.


The biggest mystery to me in all this is that console reports nothing when this happens. It seems like something so severe that it causes the entire system to hang would at least generate a message.

I am at my wit's end on troubleshooting this, beyond just taking days or weeks to try to pin down a cause. I just spent an entire day Monday getting this laptop set up, and I am truly loathe to reinstall.. again.

Any help or advice is appreciated, including any assistance with troubleshooting, or anyone who can report the same phenomenon. These new i5 processors are amazingly fast on benchmarks, but may as well be the slowest processors on earth if my computer keeps hanging like this.
MacbookPro6,2, Mac OS X (10.6.3), HR Glossy Display
  • Mac Medic ( Level 6 Level 6 (17,290 points)
    Could this indicate that it is related to the hard drive?

    Yes. I would try and get Apple to replace the drive and go from there.

    Check out the new remodeled MacOSG website! 24-hour Apple-related news & support.
     MacOSG: An Apple User Group  iTunes: MacOSG Podcast  Follow us on Twitter: MacOSG

    3.33Ghz 21.5" iMac • 500GB HD • 8GB RAM, Mac OS X (10.6.3), 1.6Ghz MacBook Air • 3 iPods • iPhone • AppleCare
  • lhotka Calculating status...
    Time Machine restore simply isn't reliable. Use SuperDuper or Carbon Copy Cloner instead. I just did it a while ago, and many preference files weren't restored.

    I'm having this issue with my i7 as well - frequent beachballs whenever there is significant disk activity. I've tried replacing the hard disk with an aftermarket one, and had no difference.
    Mac Book pro, Mac OS X (10.6.3)
  • Stephane7728 Calculating status...
    I've got the exact same hangs on my new MacBook Pro 15' Core i5. They last 5 to 15 seconds and then back to normal. (no console message either)
    I've tried many things without success . (Onyx, Disk Utility, TechTool Deluxe, Disk repair with Mac OS X DVD ....)
    I've noticed that the option "use secured Virtual Memory" is on ...
    I'll try with this option off ... and get you informed.

    Maybe it's the same "beep and click" hangs that was on the previous generation of macbook Pro with the 7200 RPM momentus disks ...
    Apple fixed it with a firmware update ...
    Wait and see ...
    MacBook Pro 15 ' 2,4 Ghz Core i5 320 Gb HDD, Mac OS X (10.6)
  • gomolld Calculating status...
    I have the exact same thing going on here. Frequent beachballs occurring - 10 to 20 second system hangs. Seems to happen most often when switching apps.

    Message was edited by: gomolld
    MBP 2.53 i5, 7200 500gb, HR anti-glare, Mac OS X (10.6.3)
  • gomolld Level 1 Level 1 (0 points)
    I haven't seen any other topics like this one - apparently the issues we are experiencing are not wide spread. Time to start exploring other possibilities here I guess. I'm hoping this won't end up with me having to reformat and/or reinstall.

    It does seem to get better over time. Hangs are much more frequent when the machine first starts up.

    Just a few minutes ago I got three separate beach balls lasting about 30 seconds a piece when attempting to hit cmd-F (find) in Firefox. It is a system wide hang as well - if I go back to the finder it will switch but then almost immediately the beach ball will come up again and I can't go anywhere else. After a few moments all the mouse clicks/keyboard events catch up and I am good to go again.

    FYI - I did a firewire migration assistant transfer from my old late 2008 15 inch MBP the first day I got this machine. Any chance something in the system was copied over that should not have been?
    MBP 2.53 i5, 7200 500gb, hi-res anti-glare, Mac OS X (10.6.3)
  • Stephane7728 Level 1 Level 1 (10 points)
    I have the same problem as you and I didn't use migration at all.
    Whaterver I do, I have frequent beachballs for 5 to 10 seconds with NO HARD DRIVE activity at all, but I still can move the cursor. The hangs are caused by Hard Drive "Pause".
    The system is not freezed, it is just waiting for the HDD. As soon as HDD regain activity, the beachball is gone and everything is fine.
    I tried to deactivate the Sudden Motion Sensor, to see if the problem is related to it, without success.

    So I think it's a hard drive problem.
    Maybe i'll have it changed.
    MacBook Pro Core i5 2,4 Ghz, Mac OS X (10.6.3)
  • Stephane7728 Level 1 Level 1 (10 points)
    I've reinstalled Mac OSX without erasing the disk. (i didn't lost my data and user account) And it seemed to have solved the problem ... for now ... maybe it's some Mac OSX update that came after the DVD (I used the DVD in the MacBook Pro package) ...
    I'm using my Macbook pro for 1 hour, fresh boot, no hang ... for now ...
    MacBook Pro core i5 2,4Ghz, Mac OS X (10.6.3)
  • Stephane7728 Level 1 Level 1 (10 points)
    sorry ... hanging again ... it's not the solution...
    MacBook Pro core i5 2,4Ghz, Mac OS X (10.6.3)
  • gomolld Level 1 Level 1 (0 points)
    Interesting - well I guess I won't try reinstalling OSX then. Do we all have 7200 HDs? I wonder if this is a hardware issue...
    MBP 2.53 i5, 7200 500gb, hi-res anti-glare, Mac OS X (10.6.3)
  • Stephane7728 Level 1 Level 1 (10 points)
    No I have the same 5400 RPM HDD as iRuney. The standard seagate 320Gb.
    MacBook Pro Core i5 2,4 GHz, Mac OS X (10.6.3)
1 2 3 ... 30 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.