Skip navigation
This discussion is archived

Annoying Firewall Allow / Deny Dialog

27407 Views 32 Replies Latest reply: Sep 1, 2010 11:46 PM by fmLIE RSS
  • LLPP Calculating status...
    Currently Being Moderated
    Jan 14, 2010 1:50 AM (in response to KyleGawley)
    The most annoying for me were the dialogs generated by using the Finder. So, I added Finder.app to the firewall app list, and selected "Block".
    Macbook, Mac OS X (10.6.2)
  • Luis Alejandro Calculating status...
    Currently Being Moderated
    Feb 2, 2010 4:46 PM (in response to KyleGawley)
    Me too, i wish apple fix this problem in Mac OS X 10.6.3 Update soon
    Macbook, Mac OS X (10.6.2)
  • Martin Pace Level 5 Level 5 (5,075 points)
    Currently Being Moderated
    Feb 2, 2010 4:54 PM (in response to Luis Alejandro)
    In the preferance pane Security -> Firewall -> Advanced I deleted all of my Allow/Block incoming connections (essentially starting over from scratch) and that solved the issue for me.
  • fugazied Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 25, 2010 10:09 PM (in response to KyleGawley)
    Does anyone have a viable answer to this yet?

    I get the popup with firefox everytime I try to download something. I get it TWICE in a row everytime. So annoying when I am doing multiple downloads.

    I don't want to turn my firewall off. This should be a very high priority fix for Apple because it is a ridiculous bug.
    15" Macbook Pro, Mac OS X (10.6.2)
  • Amaury Vargas Level 2 Level 2 (345 points)
    Currently Being Moderated
    Mar 23, 2010 7:48 AM (in response to KyleGawley)
    same problem here.
    it started a couple months ago with JDownloader, and now Word, Excel and Powerpoint do it too.
    i configured the firewall to always allow these apps, but they insist on asking.
    Mac mini 1.83 1 GB RAM, MacBook white 2.1 4 GB RAM, Mac OS X (10.6.2), 19" LG L196WTQ Flatron Wide/Seagate FreeAgent Pro/hp psc 1210/Canon A1100 is
  • aggo Calculating status...
    Currently Being Moderated
    Mar 29, 2010 8:39 PM (in response to Amaury Vargas)
    Same with me too. Just updated to 10.6.3 and problem's still there.
    Mac Mini, 1.66 GHz Intel Duo, 2GB RAM, Mac OS X (10.6.2)
  • MadMacintosh Level 1 Level 1 (5 points)
    Currently Being Moderated
    Apr 12, 2010 8:51 AM (in response to aggo)
    I had also hoped that 10.6.3 would fix this, but unfortunately it hasn't. This is behavior we expect from Windows, not OS X.

    Message was edited by: MadMacintosh
    iMac 20", Mac Pro Quad 2.8, Mac OS X (10.6.3)
  • Lopt Calculating status...
    Currently Being Moderated
    Apr 13, 2010 4:27 AM (in response to KyleGawley)
    It does happen to me as well with many applications such as Dropbox, Skype, Vuze. I've tried everything, from removing com.apple.apl.plist to manually adding/removing allowed apps. Nothing worked, except *turning firewall off*, which I consider not to be the smartest solution. I think it's about time Apple solved that issue. Appreciate any other hints.
    iMac Intel, Mac OS X (10.6.3)
  • paul2992 Calculating status...
    Currently Being Moderated
    Apr 14, 2010 4:09 AM (in response to Amaury Vargas)
    Same here (with SyncDocs and many other apps).
    I've also configured the firewall to always allow these apps, but they insist on asking...
    Useless firewall (rules) I guess?!

    Apple, please take action.
    ScratchProneCheapWhitePlasticUnibodyMacBook,APE,TC1T,iPhone3G..., Mac OS X (10.6.3)
  • someguy2010 Calculating status...
    Currently Being Moderated
    Apr 15, 2010 2:26 PM (in response to paul2992)
    exactly the same here.

    mac os x 10.6.3
    CLEAN install

    aMSN and jDownloader keep prompting every time I start them.

    it never worked.
    not with 10.5 or any other version.
    MacBook Pro 5,3, Mac OS X (10.6.3)
  • someguy2010 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 15, 2010 2:36 PM (in response to someguy2010)
    I think I figured it out:

    http://support.apple.com/kb/HT1810

    +If you run an unsigned application not in the Application Firewall list, you will be presented with a dialog with options to Allow or Deny connections for the application. If you choose Allow, Mac OS X 10.5 will sign the application and automatically add it to the Application Firewall list. If you choose Deny, Mac OS X 10.5 will sign the application, automatically add it to the Application Firewall list and deny the connection.+

    +Some applications check their own integrity when they are run without using code signing. If the Application Firewall recognizes such an application it will not sign it, but then it will re-present the dialog every time the application is run. This may be avoided by upgrading to a version of the application which is signed by its developer.+
    MacBook Pro 5,3, Mac OS X (10.6.3)
  • paul2992 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 15, 2010 4:29 PM (in response to someguy2010)
    someguy2010,

    if so, then I guess the only way to stop all these "allow/deny" is to simply turn off the firewall...
    Not good, but better than being annoyed every time by it..

    (seems we now only need an ""AppStore" for OSX, so then all the apps will stay signed..)
    ScratchProneCheapWhitePlasticUnibodyMacBook,APE,TC1T,iPhone3G..., Mac OS X (10.6.3)
  • Jim / Turnip Video Level 3 Level 3 (610 points)
    Currently Being Moderated
    May 3, 2010 10:25 AM (in response to A*J*P)
    One thing to try. This appears to work for me, although I can't claim it's 100% reliable.

    - in the firewall settings dialog box, select the application and delete it from the list.

    - now run that application

    - it reappears in thelist, but something about this seems to update the digital signature and the pop up no longer appears.

    ::: a different workaround is to select the "only core services" setting of the firewall and not set it individually for various apps. Can be supplemented for security with Lil Snitch.
    8-core Mac Pro; 30" ACD; FCP Studio 2; Matrox MXO being rebooted often + 23" ACD, Mac OS X (10.5.8), (for SD: JVC SR-GS30 deck), DVX-100a, Sony XDCAM EX1
  • yachts99 Level 1 Level 1 (15 points)
    Currently Being Moderated
    May 13, 2010 7:04 AM (in response to Jim / Turnip Video)
    Deleting the application from the Firewall list only seems to work for the first subsequent launch of the application.

    App launches after that still pop up the window even with "Allow connections" for the app appearing in the Firewall list.
    Mac Pro 2.66 GHz Dual Core, Mac OS X (10.6.3)
  • phonotax Calculating status...
    Currently Being Moderated
    May 14, 2010 5:13 AM (in response to yachts99)
    Hi!

    I've been having the same problem with Vuze, having had to manually Allow each time when starting the program.

    I think I managed to solve the problem following the (rather convoluted) procedure describe here: http://forums.macnn.com/79/developer-center/355720/how-re-sign-apples-applicatio ns-once/
    "
    However, I had to check the "Code signing" box at step 12 of "Obtaining a Code Signing Certificate" – thus not abiding with the defaults there. Also having completed the code signing part, I also removed Vuze from the Firewall's allowed list and re-entered it, although I don't know if it was necessary.

    I probably will have to rerun the codesign command each time Vuze updates itself, but that shouldn't be so bad.

    - Kalle
    MacBookPro4,1, Mac OS X (10.6.3)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.