Skip navigation
This discussion is archived

Overscan issue with mac mini connected to Samsung LCD TV via HDMI

31173 Views 12 Replies Latest reply: Jun 29, 2010 10:54 PM by dblood RSS
reddog708 Calculating status...
Currently Being Moderated
Oct 20, 2009 7:43 PM
I have a late 2009 intel mac mini connected to a 27" Samsung LCD HDTV via HDMI.

I've read problems about overscan, which hides the menu bar, and I'm aware of the disable overscan feature in display preferences, but what that creates is an image that is too small. The menu bar and edges are visible, but then it only takes up 90% of the tv's screen, leaving an on-screen black border. So it's either too big or too little, but far from having the display end right at the edge of the screen in an acceptable manner. Is there any way of tweaking the scale of the display to do a manual overscan fix? i downloaded a trial of switchresx, but i couldn't find a solution with that either.
Mac Mini dual core late 2009, Mac OS X (10.5.8)
  • BSteely Level 5 Level 5 (7,635 points)
    No, there is no good solution from the Mac's side of things. It's best when the TV itself has adjustments for scan size. Have you checked the Samsung's user guide about PC connections? It might have something to say about this. Usually Samsungs have a setting called Just Scan or some other picture format setting that makes the screen just fit. At least that is true of their more high end TV sets. Not sure about a 27" though.
  • lee74c3 Calculating status...
    I'm looking for a similiar (same?) solution for my MacBook connected to a new Samsung 23" LED monitor. It is also connected via HDMI.
    MacBook2,1 Intel Core 2 Duo, Mac OS X (10.5.3)
  • nmassello Level 1 Level 1 (25 points)
    If your TV doesn't have a dedicated computer (DVI or VGA) input, check the forums at the AV Science Forum web site to see if anybody has posted instructions for your set's service menu that might let you to reduce the overscan for the HDMI input.

    <http://www.avsforum.com>
    Macmini2,1, Mac OS X (10.5.8)
  • lbenes Calculating status...
    I fixed my overscan issue when connecting my ATI video card to my Samsung LCD TV by going to:
    menu->picture->picture options->size
    And changed the size from the default of 16x9 to "Screen Fit"

    Now the text is razor sharp and fills the screen completely without having to tweak the overscan or underscan options in the CCC driver options.

    Thanks for all your help out there!
    Windows XP Pro
  • tom123456789 Calculating status...
    I have a new mac-mini (intel 2.53ghz 4gb). It is connected to a late 2009 model samsung 7 series (750) and I like many others are experiencing the text issues that other people are talking about. I'm connecting with a mini-dvi to dvi and then using a belkin dvi to hdmi to connect it to the tv. I've solved the screen size problem by setting the tv screen size to fit screen instead of 16:9 and I now use overscanning on the mac mini, actually now that I've reset the tv that overscanning doesn't seem to make a difference. Nowhere that I have searched seems to have a solution to the text problem, that is it looks like there is an alpha transparency around the text and it's most noticeable on the menus or on other non-white backgrounds. I've tried adjusting contrast and brightness and all the other color settings on the tv. I've turned off font smoothing. Nothing I try works. Here's the kicker, I have an amd 64bit computer that I paid less than $300 running ubuntu and it looks much better, just like it does on a regular monitor. And windows 7 is perfect as well. What is it with apple that makes this so awful? I would hope that with all the complaints I've seen over this that apple would do something to fix it. Macs are not going to make it as media centers if people can't read the text and other less expensive options work much better. So if anyone can tell me something I've missed, I'm all ears.
    mac mini, Mac OS X (10.6.2), Samsung series 7 lcd tv
  • anthonycmoreno Calculating status...
    Tom,
    I'm new to all this and I was hoping for some help. I have the same series television as you do (however, it's a 2008 model). Can you describe a bit better (or maybe even send pictures) of what you mean by the text issue? If you can't post pics here, you can send to anthonycmoreno-at-hotmail.com

    Also, have you come up with a solution? I'm considering a Mac-Mini, but not if it's going to be a less that desired solution.
    Mac OS X (10.5.6)
  • Yoash Calculating status...
    I got the same problem and your post just helped me fixed the problem.

    I am posting my scenario as it a bit different and might help other users:
    HW:
    Samsung SynMaster 2494HS 24'' LCD display and I am working with Mac Mini and a PC.
    Steps to fix the problem:
    On the Samsung I selected Menu->Setup->Image Size -> Just Scan (the default was Wide)
    On my Mac Mini display preferences I reselected the Overscan option.
    Mac Mini Intel Code 2 Duo, Mac OS X (10.6.2)
  • 1spoonful Calculating status...
    I had the same problem on my Mini that I use as a media center. The "Just Scan" setting on my 36" Samsung worked perfectly. Thanks for the suggestion.

    Message was edited by: 1spoonful
    Macbook Pro, Mac OS X (10.6.2)
  • hank roberts Calculating status...
    Aha! Similar problem here; Mini (Intel, Macmini2,1, the 2007 version with the larger HDI port not the smaller one)

    Problem seems to happen only with both HDMI and USB connected (USB only to use the built-in webcam on the monitor, an AOC V22+ (which I love, it's a very nice monitor; LED instead of fluorescent backlight).

    Sometimes it would suddenly switch to where the dock and menu bars and status bar were hidden (the desktop gets 'too big for the screen).
    Then I'd go to the Display settings and unselect "overscan"
    Then it'd be OK for a while, then switch to a big black space around the desktop window, lots of unused screen).
    Then I'd go to the Display settings and reselect "overscan" and it'd be Ok.
    For a while.

    There really ought not be a need to fiddle with 'overscan' at all -- since I'm not using this as a television. Mac OS 10.3.6 seems to mistakenly think the monitor is being used as a TV -- maybe when there's a video in a browser window?
    Not sure.

    Anyhow it becomes a rock-paper-scissors problem where I have to keep chasing the settings to undo whatever it changes to at random, Lather rinse repeat.

    Seems like it's only a problem for me when I have the USB cable also connected, to use the built-in webcam -- so I don't use that now.

    The AOC folks have been working hard on solving this.
    I just found this topic and have referred them here.

    They'll be glad to know it's not their problem, I guess.

    (does it happen on Apple brand displays too? I'm not sure)
    Mini/Pismo/512ke/pb140/150/180/180c/520c/LC/SE30, Mac OS X (10.6.3)
  • BJackson Level 1 Level 1 (10 points)
    Same issue here with a new Mac Mini and 10.6.3

    Have you had any success resolving this? Here's my note to Apple..

    New Mac Mini, 10.6.3, want to use my Sanyo AVL 279 720p HDTV as a display for iPhoto, Keynote, etc.

    There is no means to select / deselect overscan using mini display port to HDMI so I'm using mini DVI port to HDMI.

    On overscan the toolbar, dock and some icons are outside the viewing area. With no overscan there is a large black border. Why can't I set my resolution (1366 x 768) or scale the overscan setting?
    iMac G5, MacBook, Mac Mini, Mac OS X (10.6.3), iPod Classic, iPod Touch, iPhone
  • gianprior Calculating status...
    Good morning,

    i have a mini mac MB139T/A with this video output:
    1 x display / video - DVI-Analog/Digital - DVI combinato 29 pin.
    For your experience, what is the better solution to connect the mini mac to 37'' LCD Toshiba? This Toshiba TV have input HDMI, s-video or VGA.
    Thanks
    Mac mini, Mac OS X (10.6), MB139T/A
  • dblood Calculating status...
    I just ran into this issue and found out how to fix it with a bit of help from this discussion. What was happening is both the TV (37" Panasonic) and my Mac (2007 Macbook) were set to Overscan the image. This was causing part of it to be cut off. When I set the TV to not Overscan, and OSX to Overscan on 1080p it fills the screen perfectly.

    I hope this helps someone.
    Macbook, Mac OS X (10.6.4), Late 2007

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.