9 Replies Latest reply: Jul 30, 2010 8:57 AM by Rob1sonjr
Inge Nagelhus Level 1 (0 points)
Problem: iMovie or FCE will not import your footage from SDHC camera with files in AVCHD structure, or cannot import .mts or .m2ht files (which you may have copied from AVCHD structure. When mounting camera, you can see the camera as disk but iMovie will not try to import footage. If you point Final Cut Express (FCE) to the file structure, it fails to recognize it as a valid file structure. (I have Canon HF10, but understand that this problem is common on many camera models, maybe camera has been turned off at the wrong moment?)

Cause: Faulty file structure on camera or disk

Soultion: Rebuild AVCHD file structure using an AVCHD editing tool. I found multiAVCHD (multiavchd.deanbg.com), which is not perfect, but will do the job. And it is freeware (possible to donate).

I would like comments about others experience - but at least this worked for me:
- Download and install the software (Yes, you need Windows)
- Set the right parameters: mostly default, I didn´t want any recoding. But tick off to keep the source files!
- Select the AVCHD source (or source .mts or m2ts files) and destination
- Start rebuilding: select output for Sony Playstation 3
- Put the AVCHD file structure on a USB stick

*If using iMovie:*
Start iMovie and plug the USB into the mac (virtual disk (.dmg file) or other media should work fine as well). The USB may contain other files as well, but the root of AVCHD must be named AVCHD.
iMovie recognizes the drive as a camera. All is not 100% well, as the dates for making the footage is lost, and the thumbnails are distorted if seen at all, until clicked on. But then import worked for most clips. Some clips gave an error message, but FCE was able to import these (Log&transfer).

*If using FCE:* Use Log and transfer on this file structure (need not be on external disk)


If you have a better solution - please share! I suppose there are other tools out there which may correct the file structure with less side effects and no errors.
If you go for this solution - remember the author of multiAVCHD, he will surely appreciate a donation. I guess everybody will agree that this is worth at least as much as you paid for your SDHC card.

Why a function to correct faulty file structure is not included in iMovie and FCE is beyond my understanding!

I notice many users salvage their footage by converting the .MTS files, using Handbrake etc. But I believe rebuilding the file structure is faster and with no quality reduction.

Macbook Pro 17, Mac OS X (10.6.3)
  • Tom Wolsky Level 10 (115,530 points)
    ClipWrap 2 will convert the mts media file to the correct format used in FCE or iMovie regardless of the folder structure.
  • Inge Nagelhus Level 1 (0 points)
    multiavchd is free (clipwrap is not), and allows import of mts and m2ts files as if they were on the camera. I'm quite happy with this!

    Only wish I had a similar program on the mac....
  • Tom Wolsky Level 10 (115,530 points)
    MPEG-4 media in H.264 with AAC audio will not work properly in FCE. It needs to be converted to the QuickTime using the Apple Intermediate Codec. ClipWrap does that.

    Instances of corrupt folder structures are negligible. The most common problem is that users have extracted the mts files from the folder structure, rather than preserving the folder structure.

    If you're a Mac user you could of course purchase Windows software and rebuilt your hard drive to use the multiavchd software, which will create media that still needs to be converted.
  • Inge Nagelhus Level 1 (0 points)
    By rebuilding the AVCHD file structure (or making a new one, adhering to the standard), iMovie and FCE can import the footage as intended, using the Apple Intermediate Codec. This is the way it was supposed to be imported from camera to FCE and iMovie by Apple developers.

    I still think this is a better solution than using conversion software (ClipWrap may be an exception, but as I have not had any need for it I have not tried it).

    Maybe "Instances of corrupt folder structures are negligible." However, I have found that every week there are posts about not being able to import from different cameras, with behavior as if the file structure is damaged! (My comments on these have now been removed by Apple Discussion Staff, as "duplicates".)
  • Palmvig Level 1 (0 points)
    I have tried to what you say with multiavchd, but I can't make i work.

    Not in FCE or Imovie..

    Don't know what I'm doing wrong.

    Export to a folder named AVCHD om my external hdd.

    Please help!!
  • Inge Nagelhus Level 1 (0 points)
    If the AVCHD file structure look right, it should be ok.
    The AVCHD directory should be on root level of the external hard drive (or memorystick).
    Disconnect and reconnect the device. iMovie checks the files when device is reconnected.
    If this does not work, try rebuild with a subset of the MTS files.
  • jhillestad Level 1 (45 points)
    To get mts avchd files into a ' media ' that can fool imovie into importing them as if it were a camera try using Toast 10 with the bluray plugin , make a avchd disc using your selected mts files and then either make a real disc or an image , once mounted the disc or image will be seen by imovie as a camera and those clips can now be imported as if you remade a memory stick even though your stick was long ago erased .....
  • Robjarv Level 1 (0 points)
    Hi everyone,
    I'm hoping someone is still subscribed to this and can help.

    I have a Sony HDR-SR10. Yesterday I was able to connect it to my iMac by USB and view all the footage in the import window of iMovie (08).
    Last night, to save time sorting at home, I took it to work with me and using the software that came with the camera installed on a Windows PC went through to see which files were rubbish and could be deleted before importing to speed up the transfer on to my mac.

    Today, my Mac won't recognise the Camera!?!?!?!

    Have I inadvertently reformatted the .MTS files or the camera itself, to windows or something? CanI change it back??

    I'm currently creating a new disk image of the camera on my Mac in the vain hope that it will work and be recognised by the Mac as a camera. I can see from the progress box the following text:

    Creating Image "Sony Camcorder Media.dmg"
    =====Progress Bar=====
    Reading (WindowsFAT32 :1)...

    Which is why I think I've done something seriously wrong!! .. because it mentions windows!

    HELP! HELP! HELP!

    I have my entire honeymoon and the first year of my son on this camera and I want to edit with iMovie! Especially as I just paid for iLife 09 upgrade!
  • Rob1sonjr Level 1 (0 points)
    I had a similar problem, not being able to import AVCHD files from my Panasonic DMC-FZ35 Camera. I found out that Imovie recognized my 2GB SD flash card, but would not recognize my SD 8GB flash card. So I copied the AVCHD folder to the Mac, formatted the 8GB flash card using the Mac. Now Imovie recognizes and imports the AVCHD files. I put the original AVCHD folder, with movies, back on the SD Card and was able to import the files. I had originally formated the SD card using the Camera, and it seems Imovie could not recognize AVCHD files. IPhoto worked fine even when the SD card was formatted by the camera.