Skip navigation
This discussion is archived

MacBook waking instantly from sleep

3614 Views 3 Replies Latest reply: May 31, 2010 6:07 AM by gzat RSS
Alex Chaffee Level 1 Level 1 (0 points)
Currently Being Moderated
May 1, 2010 2:29 PM
When I ask my MacBook (unibody, running 10.6.3) to sleep, it obliges, then immediately wakes back up again. Insomnia *****, especially when it's in my bag getting hotter and hotter!

I've spent the past 2 hours googling and trying solutions:

* I reset the PRAM and the PMU
* "Wake on Network" is disabled
* There's no runaway process
* I've installed the latest system updates
* I disabled IR control
* I set the sleep mode (pmset -g | grep hibernatemode) to both 3 and 0, to no avail: the only thing that changes is the time it takes before rewaking, since in one case it's writing the hibernate file and in one it's not
* Setting the hibernate mode to 1 is a workaround, but that's because it's never actually asleep, it just always hibernates. This is not great since that makes it take 30-40 seconds to both sleep and wake up every time.

In my console log is the following clue:

5/1/10 2:03:53 PM kernel Wake reason = OHC1
5/1/10 2:03:53 PM kernel System Wake
5/1/10 2:03:53 PM kernel Previous Sleep Cause: 5
5/1/10 2:03:53 PM kernel The USB device Apple Internal Keyboard / Trackpad (Port 6 of Hub at 0x4000000) may have caused a wake by issuing a remote wakeup

OHC1 is the code for "keypress". Suffice it to say that I'm not pressing any keys -- it just wakes on its own. And since this happens after selecting "Sleep" from the menu, it's not the clamshell monitor lid hitting a key. (It also wakes immediately if I close the lid to sleep, of course.)

Is this a hardware problem? Does my USB keyboard have a short or something?

I also have this annoying thing happening every 30 seconds or so, but I think it's unrelated:

5/1/10 2:25:09 PM mDNSResponder[19] Update Canon\032MP450.ipp.tcp.daychaffee.members.mac.com. refused
5/1/10 2:25:09 PM mDNSResponder[19] hndlRecordUpdateReply: Registration of record Canon\032MP450.ipp.tcp.daychaffee.members.mac.com. type 33 failed with error -65553
5/1/10 2:25:21 PM mDNSResponder[19] ERROR: mDNSPlatformWriteTCP - send Broken pipe
5/1/10 2:25:21 PM mDNSResponder[19] tcpConnectionCallback: error writing

"Canon MP450" is the name of my printer, which isn't actually plugged in right now. I'll go uninstall the printer and see what happens...

Message was edited by: Alex Chaffee
MacBook 5,1 unibody, Mac OS X (10.6.3)
  • gzat Calculating status...
    Currently Being Moderated
    May 30, 2010 2:14 PM (in response to Alex Chaffee)
    I have the same problem with my MBP 5,5. Do you have find a solution?
    MacBookPro5,5, Mac OS X (10.6.3)
  • Dale Weisshaar Level 6 Level 6 (15,855 points)
    Currently Being Moderated
    May 30, 2010 8:26 PM (in response to gzat)
    This is for a Mac that won't sleep.

    Here is Apple's KB article HT1776 with their tips.

    Mine follow;

    USB devices and hubs often cause Macs to not sleep or wake quickly from sleep (notably HP printers and scanners, HP all in ones, and Cannon scanners). Disconnect all USB except for keyboard and mouse and try. If it sleeps, add one back at a time testing after each one to find the culprit.

    If you've set your Mac to receive faxes, it may not be able to sleep. It might also have a damaged preferences file.
    If you use your Mac for faxing, open System Preferences. click Print & Fax, click the Faxing tab, and uncheck the Receive Faxes On This Computer box.

    If that doesn't work or you've never faxed on your Mac, go to Finder/Hard Drive /Library/Preferences/SystemConfiguration and delete the com.apple.PowerManagement.plist and com..apple.AutoWake.plist files (if your Mac asks, type your admin. password).
    If the latter file isn't present in the folder, go to user name(probably your name)/Library/Preferences, delete the com.apple.systemuiserver.plist file, and reboot your Mac.

    Next are user tips……..

    Check in System Preferences > Energy Saver is "Wake for network access" checked? If so, uncheck it.

    One user reported, " I couldn't make my macbook pro to go to sleep because I had my wireless headphone receiver still plugged in. I unplugged it and then it went to sleep."

    Also, if you have an External Western Digital (WD) hard drive and have installed
    WDDMService and WDSmartWareD on your Mac, it may not sleep. Fix is to un-install those....you don't need them to use the drive.

    "I have had this problem with my IMac G5. It is surprisingly irritating. LaCie's Silverkeeper backup software was the cause. By default it gave itself permission to wake up the computer to check if a backup was needed. Do you have this or a similar program installed which has scheduled activities including wake-up permissions as an option?"

    One provided this link, xlr8yourmac.com, to a member, which addresses failure of deep sleep with some users that updated and added new FireWire and USB card.

    Also, here is Apple KB article TA2469 about PCI cards and sleep.

    After few days of messing around I found out that I had desktop background (wallpaper) set to change every 1 minute.
    After unchecking "Change picture..." in system preferences (under Desktop/Screen saver), my powerbook went to sleep all by itself.

    "I have a Canon printer(shared) and my imac would not sleep. I opened up printer/fax in system prefs and noticed it said the printer was in use when it was off. Opened up the printer queue and noticed about 7 pending documents. Deleted them all and now it sleeps.
    Check the printer queue!"

    One user has had success, after trying all these tips, using an App. called PleaseSleep. I've never used it though.

    Good Luck!  DALE
    MacPro, 3.0GHz Dual C., 5 GB, X1900, 30"ACD,Airport Extreme,HP C7180 Printer,, Mac OS X (10.6.3), G4 Gigabit E. 1GHz OWC 10.4.11, 1.62MB MacBook Pro Late '08, 15", 2.4GHz, 4GB
  • gzat Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 31, 2010 6:07 AM (in response to Dale Weisshaar)
    I've solved the problem. I shutdown the computer and pressed many times all the keyboard keys and they back to sleep. Should have a keypressed or a keyboard bug.

    The log register:
    kernel The USB device Apple Internal Keyboard / Trackpad (Port 6 of Hub at 0x4000000) may have caused a wake by issuing a remote wakeup
    MacBookPro5,5, Mac OS X (10.6.3)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.