Skip navigation

Safari 5: How do I disable address auto completion?

34226 Views 42 Replies Latest reply: Feb 17, 2014 6:00 AM by crew3lt RSS
1 2 3 Previous Next
Babaganoosh Level 1 Level 1 (0 points)
Currently Being Moderated
Jun 10, 2010 2:21 PM
I am very irritated with address autocompletion in Safari. How do I turn this annoyance off? It's preventing me from going to some sites.

For instance, if I want to go to one site, and its address is similar to one of the sites in my bookmarks list, Safari will insist on taking me to the address of that bookmark, and will not yield to my demands. (An example would be if I have a particular RSS feed, such as MacWorld, in my bookmarks. Now I try to type in macworld.com so I can actually go to the real website, but Safari thinks I want to go to the RSS feed and stubbornly fills out the rest of it. I try to delete that from my toolbar address field, but Safari fills it right back in again!) How can I stop it from doing this?

(Note that I already have AutoFill completely disabled. All of its check boxes are deselected.)
iMac Core 2 Duo, Mac OS X (10.6.3)
  • Carolyn Samit Level 10 Level 10 (84,035 points)
    HI,

    There's a work around. From the Safari Menu Bar click Safari/Private Browsing.

    Read the dialog box...





    Carolyn
    Intel iMac 2.66 iPad 32GB iPhone 3GS. MBAir, Mac OS X (10.6.3), QTPro Intuos Tablet Epson Olympus Airport iPods JBL
  • Igor_G5 Level 2 Level 2 (300 points)
    I can't say for sure but I would think that if you go to Safari/Preferences/Autofill and uncheck all of the boxes it should accomplish this. If you don't give it a source to autofill from it shouldn't autofill. But I'm just guessing.
    G5 Quad 2.5 gh, 5gig RAM, 500 and 750 gb w/ 30" Cinema Display, Mac OS X (10.5.6), MBP, 17" C2D 2.53.(10.6.2). G4 Gigabit, dual 1.4 processor iPhone 3G, 16 gig
  • candez Calculating status...
    I feel your pain, Babaganoosh. It is immensely irritating.

    Just now, I typed "Apple" into the address bar and hit Return. In Safari 4, it would have appended the www. and .com to Apple and sent me on my merry way to Apple's home page. In Safari 5, I was whisked off to: http://d8.allthingsd.com/20100601/steve-jobs-session/

    Why? Because the title of the page is "Apple CEO Steve Jobs Live at D8 | D8 Conference | AllThingsD" and when I typed "Apple" into the address bar, it inexplicably determined that I was typing a page title into the address bar instead of a URL, and searched its memory for page titles that begin with "Apple." Who types *page titles* into the address bar?

    I don't mind Safari giving me a list of options from history or bookmarks that I could choose from below the address bar, but it is driving me batty that it's forcing those options on me rather than giving me what I'm actually asking for.
    iMac 24", Mac OS X (10.6.3), Day One iPhone . Snowball iMac . Bondi Blue iMac . Macintosh Classic . Apple //e . Apple ][+
  • anotherscott Calculating status...
    Yes! I have no idea whether anyone from Apple reads these discussions, or if these are just a way for users to talk to other users, but please, if anyone from Apple reads this, PLEASE let us disable this feature!! Terribly irritating, and at least in my case, more likely to get in my way than it is to help. I hate this "microsoft style" trend of computers giving us what they think we "really" want instead of giving us exactly what we ask for. I switched back from firefox to safari in part to get rid of this terrible "feature". Like candex says, it's fine to pop down a list of things we might want, but if we don't pick anything from the list, it should behave as expected a la safari 4. If I type Apple, I want www.apple.com - period!
    MacBook, Mac OS X (10.5.5)
  • Klaus1 Level 8 Level 8 (43,305 points)
    In the meantime the simplest way to stop Safari doing this is to add a space before typing the URL.
    20" 2.1GHz iSight iMac G5, 250GB HD, 1.5GB RAM, Mac OS X (10.5.8), iLife 9 but iMovie 6, QTPro 7.6.6, Safari 5
  • Aaron H. Calculating status...
    Currently Being Moderated
    Jun 22, 2010 3:31 PM (in response to Klaus1)
    I was excited to try this "space first" trick, but it doesn't work.

    The problem is that Safari seems to be weighting the TITLEs of pages in your history above the actual URLs in your history when filling in the auto-complete. So, if you've got a page in your history that has a title that begins the same as the URL you are typing, you have to type until it no longer matches (or clumsily attempt to select the 5th hit in a mishmash list of options).

    The URL bar should match first on the URL and then attempt to match on title and should NEVER auto-select a title based match without additional confirmation (i.e. tabbed complete).
    27" iMac, Mac OS X (10.6.4), Safari 5
  • iGary Calculating status...
    I experience the same irritation with Safari 5.

    A couple of examples:

    I key in "apple" into the address bar. With Safari 4 I would wind up at www.apple.com. With Safari 5 I wind up at www.macsales.com

    I start to key in "marketwatch". With Safari 4 it would correctly auto-complete and take me to www.marketwatch.com. Now with Safari 5 I wind up at www.foxbusiness.com.

    It has always been a huge irritation for me with Explorer for Windows in that keying in something like "amazon" into the address bar would return a page of search engine results for "amazon."

    I've always appreciated on the Mac that keying in "amazon" into the address bar actually takes me to ww.amazon.com.

    Wow what a concept!
    Mac Pro X 3, Mac Mini X 2, MacBook Pro 17" X1, OS X Server 10.5.x, Mac OS X (10.5.6)
  • chrisallenluke Calculating status...
    i agree, this is an irritating "feature." let's keep this thread at the top of the discussion forum.

    keep replying.
    Macbook Pro 17", Mac OS X (10.6.4)
  • Klaus1 Level 8 Level 8 (43,305 points)
    For what conceivable purpose?

    You are not getting Apple's attention here. To do that use the Bug Report button to send Apple product feedback and feature requests.
    20" 2.1GHz iSight iMac G5, 250GB HD, 1.5GB RAM, Mac OS X (10.5.8), iLife 9 but iMovie 6, QTPro 7.6.6, Safari 5
  • notmyphorte Calculating status...
    I've been trying to get around this with a Safari extension: http://bit.ly/aKgVlh

    It's a horrible hack - it uses JavaScript to inject an odd UTF-8 character before each character in the page title. This means that after the second character is typed into the address bar page titles from the history will not be suggested (but URLs from the history will still be).

    *Note that you must clear your existing history first (else these will still be suggested).*

    This does not apply to other items (e.g. existing bookmarks).

    It has a few quirks: short tab names are shifted to the left and in a couple of minor situations gaps appear between the title characters - when inspecting element or for the suggestions that appear based on URL in the address bar.

    This is JavaScript based, so it may have issues with some sites that manipulate the page title.
    Intel iMac, Mac OS X (10.6.4), Safari 5
  • Mike Harrison Calculating status...
    Boy, if someone tried to invent annoyance, this would be it.

    Here's the best place to make your voices heard:

    http://www.apple.com/feedback/safari.html

    I suggested that giving users OPTIONS (a means of enabling and disabling at will) is the best way to go; not deciding for us.
    Power Macintosh G4 MDD, Mac OS X (10.4.11), 2 GB RAM; 1.25GB PPC Processor
  • pgreasby Calculating status...
    The problem is that many people touch type and may not even notice this irritating feature until they get some obscure web page that was not what they typed. This should NOT be a default feature. I mindlessly updated to Safari 5 and it has been a major mistake. I couldn't get youtube to work. This is NOT what I expect of an Apple product.
    Macbook Pro, Mac OS X (10.6.4)
  • Matt Hardy Calculating status...
    Currently Being Moderated
    Jul 5, 2010 5:25 AM (in response to iGary)
    When I typed 'fa' in safari 4 it'd auto-complete facebook.com
    Which was useful.

    Now in safari 5, I get taken to... wait for it...

    'Failed to open page'

    Title versus URL is now making me type more, not less, argh
    But have to laugh, cause I should not go to facebook anyway...

    Message was edited by: Matt Hardy
    MacBook Pro (Intel), Mac OS X (10.6.4), 2.53GHz 4GB
1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.