Skip navigation
This discussion is archived

Airport Self-assigned IP Address ?

28595 Views 21 Replies Latest reply: Sep 27, 2010 12:22 PM by mojofat RSS
1 2 Previous Next
OVozeh Level 3 Level 3 (840 points)
Currently Being Moderated
May 4, 2010 5:13 AM
+Could someone kindly explain to me what does this message mean : +"Airport has the self-assigned IP address and will not be able to connect to the Internet."+
Many thanks.
MacBook and iMac G5, Mac OS X (10.6.3)
  • RodneyW Level 4 Level 4 (3,030 points)
    Currently Being Moderated
    May 4, 2010 5:20 AM (in response to OVozeh)
    It means that your wireless router and your Mac have not been able to negotiate an IP address. Is this a new problem on a previously working setup, or is it a new wireless router/Mac combination?
    MacBook (2.16 Ghz, 2 GB), Mac OS X (10.6.3), MacBook Pro (2.53 GHz, 4GB, 13i), Powerbook G4 12i (867 MHz, 640MB, 10.5.8)
  • RodneyW Level 4 Level 4 (3,030 points)
    Currently Being Moderated
    May 4, 2010 5:38 AM (in response to OVozeh)
    No problems. Let's hope that my response leads to a productive outcome.

    Firstly, have you used the "Assist me.." option in Network preferences?

    If you have, and have no satisfaction, then some trouble-shooting steps are in order:

    1) Are there any other computers/devices that are able to wirelessly connect to your Time Capsule? If yes, then it suggests that the problem is on your Mac. If no, then it is on your router.

    2). If it is your Mac, try turning Airport off (click on the Airport icon in the menu bar and select "Turn Airport Off"). Wait 5 seconds, tap your heels together, and then turn it on again. Does this work?

    3) If it is your router, try turning the router off, wait 5 seconds, clap your hands, and then turn it on again. Does this work?



    p.s. the tapping of heels and clapping of hands is critical to successful troubleshooting.
    MacBook (2.16 Ghz, 2 GB), Mac OS X (10.6.3), MacBook Pro (2.53 GHz, 4GB, 13i), Powerbook G4 12i (867 MHz, 640MB, 10.5.8)
  • bas_ackwards Calculating status...
    Currently Being Moderated
    May 4, 2010 7:27 AM (in response to OVozeh)
    Hello, had the same issue on two different Mac's the in the house. This fix worked:

    - turn off Airport
    - delete Airport as an 'interface' in System Pref / Network
    - reboot
    - **** your pants, because when your machine comes back up your Airport will be 'gone'
    - go back into Network, re-add Airport
    - reboot
    - go back into Network and reconfigure as you originally did when you first set up your machine

    This worked the first time on both the machine quoted below and a Mini running 10.4.11. Problem appeared the same way: Airport got locked on a self-assigned IP and wouldn't accept a DHCP renew nor would it accept a manual IP configuration.

    I've sent the above to Apple and asked for a 'fix' as there is clearly a bug in the Airport code.
    MBP 2.8G, Mac OS X (10.5.8)
  • nora333 Calculating status...
    Currently Being Moderated
    May 4, 2010 11:48 AM (in response to bas_ackwards)
    Thank you so much bas-ackwards..........I tried this and it worked!!!!!!!!!!!!!
    I got my first ever apple laptop at Christmas, and its been driving me mad, dropping internet connection 4-5 times an hour or more. I'd even taken it to the apple store and they said there's nothing wrong and they'd not heard of anyone else having this problem so I was very fed up with it.
    I did what you said and now I can even shut the lid, leave it a while, open the lid and its still connected. I am very happy, thank you so much.
    Macbook Pro 13"
  • Binhnt Calculating status...
    Currently Being Moderated
    May 4, 2010 4:11 PM (in response to OVozeh)
    I have same this problem, too.
    Normally, I share internet connection with my iphone via Airport has no problem. But today I can not do that. My iphone can connect and share files with my Macbook via wifi but it is unable to connect to internet?! I have checked my network and it also appear the notice that : "AirPort has the self-assigned IP address and will not be able to connect to the Internet".
    What is my problem ? and how can i fix it ?

    I have done follow bas_ackwards's instructions, but it didn't work.
    Mac OS X (10.6.2)
  • richwt Calculating status...
    Currently Being Moderated
    May 8, 2010 6:10 PM (in response to OVozeh)
    I disconnected my DirectTV DVRs and issue went away.
    many, Mac OS X (10.6.3)
  • Tonia Calculating status...
    Currently Being Moderated
    May 13, 2010 1:28 PM (in response to bas_ackwards)
    Thanks, bas_akwards, your solution worked for me as well!

    My Macbook was fine on our network but hubby's had that self-assigned IP Airport issue. You saved me a ton of time and probably money, too.

    Never had this issue before the upgrade to 10.6.3 last week, don't know if it's connected. But I'm thrilled to have the solution if it drops out again.
    MacBook White 2 GHz, Mac OS X (10.6.3)
  • William Kucharski Level 6 Level 6 (14,405 points)
    Currently Being Moderated
    May 13, 2010 2:32 PM (in response to richwt)
    richwt wrote:
    I disconnected my DirectTV DVRs and issue went away.

    Often this occurs when your router or cable/DSL modem can only assign a limited number of IP addresses, and adding more devices to the network exhausts the supply of available addresses.

    You may want to check to see if that was the cause in your case.
    Quad 2.5 GHz G5, 5 GB | 15" 2.6 GHz MBP Penryn, 4 GB | 1 TB Dual-Band TC, Mac OS X (10.6.3)
  • LeahMarie Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 13, 2010 9:04 AM (in response to bas_ackwards)
    I tried deleting my airport and it didn't work. I don't think I know how to reconfigure my network.
    can someone explain how to do that?
    MacBook Pro, Mac OS X (10.6.2)
  • CCS69 Calculating status...
    Currently Being Moderated
    Jun 14, 2010 11:28 AM (in response to OVozeh)
    Having a similar problem with a MacBook Pro and a Time Capsule(which is an Airport Extreme with an NAS hard drive in it):

    My Setup:

    Cable >>> Cable Modem >>> Time Capsule >>> Wireless and Wired Client Machines

    Before I setup my new Time Capsule, my MBP was not able to connect to the previous router using Ethernet. I thought maybe my Ethernet port had fried, but it turned out that the DHCP settings on the MBP got messed up be because I had used a Verizon wireless broadband card and its Location settings under Network Preferences, were overriding the 'Automatic' settings. Once I put the Location back to Automatic, it seemed my Ethernet was working again.

    I installed Time Capsule, which was amazingly able to connect to the Internet through the cable provider without using PPPoE, which I did not know it could do. My MBP was assigned an IP address of via Ethernet, and Airport client automatically turned off. Great!

    Then I tried to do a backup with Time Capsule. This part proved to be a nightmare, and I still haven't been able to complete a first backup of my machine.

    Time Capsule (as a Network Access Storage device, NOT as Airport router) would dismount midway through backup - gone! - and it's because my Ethernet IP address settings suddenly switched to 'self-assigned' IP address, and with Airport turned off, unable to connect to my LAN (10.0.1.x range).

    I tried Manually assigning a address to my Ethernet settings, but it won't connect.

    I rebooted the machine a few times, messed with the DHCP settings for both the Time Capsule and the MBP, and I was even able to get Ethernet working temporarily, but within an hour, BOOM, Ethernet back to 'self-assigned' IP address, and I'm only able to connect to the Internet via WiFi, because using Airport as my Network client, I am assigned a proper LAN IP address of

    So, now I'm backing up my MBP for the first time to Time Capsule and it has taken ALMOST 24 HOURS ALREADY!!!


    So, is the problem with Time Capsule/Airport base station technology, or is it with OS X and the client computer??? Considering I was having this kind of problem using a Linksys router, well before I installed Time Capsule, makes me think it is the latter.

    In fact, I have a printer and a WinXP machine on the same LAN, and they have no problem receiving proper IP addresses from the Time Capsule. It is only the MBP and only the Ethernet connection. Connecting to the Internet via WiFi is great at the airport, but it is woefully inadequate when you have to upload and download files constantly for a living. Slllllooooowwwww.

    Folks, if you are having trouble with self-assigned IP addresses, try some of these possible solutions:

    I consider this a serious bug that Apple needs to address. Why doesn't DHCP work right in OSX?
    Macbook Pro, Mac OS X (10.5.8), Time Capsule
  • M1SSB Level 1 Level 1 (25 points)
    Currently Being Moderated
    Jun 14, 2010 9:20 PM (in response to OVozeh)
    dear it is your macbook ...
    A Macbook aluminium 5,1
    I think it's a general bug, but nothing seems to work with me it just doesn't work!!!!!!!!!!
    I have parallels installed, I don't know if that it's a problem I don't think so, but anyway. when i try to eliminate the airport of the parallell installations on the network setting when i reboot they come up again! how is that possible? I heard that If I reinstall the 10.6 OSX it continue with the same problem what else can I do? or what worked for you? thanks!
    Macbook Aluminium 5,1 /2.0GHZ, Mac OS X (10.6)
1 2 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.