Skip navigation

Keyboard stops working in Snow Leopard when using Spaces

113296 Views 292 Replies Latest reply: May 7, 2013 6:42 AM by kwxr2000 RSS
  • dacohen Calculating status...
    nevermind. it's not fixed.

    **** it, apple! my happiness level for my Mac has gone from about a 9 to a 6. Get it fixed!

    on another note, even when keyboard shortcuts exhibit the problem, using jitouch gestures to switch between spaces don't. So i guess i'll be using those.

    Before i discovered jitouch two days ago, i put Spaces into one of the hot corners.
    Late 08 MBP 17", Mac OS X (10.6.3), cheesecake is delicious
  • Screaming.Pict Level 1 Level 1 (0 points)
    ...yeah it's still borked. Sheesh.

    Back to CTRL-SHIFT-EJECT.
    MBP 15" 2.8GHz, Mac OS X (10.6.3)
  • Court Dimon Calculating status...
    Just adding my voice to the choir.

    Running the 10.6.4 on my iMac, and continue to intermittently run into the spaces issue (whether I am running Things or not - though I generally do run Things because it is awesome).

    Would love to see Apple address this - it's been going on for quite some time.
    24" iMac8,1, Mac OS X (10.6.4)
  • cneidorf Calculating status...
    Well, it appears that at least a few of you don't have to imagine the disappointment I experienced when I saw the 10.6.4 release notes make mention of the keyboard lock-up problem. How quickly my hopes were dashed after I installed 10.6.4 and attempted to use use keyboard commands to shift between Spaces.

    Meet the new problem, same as the old problem.

    It's hard to believe that the Apple programmers could let this issue remain unresolved through FOUR different updates to the Snow Leopard.

    Perhaps all of Apple's attention is on the Ipad and the new Ipod these days.
    MBP 15" 2008, Mac OS X (10.6.4)
  • Erin Craig Calculating status...
    I just upgraded from Leopard to 10.6.4. Keyboard crashes regularly, approx every twenty minutes, whenever more than one application is open. So far I am only using Apple applications - itunes, ical, safari - oh, firefox also did it. Here is what I have already tried:

    * Turned off spaces and restarted
    * Turned off all applications launching at startup and restarted
    * Tried using the screen sleep workaround; no dice

    For me, the trackpad still works fine, but the keyboard does not; AND, whichever application freezes the keyboard, its menubar gets stuck at the top (so even if I use the mouse to launch a new application, it stays in the background even if its image is in the foreground). I believe the crashes happen at the moment I switch applications by clicking on one, but not sure.

    Only fix I have at the moment is hard restarts. I guess I could try only using one application. Genius bar tomorrow as my Snow Leopard is under warranty.
    MacBook 13" white 2.2Ghz Core 2 Duo, Mac OS X (10.6.4)
  • wyomason Calculating status...
    Just echoing what everyone else is saying. Except to say that the problem is WORSE now that I upgraded to 10.6.4. Are we going to have to march on Cupertino to get this problem fixed? Is anyone at Apple listening? Is there some way we can get together and figure out what we all have in common such that we have the problem and no one else does? I looked at the Console log. I don't see anything unusual through my novice eyes before I rebooted. I'm using Flock as my browser. Is anyone using a different browser?
    MacBook Pro, Mac OS X (10.6.4)
  • tangentially Level 1 Level 1 (0 points)
    When I experience this issue (10.6.4/mid 2009 MBP) I find that the Spaces desktop overlay stays on the screen. It only seems to happen to me when I am returning to Space 1. I use CMD-Number for my spaces.

    I've also found that using my mouse to change spaces from the menubar 4 or 5 times makes it go away.
    MacBook Pro, Mac OS X (10.6.4), 8G RAM
  • tangentially Level 1 Level 1 (0 points)
    I have a case where I can reliably cause the condition and cure it. (I use cmd-1 thru cmd-4 for my spaces desktop keys and I have vmware installed but not running.)

    To cause it:

    I Cmd-2 to desktop 2. Once there I launch iMovie. While iMovie is starting I Cmd-1. Nothing happens until iMovie finishes starting. Then I am switched back to space 1, but the spaces icon stays up and my keyboard is disabled (within apps).

    To cure it:

    I then Cmd-2 back to desktop 2 and wait for the spaces icon to disappear. Then I switch to desktop 1 using the mouse and wait for the spaces icon to disappear. Now my keyboard works.
    MacBook Pro, Mac OS X (10.6.4)
  • dan_phillips Level 1 Level 1 (15 points)
    Just wanted to add my voice to the choir. 17" MBPro 2.33Ghz, 10.6.4. This is a very annoying problem.
    mbpro, Mac OS X (10.5.1)
  • jeff_mercer Calculating status...
    I too am having this problem.

    I'm wondering if it's some sort of Apple Script problem because I can reproduce it every time with the Things Quick Entry(Ctrl +option + space) then escaping out of that screen an switching spaces with Ctrl + arrow keys.

    Also, as mentioned earlier in this thread: putting the screen to sleep with Ctrl + Shift + Eject fixes each time for me.
    13" MacBook (late 2008), Mac OS X (10.6.4)
  • macswe Calculating status...
    I'm also a victim. MBPro 2.66GHz i7. I found that using the mouse to select a Space with the little menu icon makes the large center screen icon finally fade away, but doesn't re-enable the keyboard. I've been recovering by closing my cover, waiting for sleep, then waking it. I'm chiming in here so I will get notified if it's ever solved.

    I noticed several people saying they had this happen every time they used keystrokes to shift Spaces. I have the two thumb buttons on my Microsoft Intellimouse Explorer 2.0A set to command-option-leftarrow and command-option-rightarrow, the Spaces next and previous commands. They work with no problem almost all of the time, so that doesn't seem to be what is triggering it on my machine. The corresponding keyboard keys work equally well.

    What triggers this most often on my machine is launching Parallels, which I have set to use a fixed Space. Because Parallels takes a long time to boot up, I often switch out of this Space to do something else while I'm waiting. Some combination of the above behavior triggers this bug with great frequency. But it occasionally occurs when I haven't gone anywhere near Parallels, either.

    Also (and I find this really bizarre) when the keyboard is "dead" it will still process control-1 to control-6 keystrokes (Spaces go-to-Space-N commands) — but not any other keystroke.
    MBPro 2.66GHz i7, Mac OS X (10.6.4)
  • wabbott Calculating status...
    I'm in the same boat. I just upgraded from 10.5.8 to 10.6.4 and with a few days I started experiencing the keyboard problem. In my case it's as if the command key is stuck - once that happens I can't do much. I thought at first this might have been a hardware problem until I came across this thread - it's just too much of a coincidence for this to have happened so soon after my upgrade. I was only able to break out of the problem by restarting several times. Like others have said this is beyond annoying...
    MacBook Pro 15, Mac OS X (10.6.4)
  • Luke Murphy1 Calculating status...
    I'm starting to suspect it's related to Growl. It started a couple of days after I installed Growl. After some days of frustration I uninstalled Growl and restarted, the problem went away and stayed away for months. Another app just installed Growl for me two days ago and ta-da, the problem's back. I've switched off Growl and restarted and hopefully I won't see it again. Anyone else want to try switching off or uninstalling Growl?
    Mac Pro, Macbook Pro, Mac OS X (10.5.3)
  • macswe Level 1 Level 1 (0 points)
    Don't use Growl and never have, so it isn't the cause. Could be exacerbating the underlying problem, of course.
    MacBook Pro, Mac OS X (10.6.4)
1 ... 10 11 12 13 14 ... 20 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (7)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.