7 Replies Latest reply: Jul 6, 2010 3:12 PM by shcaerp
DrSupachicken Level 1 Level 1 (5 points)
Hi Guys,

I have seen a few posts on this but can't quite work out how to fix it.

Server is running 10.6.4 all updated on a fresh install.

I have edited DNS zone so the zone name is domain.com and not server.domain.com - I have also changed the name server from server.domain.com to domain.com and left the name server as server.domain.com - finally I have the MX record set to server.domain.com

In server admin I have configured mail with an internet name domain.com and a hostname of server.domain.com as I understand it should be.

In webmail messages only send and receive if they are sent to user@mail.domain.com rather then user@domain.com

Do I need to edit the squirrelmail file in the terminal to change the hostname for this to work? If this is the case can someone point me in the direction of a walkthrough for doing this?

Thanks in advance.

MacBook Pro 13" 2.53GHz 4GB 250GB, Mac OS X (10.6.4)
  • 1. Re: Remove @mail.domain.com
    MHF2 Level 1 Level 1 (0 points)
    The only thing that I have found to fix this is changing the settings in webmail. Options -> Personal Information -> "email address" & "reply to".

    Don't think it is the proper fix, but it seems to be working
  • 2. Re: Remove @mail.domain.com
    Christopher Rogers3 Level 1 Level 1 (5 points)
    Hey MHF2,

    Unfortunately this has been existing issue on OS X Server for quite some time and I have yet to find out a fix for it yet. I can only assume there is a config file buried somewhere that gets generated and sets that default for each user.

    Anyone have an idea?
  • 3. Re: Remove @mail.domain.com
    foilpan Level 4 Level 4 (1,385 points)
    can't you use the config.pl tool to edit these parameters?

    check here: http://squirrelmail.org/docs/admin/admin-5.html
  • 4. Re: Remove @mail.domain.com
    Yayouuu Level 1 Level 1 (0 points)
    Hello All

    i had a look on the configuration file of squirrelmail

    in /etc/squirrelmail/config there is the file config.php

    in this file i've found this definition


    /* Server Settings */
    /**
    * Default Domain
    *
    * The domain part of local email addresses.
    * This is for all messages sent out from this server.
    * Reply address is generated by $username@$domain
    * Example: In bob@example.com, example.com is the domain.
    * @global string $domain
    */
    $domain = getenv(SERVER_NAME);

    So i replaced getenv(SERVER_NAME) with the name of my domain and it works

    Regards

    Yannick
  • 5. Re: Remove @mail.domain.com
    shcaerp Level 1 Level 1 (55 points)
    All you have to do is open Server Admin and go to the mail service. Click on settings -> advanced -> hosting. Simply check "Include servers domain as local host alias". That will fix your problem.
  • 6. Re: Remove @mail.domain.com
    Yayouuu Level 1 Level 1 (0 points)
    So your solution is ok for :
    - automatic creation of email during creation of a person in the open directory
    - automatic creation of wiki email address

    but it doesn't work with the use of Webmail.
    The only solution i've found to solve this issue is to modify the config.php file of squirrelmail.

    Thank you for all

    Regards

    Yannick
  • 7. Re: Remove @mail.domain.com
    shcaerp Level 1 Level 1 (55 points)
    It works for all services in SLS. I use it with webmail all the time. The email address created when you add the user is available for all services. Don't know what you are talking about. Checking the box allows you to use shortname@domainname for your email address instead of shortname@server.domainname.