Skip navigation

ALERT: NO INTERNET CONNECTION

94520 Views 35 Replies Latest reply: Apr 15, 2014 10:36 PM by KKKKkeiraa RSS
  • Rod Hagen Level 7 Level 7 (31,985 points)
    Currently Being Moderated
    Jun 19, 2010 6:27 PM (in response to yvdineshkumar)
    You need to spell out your problem more clearly, yvdineshkumar

    Are you saying that you can't connect to the internet wirelessly only at your friends house or does the problem occur elsewhere, too?

    If the problem is occurring when you are at your friend's place what sort of wireless router do they have?

    Again, if the problem is happening when you are at your friend's place what happens if you choose "Join other network" from the Airport menubar item at your friends house, and then enter the name of the network and *the password for his or her network* in the relevant box that appears?

    If it is happening at YOUR place, what happens if you choose "Join other network" from the menubar Airport item, and then enter your OWN network name and password?

    Cheers

    Rod
    MBP 13"2.26, MBP15"2.2, iMacG520"RevB , MB2CD, MBCD, ,PM5400/180 & earlier, Mac OS X (10.6.3), 7 chooks, 2 dogs, 2 daughters, 1 pear tree, 0 partridges, itinerant bats, magpie
  • Rod Hagen Level 7 Level 7 (31,985 points)
    Currently Being Moderated
    Jun 20, 2010 4:38 PM (in response to yvdineshkumar)
    The most likely explanation here is a settings issue with the new router, rather than any problem with the computer itself.

    How is the netgear router set up? What wireless transmission mode is it using? 802.11n or something else?

    Is it acting as a DHCP server, or are you using it in "bridge" mode from an ADSL modem, or, perhaps, do you have addresses configured manually?

    What encryption settings do you have enabled on the Netgear? WPA? WPA2? Something else?

    Your best bet might actually be to post over in the airport forums, providing as much information as possible about the router model and its current settings. People there are likely to have a similar set-up. You could also see if Netgear are able to provide you with help connecting a Mac running Snow Leopard to their equipment. I've seen quite a few people reporting set-up issues with Netgear routers.

    Cheers

    Rod
    MBP 13"2.26, MBP15"2.2, iMacG520"RevB , MB2CD, MBCD, ,PM5400/180 & earlier, Mac OS X (10.6.3), 7 chooks, 2 dogs, 2 daughters, 1 pear tree, 0 partridges, itinerant bats, magpie
  • libzombie Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 9, 2010 12:53 PM (in response to Baby Boomer (USofA))
    Baby Boomer (USofA) wrote:
    "Do the following:
    In the Library/Preferences/SystemConfiguration/ folder delete the following:

    com.apple.airport.preferences.plist
    NetworkInterfaces.plist
    preferences.plist
    com.apple.nat.plist

    You will have to re-configure all your network settings since deleting"


    I just wanted to say thank you SO much for this. I was having this issue in the last few days at work and couldn't figure out why I couldn't connect to the wireless any longer. I found the first .plist file in question and removed that, but couldn't find the other three. Frustrated, I was about to turn off the computer but noticed that at the deletion of that single file, I suddenly had my wireless back.

    And it's still going on strong an hour later.

    So, Baby Boomer, thank you SOSOSO very much for help with this, even though I wasn't the original poster.

    Cheers,
    libzombie
    MacBook 2,1, Mac OS X (10.6.4)
  • palmwoods Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 12, 2010 3:37 PM (in response to yvdineshkumar)
    Yep, just had the same problem within a group of macs I am network administrator for. For some reason, since snow leopard the macs have been getting themselves confused when connecting via the airport. The issue is not necessarily the airport, but the fact they are trying to all connect using the same IP address through a router and or switch.

    The latter of two macs to do this is thus denied access to the internet, but can access other computers and printers through the network. The dreaded ALERT NO INTERNET CONNECTION appears in the airport menu.

    I found the way to fix this was to manually assign yourself an IP address. You can do this by visiting apple menu/system preferences/network/ select the airport tab on the left and click the advanced bubble in the bottom right hand side of the pop-up window.

    Go to the TCP/IP tab and select Using DHCP with Manual Address next to Configure IPv4.

    As to what that address might be is specific to your network 192.168.0.(insert number here).

    Hope this helps.
    Macbook Pro 3.06Ghz Intel Core 2 Duo, Mac OS X (10.6.4)
  • Leonardo Lazo Level 1 Level 1 (5 points)
    Currently Being Moderated
    Aug 15, 2010 7:14 PM (in response to palmwoods)
    I am having the same problem, but it only at my home. I have not problem connecting to other wifi (at my in-laws, school) I keep getting the exclamation signal and the self-assigned IP address. I have deleted the following:
    com.apple.airport.preferences.plist
    NetworkInterfaces.plist
    preferences.plist
    My wife's older MBP 17" connects without problems. I tried to copy her settings and input it manually in my computer, but still no connection. I have followed all of the above suggestions. I am quite savvy with macs but this one has me stumped.
    I use T-P Link router. It has worked fine without any problems. Other computers can connect, but mine. And usually, mine is has the better connection/speed.
    Any suggestions is greatly appreciated.
    MBP, 2.4 Intel Duo, 4 GB RAM, Mac OS X (10.6.4)
  • Leonardo Lazo Level 1 Level 1 (5 points)
    Currently Being Moderated
    Aug 16, 2010 7:16 AM (in response to Leonardo Lazo)
    Well, I got it working. I just created a new account. Logged in and had no problem getting a IP address. I logged back to my old account and it had no problem getting an IP address. I am still baffled by this. I am sure it had to do with some corrupted preference files. I thought I deleted all of them. I also used Time Machine to restore older preferences. If any of you can shed some light as to what might have caused self-assigned IP address, it would be great to know.
    iMac G5, 2GHz, 2G RAM, Mac OS X (10.4.10)
  • Joerg Von Veltar Level 1 Level 1 (15 points)
    Currently Being Moderated
    Sep 1, 2010 6:23 PM (in response to Leonardo Lazo)
    This may does not apply to everyone who has the same problem.
    Just got my MacBook Pro back from the Apple Store. They had to replace the Logic Board because of a Video Problem (Where they repair it even if out of warranty for free. See http://support.apple.com/kb/ts2377).
    Having several Mac's at home, and have two different WiFi Networks, they all worked fine for all Mac's but when I wanted to connect the repaired MacBook Pro, it saw the Apple Airport Extreme and my secondary Motorola WiFi Cable Modem. Trying to connect to the Extreme, I got the same message like her discussed but the Motorola WiFi worked fine. It needs to be said that I am using WPA/WPA2 Personal Security and have in the Access Panel of the AirPort the MAC Address authorized for any Mac I am using on either Network.
    After I wiped out the Access for the repaired Mac on my AirPort Express and then reentered the data, AirPort ID, and Name it worked.
    There seems to be some relation between the AirPort ID and the MAC ID of the Logic Board and when they not match as initially setup (based on the new logic Board) the message comes up.
    It's frustrating but it happen.
    MacBook Pro 15", Mac OS X (10.6.4)
  • Davinder Sangha Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 24, 2011 12:45 AM (in response to Joerg Von Veltar)
    I had this problem yesterday. It seems as if the Airport was trying to pick up a signal from my repeater.

    Essentially, I have a NETGEAR 150, plus a Belkin G Extender/Repeater to boost the range. Working fine, but it seemed that the signal must have dropped from the Netgear and it decided to pick up the signal from Belkin, despite it showing it was linked to the Netgear. It was creating it's IP address from the Belkin
    iMac, Mac OS X (10.5.4)
  • gamedev Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 14, 2011 1:37 PM (in response to yvdineshkumar)
    On my new MBP I got the "Alert: No Internet Connection" message at my brother-inlaw's place. I was surprised since my iPhone connected no problem. Double checked the password, tried restarting the router & the MBP, using manually entered IP etc. nothing worked. Then he changed the router to use WPA instead of WEP for security. I connect with new WPA password and everything worked! Maybe Snow Leopard has problems with WEP (or a certain WEP sub-type).
    MBP(Feb 2011) 15", Mac OS X (10.6.7), 2.3Ghz 500GB 7200rpm Hi-Res Anti-Glare
  • 2010MBP Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 3, 2011 7:49 AM (in response to yvdineshkumar)

    This explanation for the problem is somewhat simple and may not help everyone with this problem.

     

    I was trying to connect to a network at a relative's home. The network is WEP encrypted.

     

    They gave me the incorrect password to connect with.

     

    My first round of logon attempts I was using a password with all lowercase letters and 1 incorrect number.

     

    ie.

     

    first version of password: gky23cgy72

    correct password: GKY23CGY79

     

    I found out the correct password by getting onto their computer and having a look at the network and getting Windows 7 to show me the password they were using.

     

    Armed with the correct password I went into network preferences, removed the network from the remembered networks list under advanced settings, applied the changes there and turned airport off then on again.

     

    My computer no longer automatically connected to the network. I entered the proper password and connected without a problem.

     

    A possibly half-baked explanation for this:

     

    My guess is that instead of storing the password as the literal characters a user enters, a WEP network uses a checksum to verify a password. The characters in the password may be converted to a numerical data type, manipulated with an algorithm to ensure the checksum is unique and the product of this equation is the checksum. When a password is entered the same algorithm is used the manipulate the entry and if the products match, the password must be the same. Usually something like this produces unique values. But, the range of possible passwords is VERY BIG. Testing each and every password to ensure ALL checksums produced by an algorithm are unique is probably impossible. 100 out of a few billion cases might produce this anomaly and the algorithm remains in use to act as a pain in my butt.

     

    Anyway, that's just an absolute noob's understanding of passwords n' stuff.

     

    Hope this helps somebody.

  • rabbitwoodrun Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 13, 2012 5:03 PM (in response to Baby Boomer (USofA))

    I have a Macbook from 2007 of March.
    Current operating System is Snow Leopard 10.6.8

    No new updates in the last couple months.
    Airport was working this morning just fine. This afternoon, it says, "Alert: No Internet Connection"
    My Network Preferences do not acknowledge any wireless networks, nor does the Airport Utility application.
    However, when I scroll down on my Airport button in the top right hand corner of the screen, it does show the wireless networks. I checked with other computers in the household (The Macbook Pro I am currently using.) and their wireless connections work just fine.

    I tried the given solutions that have been posted, deleting the files specificed, restarting and running the diagnostics. However, I am still in the same boat.
    Up until this day, I have had no problems whatsoever with my Macbook or the Aiport utility. Any further suggestions?

  • 2010MBP Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 24, 2012 9:30 PM (in response to rabbitwoodrun)

    This is a solution that was specific to what I assume is a highly secure network (the one at my college) and might help.

     

    I had the same problem I had all passwords correct for the correct networks, I had been registered on the network as a safe user and everything was working perfectly until one day my computer started to forget what time it actually is in this part of the world. Something goes wrong with the time and date and it suddenly thinks its December 31 1970 or January 1 of some other year I wasn't even born in.

     

    Another manifestation of the problem was to have the time be four or five hours earlier or later than it actually is in my time zone. As soon as I changed the time manually to the correct time the problem was solved. The techs said it was because their equipment thought I was in a time zone that didn't match the one it expected me to be in. I assumed this was a safety feature they designed, but maybe all wireless routers are conscious of where they are and somehow use the time to verify who they should and should not allow to use their signal.

  • lamente Level 1 Level 1 (10 points)
    Currently Being Moderated
    Feb 7, 2012 8:01 PM (in response to yvdineshkumar)

    I've seen this many times and a restart of the wireless router will always work

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.