Skip navigation

Safari suddenly stopped playing embedded YouTube videos

15222 Views 23 Replies Latest reply: Dec 4, 2012 3:41 PM by Philscbx RSS
1 2 Previous Next
goChickenboy Calculating status...
Currently Being Moderated
Jun 9, 2010 6:24 PM
A few weeks ago my Safari stopped playing embedded YouTube videos. I can right click on the embedded video and watch it directly on YouTube and I can view them embedded in FireFox, but my Safari gives me this message: An error occurred, please try again later. It's been like three weeks now. The same pages will play in my other computers on the same network, but not on my MBP.

I've tried:
emptying the cache
running in 32 bit mode
deleting com.apple.Safari.RSS.plist
deleting com.apple.Safari.plist
deleting webpageIcons.db
(I could not find the file com.apple.Safari.LSSharedFileList.plist to delete)
restarting
repaired permissions

I even updated my OS to 10.6.3 and downloaded Safari version 5.0. Still the same problem.

What am I missing? It'll play YouTube videos, just not embedded ones.
MBP 3.06 GHz Intel Core 2 Duo, Mac OS X (10.6.3), problem persists in both Safari 4 and 5
1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.