1 2 Previous Next 21 Replies Latest reply: Jan 3, 2014 11:56 AM by Apple0987
sn4p2k Level 4 Level 4 (1,215 points)
when I turn the phone on vibrate mode via the switch and I get a text message the phone does not vibrate to let me know that the text came in is there a setting somewhere I am missing to get a vibrate when a text comes in?

macbook pro 17 inch, Mac OS X (10.6.1)
  • 1. Re: vibrate for text messages?
    BugsBunnyWCV Level 1 Level 1 (20 points)
    Make sure that you check on

    Settings --> sounds

    that under Ring, Vibrate is ON and Text is selected
  • 2. Re: vibrate for text messages?
    sn4p2k Level 4 Level 4 (1,215 points)
    vibrate is on in both places on the sounds menu silent and ring vibrate on the phone vibrates for a phone call but not for a text message
  • 3. Re: vibrate for text messages?
    sn4p2k Level 4 Level 4 (1,215 points)
    bump
  • 4. Re: vibrate for text messages?
    whoknows7 Level 1 Level 1 (0 points)
    I'm having a similar problem except mine doesn't vibrate for texts or calls. And yes, vibrate is on in the settings.
  • 5. Re: vibrate for text messages?
    dtflick1 Level 1 Level 1 (0 points)
    I have the same problem. No vibrate at all. When I flip the switch, I get the indicator on the screen, but no vibrate when calls come in or texts. Also, no vibrate when I flip the switch.

    The other strange thing I've noticed is that the speaker seems pretty tinny. Maybe its just because it is new and has to break in, but I don't remember my 3G or 3GS sounding like this.

    Anyone else?
  • 6. Re: vibrate for text messages?
    dellerton Level 1 Level 1 (0 points)
    Same for me here.. Weird. All settings correct. If in silent mode, no vibrate or "wake up" when a text comes in.
  • 7. Re: vibrate for text messages?
    dtflick1 Level 1 Level 1 (0 points)
    Just to update everyone:

    I made appointment and my apple store and took my phone in and explained the problem. The store keeps a bunch of product in the back that is not for retail sale (which I found out is SOP for all stores) in case of such issues with new products. They replaced my phone with a brand new one right out of the box, activated in in the store, and I restored it when I got home. No problems to report on the replacement phone. If you're having any problems I recommend making an appointment and going into the apple store and getting a replacement. They should have a small back stock for such instances. Good luck.
  • 8. Re: vibrate for text messages?
    applepup Level 1 Level 1 (5 points)
    Well I'm glad I found this post. I thought I was the only one having this issue. My vibrate function doesn't work sometimes when getting a text message either. When I turn the phone off and on again, the problem is fixed for a while. I'm hoping it's a sw issue that will be addressed soon. Some have said that the vibrate mechanism gets stuck and a free app like iBrate loosens it up if you run it for a bit. I'm going to give it a shot, but I'm doubtful it's a "stuck" issue. Seems like a sw thing to me. I don't remember if iOS4 messed up my 3Gs like this, i only got to mess with it for 2 days before I upgraded to the 4 model.
  • 9. Re: vibrate for text messages?
    dellerton Level 1 Level 1 (0 points)
    Something to do with multitasking?
  • 10. Re: vibrate for text messages?
    Yoyi Level 1 Level 1 (0 points)
    I had the same issue but I think it's not a problem. Try this

    Settings -> Sounds

    And make sure that Vibrate is set to ON and in the New Tex Message you have anything other than None.

    Seems that if you have None (sound selected) in New Text Message it wont even vibrate.

    Hope this help
  • 11. Re: vibrate for text messages?
    sn4p2k Level 4 Level 4 (1,215 points)
    I solved this by turning the vibrate setting off then back on in settings it now works
  • 12. Re: vibrate for text messages?
    smaragdite Level 1 Level 1 (0 points)

    tried doing that. no luck...

  • 13. Re: vibrate for text messages?
    AM_Kidd Level 3 Level 3 (975 points)

    if you want it to vibrate for texts make sure that vibrate is on for silent and its also on under ringer and alerts but more specifically make sure you have a text tone

     

    the text tone will not play if you keep your phone on silent mode, instead it will vibrate twice notifying you of new texts

     

    hope this helped!

  • 14. Re: vibrate for text messages?
    DidiY Level 1 Level 1 (0 points)

    Setting Alert tone other than 'None' for text worked for me until i restarted my phone one day and never worked after that. I worked around the issue by creating my own alert and ringer sound with 'no sound' in it and synced it to my phone and i used that as my alert and ringer tone. That way it still play the tone but since it is a quite tone you don't hear anything but vibrate only.

     

    You can check this link to see how you can make your own tones.

     

    http://www.ehow.com/how_2160460_custom-iphone-ringtones-free.html

     

    OR

     

    http://www.gottabemobile.com/2011/10/26/ios-5-how-to-create-custom-ringtones-and -alerts-for-the-iphone/

     

    Not fair to have gone through all this just to put my phone on vibrate only!!!

1 2 Previous Next