Previous 1 3 4 5 6 7 Next 91 Replies Latest reply: Sep 20, 2010 2:23 AM by 1000TC Go to original post
  • d0glesby Level 1 (0 points)
    Andre's fix worked for me as well. Thank you very much!
  • matrixskp Level 1 (0 points)
    After upgrading to 10.6.4 iCal couldn't resolve the shared calendar URL's from the iCal accounts (we previously entered /principals/_uids_/wikis/groupname/ which was then replaced by the large string of HEX)

    Changing the server path for each account in iCal Preferences > Accounts as discussed resolved the issue here:


    (replace [groupname] with the name of your group from Directory Server.

    Thanks for the help guys!
  • dimphi Level 1 (0 points)
    Hi Andre,

    Address Book server (CardDAV) does not start anymore since I fixed file. lendarServer-2.5-dev

    Here is the carddav error log:

    exec python /usr/share/carddavd/bin/twistd --reactor=caldav_kqueue -n carddav -o Twisted/reactor=caldav_kqueue
    /usr/share/carddavd/lib/python/twisted/web2/dav/element/ DeprecationWarning: object._new_() takes no parameters
    child: WebDAVElement._new_(clazz, children)
    /usr/share/carddavd/lib/python/twisted/web2/dav/element/ DeprecationWarning: object._new_() takes no parameters
    WebDAVElement._new_(clazz, children)
    Traceback (most recent call last):
    File "/usr/share/carddavd/bin/twistd", line 21, in <module>
    File "/usr/share/carddavd/lib/python/twisted/scripts/", line 27, in run, ServerOptions)
    File "/usr/share/carddavd/lib/python/twisted/application/", line 374, in run
    File "/usr/share/carddavd/lib/python/twisted/application/", line 354, in parseOptions
    usage.Options.parseOptions(self, options)
    File "/usr/share/carddavd/lib/python/twisted/python/", line 184, in parseOptions
    for (cmd, short, parser, doc) in self.subCommands:
    File "/usr/share/carddavd/lib/python/twisted/application/", line 365, in subCommands
    self.loadedPlugins[plug.tapname] = plug
    File "/usr/share/carddavd/lib/python/twisted/plugins/", line 13, in getProperty
    return getattr(reflect.namedClass(self.serviceMakerClass), propname)
    File "/usr/share/carddavd/lib/python/twisted/python/", line 347, in namedObject
    module = namedModule(string.join(classSplit[:-1], '.'))
    File "/usr/share/carddavd/lib/python/twisted/python/", line 335, in namedModule
    topLevel = _import_(name)
    File "/usr/share/carddavd/lib/python/addressbookserver/tap/", line 73, in <module>
    from import DirectoryPrincipalProvisioningResource
    File "/usr/share/caldavd/lib/python/twistedcaldav/directory/", line 53, in <module>
    from import ResourceInfoDatabase
    *ImportError: No module named resourceinfo*

    Thanks in advance for your help.

  • hmolina Level 1 (0 points)

    You make a mistake: you have to modify the which is in the caldav service and not the carddav service(which is the Address Book server)

    iCal server is in:

    Address Book service is in:
    This is the wrong file, and whom you modify by error.

    You have to undo the changes in the carddav (copying the original file), and delete the principal.pyc generated under carddav. After restart the server (serveradmin stop addressbook; server admin start addressbook) .

    After, modify the in the CALDAVD directory, following the Andre's instructions. Do not forget rename the .pyc file too.

    Please, do not forget copy the original files to be able to recover from any mistake.

    Best regards.

  • dimphi Level 1 (0 points)
    Hi Hmolina,

    Many thanks for your answer.

    Could you send me original file located in "/usr/share/carddavd/lib/python/twistedcaldav/directory/" folder because I don't have it anymore...

    Thanks in advance,

  • hmolina Level 1 (0 points)
    Hi Dimitri,

    I post the file in

    The SHA1 signature to verify that file is:

    SHA1( a59e82d42b41f93988fee0710eb2e72b5bb35e74

    And the sha1 hash code for the file is

    SHA1( 92713c96a86e66a328da59b265fd5a16736d9cb5

    You can check and compare the file using the follow command:

    openssl sha1

    Best regards.

  • emb3dd3d Level 1 (0 points)
    the python patch and changing the path from .../wikis/<groupname>/ to /principals/_uids_/wiki-<groupname>/ worked for me also. I want to say thanks to all that worked on this. This is a really nice feature to have. I don't understand why it isn't supported. It really doesn't appear to add a lot of support issues to the organization once everyone understands that you cannot send out invitations from that calendar.


    Message was edited by: emb3dd3d
  • emb3dd3d Level 1 (0 points)
    sorry dont know how to delete this..

    Message was edited by: emb3dd3d
  • dimphi Level 1 (0 points)

    Thanks a lot! Address Book server works great again!

    Best regards,

  • Elliot Hui Level 1 (20 points)
    Thanks, Andre! This works really nicely.
  • Stefan Siebeker Level 1 (10 points)
    Hi all, I am quite happy to see, that I am not the only one struggling with these ical-problems. I have followed all the given solutions - thanks for that - but am still not able to run it properly. After changing the and deleting the python.pyc and restarting everything the calendar seems not to work any more at all. I am no more able to add accounts through ical-client. In the error log of the ical-service I found the following:

    2010-06-25 12:29:54+0200 [-] [caldav-8009] File "/usr/share/caldavd/lib/python/twistedcaldav/directory/", line 535, in _init_
    2010-06-25 12:29:54+0200 [-] [caldav-8009] url = joinURL(parent.principalCollectionURL(), self.prinicpalUID()) + slash
    2010-06-25 12:29:54+0200 [-] [caldav-8009] exceptions.AttributeError: 'DirectoryCalendarPrincipalResource' object has no attribute 'prinicpalUID'

    anybody and idea or help?

    Thanks in advance....

  • mike.habermeier Level 1 (5 points)
    Hi Stefan,

    i had the same problem.
    I have to download the files from the server andre has posted.

    When you edit the file via TextEdit or TextWrangler like me the file will
    be corrupt.

    I hope this helps.

  • Stefan Siebeker Level 1 (10 points)
    Hi Mike,

    thanks for you quick response on that issue. I can not find any download source posted by Andre. Can you please specify - maybe date or somehting? I only found his explanation and a link to another explanation......


  • mike.habermeier Level 1 (5 points)
    Hi Stefan,

    I found the edited file on the website he posted.
    You can download the fixed file here: lendarServer-2.5-dev -> erver-2.5-dev/twistedcaldav/directory/ -> Down on the buttom.

    And you can download it here: darServer-2.5-dev/twistedcaldav/directory/

    I did it that way:
    Stopped the iCal Server.
    Moved the to
    Deleted the principal.pyc
    Copied the new downloaded to the right place and restarted the
    iCal Server.

    I hope it helps.

  • Peter Meininger Level 1 (0 points)
    ct181 wrote:

    In the same file, /usr/share/caldavd/lib/python/twistedcaldav/directory/, before the "self._url = url" in line 534 add lines like these for each of your group calendar accounts:

    if url == "/principals/_uids_/fancy-hex-number-your-ical-client-gives-you/":
    url = "/principals/_uids_/wiki-groupname/";

    Then, if you restart the iCal server and change the URL in your iCal client back to the wiki groupname format, it works (even after restarting the iCal client).

    Your fix worked beautifully. All our shared wiki calendars work again from iCal, wiki & iPhone.

    If anybody has issues with this fix it may be improper indentation of the added code.
    It is not apparent in the forum post that the second line (starting with url = ) needs indentation (it is python code after all).

    if url == "/principals/_uids_/fancy-hex-number-your-ical-client-gives-you/":
    TAB url = "/principals/_uids_/wiki-groupname/";

Previous 1 3 4 5 6 7 Next