Skip navigation

Embedded YouTube Videos do not play

2968 Views 9 Replies Latest reply: Sep 16, 2013 12:17 PM by alcazar84 RSS
Dharma-mac Calculating status...
Currently Being Moderated
Jul 2, 2010 8:52 AM
I can play vides fine in YouTube directly. However if the video is embedded on a page like Facebook or Ebay it will not play. I get the message +An error occurred, please try again later+.

If I open the same page on Firefox the video plays fine.

I reinstalled flash, but that is not the problem. I noticed bug persists even with .mov/QT videos.

Message was edited by: Dharma-mac
2 x 2.8 Quad-core Xeon and others, Mac OS X (10.6), Safari 5
  • Carolyn Samit Level 10 Level 10 (84,070 points)
    Currently Being Moderated
    Jul 2, 2010 11:49 AM (in response to Dharma-mac)
    HI,

    If you didn't uninstall the old version of Flash then repair permissions, you should try that.



    Uninstall Flash

    Install the most recent version of Flash here.

    Adobe strongly advises repairing permissions after installing Flash.


    Launch Disk Utility. (Applications/Utilities) Select MacintoshHD in the panel on the left, select the FirstAid tab. Click: Repair Disk Permissions. When it's finished from the Menu Bar, Quit Disk Utility and restart your Mac. If you see a long list of "messages" in the permissions window, it's ok. That can be ignored. As long as you see, "Permissions Repair Complete" when it's finished... you're done. Quit Disk Utility and *restart your Mac.*









    Carolyn
    Intel iMac 2.66 iPad 32GB iPhone 3GS. MBAir, Mac OS X (10.6.4), QTPro Intuos Tablet Epson Olympus Airport iPods JBL
  • larryApitts Calculating status...
    Currently Being Moderated
    Jul 4, 2010 3:44 AM (in response to Dharma-mac)
    Had exact same problem - I got only audio from embedded videos, although they played fine on YouTube. I narrowed it down to the Flash Plugin which I had updated to the latest version (10.1 r53). I replaced this with the previous version (10.0 r42) and it is now working. Hope it stays that way
    iMac, Mac OS X (10.5.7)
  • larryApitts Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 4, 2010 3:32 PM (in response to Dharma-mac)
    I think that is the problem. As I said, 10.1.r53 doesn't work for me. Had to downgrade to get it to work. Appears that Flash and Safari are not playing well together with newer versions.
    iMac, Mac OS X (10.5.7)
  • Aldo Calculating status...
    Currently Being Moderated
    Aug 9, 2010 8:39 PM (in response to Dharma-mac)
    I have had the same problem for some time on my home computer. The pages work fine in Firefox and my computer at work.
    I did the uninstall and a new install of Flash but no luck, the new Flash is 10.1.53.64.
    I at one time signed up for the Youtube HTML5 beta do you think that could be part of the problem?
    Mac Pro 2.66 quad, Mac OS X (10.6.4)
  • alcazar84 Calculating status...
    Currently Being Moderated
    Sep 16, 2013 5:53 AM (in response to Dharma-mac)

    I have the same problem, but with Firefox.  Embedded YouTube videos don't play in non-YouTube web pages.  I can click the link in the top of the video to be taken directly to YouTube, and I can watch the video there, but when I click the big Play button in the middle of the video window, I just get a black rectangle.

     

    I tried uninstalling Flash player as suggested above, rebooted my machine, and reinstalled Flash player, but that did not fix the problem.  This is a non-Flash player problem that Apple should look into.  I have not tried this on other browsers to see if I have the same problem there or not, as I do not use other browsers besides Firefox.  I would rather not have to use another browser just so that I can watch embedded YouTube videos.  I would prefer if Apple (or another knowledgeable user) can post the solution to the problem.  Thanks!

  • Allan Jones Level 7 Level 7 (29,570 points)
    Currently Being Moderated
    Sep 16, 2013 9:07 AM (in response to alcazar84)

    Dredged up a three year-old thread. Can you make it into a new topic?

  • alcazar84 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 16, 2013 12:17 PM (in response to Allan Jones)

    Sure thing.  I did not notice the dates on the previous posts that they were that old.  I will create a new topic for discussion.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.