10 Replies Latest reply: Jul 7, 2010 4:56 PM by M1CH43L
M1CH43L Level 1 (5 points)
I have an old blue iBook G3 with an airport card that I use for surfing when I don't want to be tethered to my desktop computer. I recently replaced my Netgear router (that was dropping connections like crazy) with a fancy new Linksys WRT54G2. However, I'm having nothing but problems getting my laptop to connect to it. It works just fine if I make it an open network or if I use WEP. However, if I set it to WPA Personal, it doesn't. That's the protocol I prefer, since it's more secure and the password is easier to remember. I was using it before with the Netgear router, so I don't know why it wouldn't work with the newer router. Suggestions?

BTW: the iBook is running 10.4.11

PowerMac G4 MDD Dual 1GHz, Mac OS X (10.5.6)
  • BDAqua Level 10 (122,242 points)
    Hi M1CH43L, and a warm welcome to the forums!

    Could the new Router be using WPA2?

    The original AP cad only supports WPA on some Routers, but not WPA2...

    http://discussions.apple.com/thread.jspa?threadID=1353596&tstart=0
  • M1CH43L Level 1 (5 points)
    It was set up to use WPA2 out of the box, but I've dialed it back to plain old WPA Personal and it still doesn't let me log in. I still get the error message, "There was an error joining the AirPort network...".

    I just got off the phone with Linksys. They had me try changing the network name, password, and channel, but none of that helped. My boyfriend has a Windows 2000 laptop that connects just fine, so they decided it must be something wrong with the iBook. But what...
  • BDAqua Level 10 (122,242 points)
    Try opening Internet Connect click on the 802.1x icon, try setting it up that way.

    Do you know what Authentication protocol it uses?
  • M1CH43L Level 1 (5 points)
    Smart guy.... I think this might finally be getting at the heart of the matter.

    I launched Internet Connect and selected File > New 802.1X Connection (to add the icon you mentioned). Then I selected Edit Configuration. There are various fields to fill in that are easy enough, but when I get to Authentication, at the bottom, I'm stuck. These are the methods listed (on the iBook):
    TTLS
    TLS
    EAP-FAST
    PEAP
    LEAP
    MD5

    However, these are the methods listed on the router's setup page:
    TKIP
    AES

    Clearly, there will be no connecting of the dots. I guess, now, the question is, can I add an authentication protocol to either the laptop or the router? I'm glad to at least know what the issue is now.
  • BDAqua Level 10 (122,242 points)
    OK...

    The original Apple AirPort Card can be updated with firmware and drivers to handle TKIP; Mac OS X 10.3 Panther or later is required, however.


    http://db.tidbits.com/article/9846?print_version=1

    Though this thread seems to indcate "g" mode is required with Linksys!?
  • M1CH43L Level 1 (5 points)
    Thanks! This is certainly the first mention I've heard of TKIP, specifically, on the original airport card. I've contacted the author of the article and, hopefully, he'll be able to tell me where he found that bit of info. Maybe that will point me in the right direction.

    In the meantime, I thought that I would look to see if there's a standalone update for the original airport card, but Apple sure hasn't made it easy to find downloads on their site. It seems that all I can do is run a search and it's not turning up anything past the Airport update for OS X 10.3. There also doesn't seem to be any mention of TKIP in the entirety of their knowledgeable. Boo.
  • Matt Broughton Level 5 (4,980 points)
    M1CH43L wrote:
    In the meantime, I thought that I would look to see if there's a standalone update for the original airport card, but Apple sure hasn't made it easy to find downloads on their site. It seems that all I can do is run a search and it's not turning up anything past the Airport update for OS X 10.3. There also doesn't seem to be any mention of TKIP in the entirety of their knowledgeable. Boo.


    I found this thread while trying to set up a recently acquired iBook G3/500 (Dual USB) with a plain old AirPort card. I have an older Linksys WRT54G wireless router. Using OS X 10.4.11 with Airport Software 4.2.9 or OS X 10.3.9 with Airport Software 4.2.1, I was able to connect with Personal WPA TKIP without much difficulty.

    Don't get hung up on seeing TKIP as a choice under the Internet Connect section. I didn't see it listed on my Mac Mini G4 with OS X 10.4.11 and an Airport Extreme card. I also didn't see Personal WPA2 AES on that machine, but it worked. So Personal WPA TKIP does work in the "b" mode at least with my Linksys router.

    I hope this helps a bit in figuring out your situation.
  • ovidiub Level 1 (0 points)
    Hi guys,

    I have the same issue: older iBook G3 800Mhz (OS X 10.4.11) cannot connect using WPA/WPA2 password to Linksys WRT54GL router using DD-WRT firmware (www.dd-wrt.com). The airport was forcing the WEP password requirement though in System Preferences->Network->Airport it's allowed to add WPA/WPA2 password.
    The solution:
    1) in Wireless Basic Settings use:
    Wireless Mode: AP
    Wireless Network Mode: Mixed *
    Sensitivite Range (ACK timming): 0 *

    2) in Wireless Security:
    Security Mode: WPA2 Personal Mixed *
    WPA Algorithms: TKIP + AES

    * - required to get older Airport card connecting to WRT54GL

    I hope it helps.

    Cheers,
    Ovidiu
  • BDAqua Level 10 (122,242 points)
    Hi Ovidiu, and a warm welcome to the forums!

    Great 1st post & tip, thank you!
  • M1CH43L Level 1 (5 points)
    Ended up getting rid of the computer and am much happier with my MacBook.