Skip navigation

"Do you want iTunes to accept incoming network connections?"

104595 Views 98 Replies Latest reply: Dec 27, 2013 11:34 PM by themarkofbooks RSS
  • melwan Calculating status...
    I think I narrowed down the problem. I did the simple solution and it worked for me (basically reinstalling iTunes). Then, I fired up CleanMyMac and I did a system clean up. This involved removing the Universal Binaries and extra language files from iTunes.

    Guess what? the problem is back again. and now, codesign -v command is giving me the error "missing seal" again.

    Apparently, removing the Universal Binaries from iTunes along with the language files (~100 MB in total) results in that firewall pop up message.

    Is this a bug? CleanMyMac's fault? Apple's fault? Non of the other Apple software results in that problem btw and yes, I cleaned their Universal Binaries and language files as well.
    iMac '09, Mac OS X (10.6.2)
  • hbone Level 1 Level 1 (0 points)
    I just installed Snow Leopard on my Mac and this happened to me as well. I went to the Apple store because I had several problems including this one happen. The Apple Genius was stuck on this problem. I will try this, cause its very annoying to have all your settings removed and this pop up window appear every time you log on.

    All I wanted from SL was the 22GB of HD space back. ((sigh))
    G4 Quicksilver, iPhone OS 3.1.3, PowerbookG4 | Macbook Pro Unibody
  • Don Trammell Level 3 Level 3 (620 points)
    MBP17 Inch , 4 gig of ram,, Mac OS X (10.6.3), Shure SE 530's, iPhone 3G, Nikon D300s, Nokia E72
  • bitblasters Calculating status...
    Well I am seeing this problems as well. It also happens with another app I have. This started once I had to go get another DSL modem because my other one went out. Now I get this same message when ITunes starts up and also Ch-Ching, but when I try to connect with my iPhone to iTunes with Remote.app from the iPhone or Ch-Ching from my iPhone, they do not see that my iPhone is connected. Qwest is of no help here at all, they have no clue what I am talking about of course. This all worked fine until I put this new modem on and now it does not work. Does any one have any ideas on this?
    Mac Pro, Mac OS X (10.6.3)
  • Brad Cantos Level 1 Level 1 (130 points)
    I have been seeing this problem for several weeks now, and I think that you may be onto something with the CleanMyMac correlation. This link http://superuser.com/questions/42776/itunes-app-to-accept-incoming-network-conne ctions indicates that any modification of the package will trigger the message due to a verification feature. I tried the test shown on this page and indeed I get the broken link response:
    /Applications/iTunes.app/: a sealed resource is missing or invalid
    /Applications/iTunes.app/Contents/Resources/iTunesASUHelper: resource modified
    /Applications/iTunes.app/Contents/Resources/iTunesHelper.app/Contents/MacOS/iTun esHelper: resource modified
    So I think that removing the binary file may be the cause. I'll live with the problem rather than bloat my HD.
    iMac 27", MBP 2.2 GHz C2D, Mac OS X (10.6.3)
  • Duda Level 1 Level 1 (0 points)
    I think I had iTunes 9.1.1 installed in my MacBook Pro. And this message always appeared for me. Today I installed iTunes 9.2 and the problem persist. Here this message is directly related with "Sharing" option. If I uncheck "Share my library on my local network" the message go away. But If I mark this the message com back again.

    I didn't change my icon or anything else.

    I thought that this problem would be solved with an iTunes update, but I was wrong.
    MacBook Pro (15-inch, Mid 2009), Mac OS X (10.6.3)
  • mrcoxon Calculating status...
    hey I had the same problem with iTunes 9.2. I solved it though.. it might sound a bit of a hocus-pocus but what the ****: it worked. Here's what you gotta do:

    1. Drag iTunes.app to the Trash.
    2. Empty the Trash
    3. DO NOT delete any other iTunes-related file as you may lose all your data (preferences, library, songs, iphone apps and whatnot). You may want to restart your computer at this point, but it is not necessary.
    4. Download iTunes again. Install it... and you're done. It may ask you to accept incoming connections but it'll be only once... after that it won't bother you again...

    I hope this works for you!
    MacBook Pro 5,5, Mac OS X (10.6.4), MacBook Pro 13'' 2.53 Ghz
  • MacPaw Calculating status...
    iTunes is a code-signed application and if you clean it using CleanMyMac or remove the useless binaries from it in any other way - your System Firewall will be showing you that message (topic) every time you launch iTunes.

    That is why CleanMyMac has a separate setting for such cases in the Advanced tab of its Preferences. You can just disable the cleanup of code-signed apps to resolve the issue. That's it.
  • Erin Bird Calculating status...
    This worked for me! Thanks mrcoxon. I had been having this issue since upgrading to 9.2 and it was driving me batty. No more!
    MacBook Pro 15" 2.5 Ghz i5, Mac OS X (10.6.4), iPhone 3GS
  • Curtis Tucker Level 2 Level 2 (270 points)
    @Don Trammell

    Excellent advice!
    Macbook (Late 2008), Mac OS X (10.6.4), Mac mini (Mid 2010) iPad (Wi-Fi)
  • Shiznit• Calculating status...
    Thanks mrcoxon, worked a treat, easiest solution every, has to be ha ha
    MacBook Pro / Mac Pro / iMac, Mac OS X (10.6.4), iPhone 4
  • Jonathan Phillips Calculating status...
    I was having this issue too, very irritating. Having read all the posts decided to start with the removal of iTunes and a reinstall and it worked perfectly.

    Used this support page.. only need the first 20 steps

    http://support.apple.com/kb/ht1224

    Jonathan
    imac 24 inch, Mac OS X (10.6.4)
  • Marty McFly Level 1 Level 1 (5 points)
    This seems to have fixed it for me as well. Thanks!
  • queequeg731 Calculating status...
    I have tried everything in here and I still have the problem. I've had this problem since iTunes 8 and I've just about to throw it all out the window.

    Uninstalled iTunes 8 before installing version 9 when it came out - problem persist
    Uninstalled iTunes 9 before installing Version 10 yesterday - problem persist
    deleted that com.apple.alf.plist file. reboot. nothing changed.

    The only way to stop the stupid message is turning off the firewall (i prefer firewall on) - turn it back on again there is that stupid message again. its something that shouldn't be happening, had a gut full of it.
    iMac 2.66Ghz 20-Inch, Mac OS X (10.6), 4 GB Ram - 320 GB Hard Drive - 256 MB ATi Radeon 2600 HD
  • Flemming Rasmussen Calculating status...
    It doesn't work for me with the terminal command. But that's probably because i've changed the iTunes icon with my own: http://wearebigger.com

    The CleanMyMac suggestion doesn't do the trick either.
    Macbook Pro Unibody, Mac OS X (10.5.7), 3.06 GHz
1 2 3 4 5 ... 7 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (10)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.