Skip navigation
This discussion is archived

AT&T 3G MicroCell and iPhone 4

23021 Views 33 Replies Latest reply: Sep 25, 2010 8:00 AM by sdirghalli RSS
1 2 3 Previous Next
JPSabo Calculating status...
Currently Being Moderated
Jul 1, 2010 5:38 AM
I just set up an AT&T 3G MicroCell (just became available for sale in CT) as my 3G service at home is spotty (1-2 bars, sometimes 3) and drops calls. The MicroCell set up was easy (I used "Option C" which is priority mode configuration such that the MicroCell is between the cable modem and the AirPort Extreme). With the MicroCell activated I now get 5 bars.

The problem is that the iPhone 4 does not automatically switch to the MicroCell. If I put the phone into airplane mode, then turn airplane mode off, "Searching..." is displayed and then the phone picks up the MicroCell (displays "M-Cell" on the top line, eg. bars, AT&T, M-Cell, wifi signal, time, etc.). Same thing happens if I reboot...the phone starts up on the areas cell tower 3G network and locks in my home wifi network, but does not switch to the MicroCell. If I turn airplane mode on/off, it searches as I noted above, then locks on the MicroCell signal and all is well.

Anyone have a similar experience? Perhaps this is just an issue with the MicroCell being a new product and the iPhone needing a firmware patch to automatically use the MicroCell signal on an authorized phone when it is available?

Regards,
John
MacPro, Mac OS X (10.4.10)
  • Glorfindeal Calculating status...
    Currently Being Moderated
    Jul 1, 2010 5:44 AM (in response to JPSabo)
    This is only an occasional occurance with me. Normally, the iPhone 4 connects immediately to my microcell when I get home. You might want to try to restart your microcell, if you haven't already.

    glor
    Mac Mini 2.53GHZ/8GB/Blu-ray/500GB Seagate Hybird, Apple 24" LCD Display, Mac OS X (10.6.4), iPhone 4 32GB, iPad 3G 64GB
  • Nathan Goldshlag Calculating status...
    Currently Being Moderated
    Jul 1, 2010 6:41 AM (in response to JPSabo)
    I have exactly this problem, and some do not.


    When I am not on the phone, in 3G coverage, and come in the house I do not find the microcell on my iPhone4 and my wife's 3GS. This happened only after upgrading to OS4. I know some people have this problem and some do not. If you put it into airplane mode so you get Searching... it will find the microcell 100% of the time, with 5 bars. So those people who have really terrible coverage may have the phone go into Searching... mode by itself, connect to the microcell, and you may think it is working fine. I know some people do not have this problem and can connect just fine.

    I have tried resetting network settings and just got a replacement microcell with the same problem. Are others seeing this? I know some are and some are not. I have a case opened with AT&T and if you have this problem please go open a case with them - the more the better. Once again - this is not an iPhone4 issue but an iOS4 issue.
    MacBook Pro 17", Mac OS X (10.6.3)
  • Glorfindeal Level 6 Level 6 (9,330 points)
    Currently Being Moderated
    Jul 1, 2010 9:54 AM (in response to JPSabo)
    It's interesting that some see it and some don't. If it was a systemic problem, all iPhone/iOS4 devices would have this issue. I wonder if it can be regional.

    Glor
    Mac Mini 2.53GHZ/8GB/Blu-ray/500GB Seagate Hybird, Apple 24" LCD Display, Mac OS X (10.6.4), iPhone 4 32GB, iPad 3G 64GB
  • Nathan Goldshlag Level 1 Level 1 (100 points)
    Currently Being Moderated
    Jul 3, 2010 3:36 AM (in response to JPSabo)
    I do not believe it has anything to do with the primary number. Both my iPhone4 (primary number) and my wife's 3GS have the problem after upgrading to iOS4. With 3.1.3 my former 3GS and hers worked fine.
    MacBook Pro 17", Mac OS X (10.6.3)
  • AMTK54 Calculating status...
    Currently Being Moderated
    Jul 3, 2010 12:22 PM (in response to JPSabo)
    I am having the same issue. I've had a Microcell in my office for several months. I had a 3GS which always picked up the Microcell without issue. Since moving to the iPhone 4, the phone only picks up the Microcell sporadically at best and stays on the Macrocell network. The phone is definitely at fault - I have a work issued Samsung Rugby II that picks up the Microcell right away, just like my 3GS did.

    I'm guessing this is a software issue and will be corrected in the next update. I can't imagine how anything hardware related would cause this issue. There's obviously something wrong with the logic the phone uses to select cell sites. Other than this issue, my iPhone 4 has been working great.
    iPhone 4, iOS 4
  • robert.h.heath Calculating status...
    Currently Being Moderated
    Jul 10, 2010 10:47 AM (in response to Nathan Goldshlag)
    I have the exact same issue... two iPhone 3G's that worked fine with the microcell for the last two months, but since upgrading to IOS4, virtually no service despite five bars. Same thing with my new iPhone 4.

    I can send/receive text messages, but have a nearly 100% fail rate on outbound calls with the 3G's and about 90% fail rate with the iPhone 4. Inbound calls generally go straight to voice mail after one ring.

    This sure seems like an IOS4 / Microcell compatibility problem from my perspective.

    Any clues on how to downgrade a iPhone 3G to v 3.1.3 of the software?
  • Nathan Goldshlag Level 1 Level 1 (100 points)
    Currently Being Moderated
    Jul 10, 2010 11:48 AM (in response to AMTK54)
    I have 10 more days on my 30 days. If not fixed the microcell is going back. Live with marginal 3G at home, and try again in a few months.
    MacBook Pro 17", Mac OS X (10.6.3)
  • Miss Julia Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 10, 2010 12:57 PM (in response to Nathan Goldshlag)
    Hey –

    I set up the Microcell yesterday. Easy. Came up with 5 bars within about an hour. My iPhone 3GS picked it up. I was very pleased. The phone went to sleep. When next awakened, I had only a crummy 3G signal. I rebooted. No success. I rechecked my settings. I toggled Airplane mode off then on. I even restored. I called AT&T local. They thought it might it might be the SIM card, but recommended I call their tech support. They had no ideas but thought the SIM card could be bad. I now have a new SIM card and a 3GS that does not see the Microcell. My husband just got home from a trip with his 3GS. It picked up the signal right away and held it. He then transferred his SIM card to his new iPhone 4 and synced – it also picked up the Microcell and held it. We concluded that it was my 3GS that was the problem. So we put my SIM card in his old 3GS, and it would no longer pick up the Microcell. The Microcell is not the problem. I think I'm going to try getting AT&T to lean on Apple.

    Miss Julia

    Message was edited by: Miss Julia

    Message was edited by: Miss Julia
    MacBook Pro 2.53 Duo + Dual 2.5 G5 + iPhone 3GS, Mac OS X (10.6.4)
  • tthiel1 Level 2 Level 2 (160 points)
    Currently Being Moderated
    Jul 10, 2010 7:21 PM (in response to JPSabo)
    I went to get a Microcell a few weeks ago when i got my iPhone 4. They told me it was not compatible with the iPhone 4 yet. So this has changed?
    Mac OS X (10.6.4)
  • Miss Julia Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 10, 2010 7:34 PM (in response to tthiel1)
    Hey – My husband's new iPhone 4 works great with it. It's my 3GS that is not working. I called AT&T tech support again (800-331-0500) and they went through a bunch of stuff with me. Didn't fix it, so they have a ticket and have promised to get back to me by the evening of the 14th for a resolution. I'll post when I know more. This seems to affect just some phones. We both have iOS4 installed, but, from what has been posted here, it looks like the problem did not show up until the new OS. The tech person I talked to has found this thread. We may get an answer pretty soon.

    Miss Julia
    MacBook Pro 2.53 Duo + Dual 2.5 G5 + iPhone 3GS, iOS 4
  • Adidadi Calculating status...
    Currently Being Moderated
    Jul 12, 2010 6:47 PM (in response to JPSabo)
    I thought that resetting network under settings solved the problem. It did NOT. My wife's 3G iPhone that is not iOS4 has no problems. My 3Gs iPhone had no problems for a month. Now that I upgraded, only problems. Phone does not find microcell unless I do network reset or power cycle phone. only stays locked for a few hours. Then drops and will not reconnect.
    G5, Mac OS X (10.4.10)
1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.