Skip navigation
This discussion is archived

Magic Trackpad doesn't work correctly with Mac Pro "Early 2008"

17564 Views 10 Replies Latest reply: Dec 26, 2010 5:28 AM by Bobzon RSS
King Hippo Calculating status...
Currently Being Moderated
Jul 29, 2010 1:07 PM
Hi -- I received my Magic Trackpad for my Mac Pro 2008 (all software updated, running 10.6.4). I paired it no problem to the Mac Pro and had basic mouse functionality immediately. No gestures worked, but I remembered that there was a Magic Trackpad/Multitouch Update issued yesterday. So I checked Software Update and nothing showed up. I had to find and download the update manually, and it installed no problem.

So at last I have a "Trackpad" preference pane -- but it varies greatly from the one I'm supposed to have according to all the Magic Trackpad reviews:
http://static.arstechnica.com/applemagictrackpad/magictrackpadprefsars.png

^^Mine should look like that, but it instead looks like this:
http://imgur.com/XQHUk.png

Additionally, even though the settings for Trackpad Gestures "Use two fingers to scroll" and "Allow horizontal scrolling" and "For secondary clicks..." are checked off, they don't work. All I can do is basically move the cursor around and single click by physically pressing the Magic Trackpad.

What gives? How do I enable the Magic Trackpad preferences instead of plain Trackpad preferences which don't seem to do anything? I already tried re-pairing the bluetooth several times. The bluetooth signal is fine -- it just doesn't recognize it as a Magic Trackpad.
Mac Pro 2008 8x2.8, Mac OS X (10.6.4)
  • Eric Maier Level 1 Level 1 (45 points)
    Odd I got mine today and it's working fine with my early 2008 MP - you definitely have the wrong control panel in there, download the correct one here:

    http://support.apple.com/downloads/

    It's near the top of the list since it's a new update

    BTW after a while I've figured out using my middle-finger (the longest one) as the cursor mover instead of my pointer finger made it MUCH more comfortable. It's pretty nice!
    iMac CD/MacBook C2D/MacPro8x2.8/Mini Mid-2009, Mac OS X (10.6.2)
  • Laurel Grant Level 1 Level 1 (45 points)
    I'm having the exact same problem on a late '09 i7 iMac. It's showing the same Trackpad preference pane as my old Macbook did, and I don't have gestures, two-finger scrolling (it's checked but does not work), nor two-finger clicking.

    Weird. Going to redownload + reinstall the update.

    EDIT: Sorry, found this via a Google search, did not see this was in the Mac Pro forums.

    Message was edited by: Laurel Grant
    White Macbook 2.0gHz / i7 iMac / iPhone 4, Mac OS X (10.6.4)
  • MacFire Level 1 Level 1 (0 points)
    After three phone calls with Apple, after an archive and install, I found it was a conflict with a 3rd party Preference Pane - either "Application Enhancer" or Norton Utilities, which Comcast had issued. Either way, with them gone, a reboot, re-install of Magic TrackPad software and a re-pair of Bluetooth, I finally got the full trackpad Preference Pane and all pad functions on a 2006 MacPro.

    According to Apple and now me, install issues are not hardware, something else prevents the complete install of the Magic Pad software...
    MacPro 2.66 w/X1900 Video & 2Gb RAM, Mac OS X (10.4.7), 3 Drives,Parallels & 30" C Display
  • Laurel Grant Level 1 Level 1 (45 points)
    Hrm, I've a bunch of 3rd party preference panes. None of those ones you mentioned, but a few; I imagine USB Overdrive could be confusing it.

    Other canditates include 3ivx MPEG-4, Growl, LCD Manager, MacFUSE, n52te editor, and Perian. Think any of those could cause the issue?
    Mac Mini 1.42gHz / White Macbook 2.0gHz / iPod Touch 32gb, Mac OS X (10.5.4)
  • Will : Hi ! Level 5 Level 5 (4,305 points)
    Laurel Grant wrote:
    Hrm, I've a bunch of 3rd party preference panes. None of those ones you mentioned, but a few; I imagine USB Overdrive could be confusing it.


    There have been reports of USB Overdrive + Magic Trackpad issues. That's what I'd look into first.

    Unless the issue is related to any third-party preference pane, I don't think your other 3rd-party panes should cause any issues (though you never know).
    MacBook Pro (mid 2007)  iMac (early 2008)  iMac i5 Quad (Mid-2010) , Mac OS X (10.6.4)
  • stejones Level 1 Level 1 (5 points)
    I also spent the past couple days with an Apple support person trying to figure why my new Magic Trackpad was not working property (it was working and would pair with the Mac, but was essentially only a one-button mouse). I tried all sorts of possible solutions, even reinstalling Snow Leopard. It turns out that if you have USB Overdrive installed on your system, delete it. But that won't be enough, as you need to delete its adjunct file in HD\Library\Extensions. Unfortunately, I don't recall the name of the file I had to delete (sorry), but it had "usboverdrive" in its file name. (This is where it pays to have AppZapper, which will automatically find all associated files of an app so you can trash them all at once.)

    In any case, USB Overdrive was the culprit on my Mac, and I now have all features (i.e., gestures) working -- and the correct preference pane showing up -- for my Magic Trackpad. So for those of you with problems with this trackpad, first check to see if you have USB Overdrive in your Applications folder (if you don't see it there, check the Utilities folder in the Applications folder).

    steve
    Chicago, IL
    iMac (20-inch aluminum), Mac OS X (10.6.4), 4 gigs RAM
  • Geeerrrt Calculating status...
    I had the same issue.

    The Trackpad works perfectly after uninstalling USB-Overdrive!
    iMac 24" '09 + black MacBook '06 + iPhone 3Gs, Mac OS X (10.6.4)
  • Pawpaw Calculating status...
    Thank you for your post. I got rid of Application Enhancer (And the leftover USBOverdrive extension). Now my new Magic Trackpad works great.
    iMac 24", Twin 2.93, MacBook Pro 15, Mac OS X (10.5.6), 1TB Time Capsule, Apple TV
  • mpoinar Level 1 Level 1 (10 points)
    I'm sure glad I found this post because I spent all day long on the phone with Apple trying to figure out why trackpad wasn't working. I exchanged it, I downloaded the correct software, I reinstalled my system
    software all to no avail. I did ask if they thought the USB overdrive may be hindering it but they said no.
    The next step was doing an erase and install but I said I needed some time off first and while taking the time off, I found this and I uninstalled the USB overdrive and voila, the magic trackpad started to magically work!!! Thank you!

    I have emailed one of the apple agents I talked to today to let him what solved the problem.

    Martha
    Intel 21.5" iMac, Mac OS X (10.6.4), 3.06 GHz, Intel Core 13
  • Bobzon Calculating status...
    I was having the same problem with the Trackpad and for me it was the USB-Overdrive too. I didn't even know I had it - what does it do anyway?

    Problem solved when I uninstalled USB-Overdrive.
    IMac7,1, Mac OS X (10.5), Magic Trackpad

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.