4 Replies Latest reply: Aug 1, 2010 12:50 PM by Todd Heberlein1
Gary i Level 5 Level 5 (6,190 points)
I have a mac mini which runs only XBMC, thats all its there for. A remote control is all I need.

However every time I restart the mac, or quite randomly when it feels like it, it insists on pulling up the bluetooth assistant to tell me there is no mouse connected.

I know, this, I don't want a mouse connected thankyou!

Is there a way to actually turn this 'helpful' feature off, because for me its not helpful at all. I have top VNC from another mac to get it to go a way, an worse it will insist on being the front most window.

Intel iMac 24inch, macbook, mini intel, Mac OS X (10.5.2), Maxed up baby
  • 1. Re: The not very helpful bluetooth set up assistant
    musicwind95 Level 4 Level 4 (1,280 points)
    I don't know if you can disable it, but if you're sure you don't need bluetooth, you can try deleting the assistant application. Don't know what that might mess up. Have your OS X install disc ready just in case.

    Musicwind95 Aqua
  • 2. Re: The not very helpful bluetooth set up assistant
    Isaac Bardin Level 2 Level 2 (175 points)
    Musicwind: If you don't know, don't post it!! You say you aren't sure, so don't post your instructions you think could be wrong. I'm not trying to bash you here; I don't have a solution either; but I'm just saying.
  • 3. Re: The not very helpful bluetooth set up assistant
    Barney-15E Level 8 Level 8 (35,295 points)
    There is an option in Bluetooth system prefs to not ask when it starts up. I'm not sure if that applies all the time. It is under the Advanced… button.
  • 4. Re: The not very helpful bluetooth set up assistant
    Todd Heberlein1 Level 1 Level 1 (30 points)
    I assume you already have solved your problem, but in case someone finds this thread (like I did) trying to solve this problem (a headless Mac Mini Blue Tooth Assistant popping up at boot time), here is my summary:

    1) In System Preferences select "Bluetooth" and uncheck "On" button in order to turn off Bluetooth

    2) Click "Advanced..." button and uncheck "Open Bluetooth Assistant at startup when no input device is present"

    It seems that if I did not do this second step, even though I turned off Bluetooth, the Bluetooth assistant started up when there was no keyboard or mouse connected.