7 Replies Latest reply: Apr 13, 2011 10:25 AM by Yerman
Judy Level 4 Level 4 (2,235 points)
I have several mail accounts. I also have several macs and an iPhone and iPad.
These accounts are synchronized with MobileMe. All Macs run Snow Leopard.

The order of these accounts changes every so often on one of the macs, so that if I do not pay attention I read the wrong inbox. And then the order change propagates by MobileMe.

I can change the order back, but it just happens again. What could be causing this?

MBP 15 CD, MBP C2D 17, 17 Uni; TiBook, G4 MP500; iMac Grape, Orange,, Mac OS X (10.6.4), 60G iPodPhoto,4Gnano,8GiPhone, 32GiPhone3GS,32GiPhone4 1Gshuffle, 2TTime Capsule
  • 1. Re: Account order keeps changing
    Fabricej Level 1 Level 1 (35 points)
    Are you're sure it's the good forum to post in?
    I think there's a better support in MOBILE ME's support page.
  • 2. Re: Account order keeps changing
    thomas_r. Level 7 Level 7 (27,960 points)
    It's a question about Mail, not MobileMe, so of course it's the right forum!

    Judy, as to a solution to your problem, it's not normal for the account order to change. Is there any pattern to how it changes? (i.e., do you have two accounts that switch places, do they seem to cycle up or down, or does it seem to be completely random?)

    You could try quitting Mail, then deleting the file ~/Library/Preferences/com.apple.mail.plist. This will delete all your settings, and all your accounts, but should leave all your mail in place. When you open Mail again, it will act like it's being opened for the first time. Set up all your accounts again (make sure you kept all the settings info). Once you set up an account, Mail should automatically locate the mailbox on your hard drive and you should be back in business. Of course, when doing something so drastic as this, it would be wise to have a minimum of two good backups!
  • 3. Re: Account order keeps changing
    Judy Level 4 Level 4 (2,235 points)
    There does not seem to be a pattern. They just get mixed.
    I think it happens when I restart the Mac after it has been shut down.
    The next time it happens I am going to write down the order so that I can track it.
    Thanks
  • 4. Re: Account order keeps changing
    korm Level 1 Level 1 (0 points)
    I'm having the same issue as Judy. The accounts in the sidebar of Mail rearrange themselves. I've opened Preferences > Accounts and dragged the accounts into the order I want, and watched as they randomly rearrange themselves. If dragged the accounts in the sidebar, and then watched as they rearrange themselves. I've deleted ~/Library/Mail/Mailboxes/.mboxCache.plist (as suggested in another posting) and the accounts still rearrange themselves. It's as if some other process on the machine is changing the order, though AFAIK there's no process accessing mail accounts other than Mail. I've disabled Mobile Me syncing to see if that's a cause, but the rearranging continues.
  • 5. Re: Account order keeps changing
    kaz78 Level 1 Level 1 (0 points)
    i have been experiencing the same for quite some time and have tried all kinds of things, such as deleting the plist, creating a new user account (which is what Apple always tells you to do, but ends up being a waste of time). i believe it is a problem with MobileMe...
  • 6. Re: Account order keeps changing
    kaz78 Level 1 Level 1 (0 points)
    i am still experiencing the same problems where all my mail accounts keep switching order every time my computer sync via mobileme. it is very annoying and i am wondering if anyone found a way to fix this issue. i assume everyone else is having the same problem?
  • 7. Re: Account order keeps changing
    Yerman Level 1 Level 1 (0 points)
    Try this...

    System Preferences > MobileMe - Turn off auto sync
    Rearrange order of accounts the way you want them in Mail > Preferences
    Close Mail
    System Preferences > MobileMe > Sync tab > Advanced > Reset Sync Data > Replace info on MobileMe with info from computer
    Let it finish
    System Preferences > MobileMe > Sync tab > Turn auto sync back on