Skip navigation

No SMTP Authentication for Thunderbird or Outlook?

7656 Views 16 Replies Latest reply: Nov 19, 2012 7:29 AM by MrHoffman RSS
1 2 Previous Next
Paul Cezanne Calculating status...
Currently Being Moderated
Sep 12, 2010 9:22 AM
Wow, this one is killing me. I have a Mini with Snow Leopard Server running mail. I use CRAM-MD5 authentication and SSL connections for both IMAP and SMTP.

I HAD to get a Windows 7 netbook to run QuickBooks and Office (not my choice), so now I'm trying to connect either the Outlook 2010 client or a Thunderbird client with one of my accounts so QuickBooks can send invoices, etc...

I was able to connect to IMAP with both clients using the SSL connection. I can't remember the level of authentication that worked for Thunderbird, but I had to drop to PLAIN for Outlook to work.

Now the hair-pulling problem... The SMTP authentication and connection methods don't work for either client. NONE of them in any combination. Even dropping SSL and going to PLAIN don't work.

Does anyone have any idea what this is all about?

Thanks.
MacBook Pro, Mac OS X (10.6.4), MacMini Server - latest Snow Leopard
  • MrHoffman Level 6 Level 6 (11,710 points)
    What are the exact error message(s)?

    How is the local network configured?

    Are you even able to connect to the mail server via telnet?

    If you're getting to the mail server, can you connect to port 25? (eg: using telnet to connect to port 25)

    If you can connect into port 25 via telnet, is it responding like a mail server?

    If you've connected to port 25 and it's a mail server, what (other) ports are you connecting to?

    Are you using authenticated connections for sending? Port 587, etc.

    If you're connecting, what sort of relevant "stuff" might be present in the mail server logs after a failure?

    Can you connect from that Windows 7 box and clients to another IMAP or POP3 server elsewhere?

    I'd also encourage you to pursue this with the Microsoft Windows and Microsoft office forums and folks; Windows is the most central part of this, and you're here connecting to a standard IMAP or POP3 server. Which means this is primarily with the client platform, and secondarily with the server. You could, for instance, be connecting that Windows box to most any platform.
  • aliaspc Calculating status...
    Paul, I'm getting a similar message from Outlook 2010 on my new iMac saying cannot connect with outgoing server. Server requires authentication. Is this in anyway similar to your issue? I can receive email from my Verizon ISP mail server using Outlook but cannot send. Have searched Microsoft Outlook Q&A, and found suggestion to try different ports, but those efforts failed as well.
    imac11,3, Mac OS X (10.6.5)
  • UptimeJeff Level 4 Level 4 (3,390 points)
    The outlook issue is probably a helo restriction.
    Look in main.cf

    Change
    smtpdhelorestrictions = rejectinvalid_helohostname rejectnon_fqdn_helohostname

    to this
    smtpdhelorestrictions = permitsaslauthenticated permit_mynetworks rejectinvalid_helohostname rejectnon_fqdn_helohostname


    In Outlook, use port 587/TLS (not ssl)
  • AlvaroL Calculating status...
    I do have a similar problem, and it is a helo command rejected. The exact message is:

    The message was not sent, one of the destinations was rejected by the server. Your e-mail address is "alvaro@ledific.com". Subject 'test', Account: 'mail.incontrol.com.ec', Server: 'mail.incontrol.com.ec', Protocol: SMTP, Server answer: '504 5.5.2 <ALVARO>: Helo command rejected: need fully-qualified hostname', Port: 25, Security (SSL): No, Server error: 504, Error number: 0x800CCC79.

    All my Macs work fine, but PCs with Windows (XP,7,Vista) receive mails but can´t send e-mails.

    If this is something I have to change on main.cf, where can I find this file?

    I am using a Mac Mini as a server with the latest Snow Leopard version
    Mac Mini, Mac OS X (10.6.5)
  • UptimeJeff Level 4 Level 4 (3,390 points)
    do this, open Terminal and copy/paste this:


    sudo postconf -e "smtpdhelorestrictions = permitsaslauthenticated permit_mynetworks rejectinvalid_helohostname rejectnon_fqdn_helohostname"



    sudo postfix reload



    that should fix it
  • jlisburn Calculating status...
    I'm having continued problems with this issue and none of the solutions listed helps me out. Some Windows/Outlook clients can connect and some can't. Al have different combos of Windows and Outlook versions and their doesn't seem to be a common thread.
    Windows 7 Outlook 2003 - no go
    Windows 7 Outlook 2007 - 2 good, one no go
    Windows 7 Outlok 2010 - fine
    Windows Vista Outlok 2007 - fine
    ??????
    MacMini 8Gb 2.66Ghz Core Duo, Mac OS X (10.6.6), Snow Leopard
  • Jeff Donovan Calculating status...
    im not sure what the settings are but im working on a similar issue.

    definitely use STARTTLS on either port 25 or 587
    you can test your connection by telneting to it:587

    verify that tls is enabled in your master.cf

    ** STMPS port 465 is disabled by default in osx server main.cf. you can uncomment the lines to allow SASL.

    you can also try
    brokensasl_authclients = yes
    # this is to support outlook and other clients

    gl

    iof anyone knows how i can get sasl to read ldap for passwd im all ears.
    IIe Dual Floppy, Mac OS X (10.5.8)
  • MO_Mule Calculating status...
    UptimeJeff

    Thank you for that, that worked perfectly. That was the answer for me, and probably answered this thread, but I didn't start it...
    Mini Server, Mac OS X (10.6.6), Xserve 10.4 Xserve 10.5
  • jpawelchak Level 1 Level 1 (0 points)

    Is the following correct? why does "= permitsaslauth..." look funny to me?

     

     

    sudo postconf -e "smtpdhelorestrictions = permitsaslauthenticated permit_mynetworks rejectinvalid_helohostname rejectnon_fqdn_helohostname"


     


1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.