8 Replies Latest reply: Nov 21, 2010 6:22 AM by Robert Carneim2
Vern Dempster Level 1 Level 1 (20 points)
Continuing afp user issues. 2 weeks ago, over the weekend did a complete clean 10.6 server reinstall- upgraded to 10.6.4, ditto copied mail and restored ldap users from backup.( can do it in my sleep now) A wonderful faster server- all working well for 10 days and now back to crashing regularly ie users lose connection to their home folders in the users folder. the server keeps working but must be restarted to fix user folders (often this happens during the same period - same classes). Please can Apple or any of you offer thoughts. This is a 4 month nightmare since 10.6.3 that makes apple servers look second rate. My 10.6.2. web server is still running flawlessly. I have contacted support and got 3 sympathetic listeners but no solution forth coming and no followup at all from support.- this is cross posted from 10.6.3 crashing in setup and migration sorry but I am now desperate. How can this work well for 10 days then start crashing? I suppose if I did it again I might get another 10 days of peace.:-(

xserve, Mac OS X (10.6.4)
  • 1. Re: Users losing connection to their afp share point on a daily basis
    InterHmai Level 1 Level 1 (60 points)
    Do you have time machine on? If so, turn it off.
  • 2. Re: Users losing connection to their afp share point on a daily basis
    Vern Dempster Level 1 Level 1 (20 points)
    Time Machine is turned off. I am aware of that. I dont use Server Admin or WGM on the server only remotely. But it just seems during periods of high workload afp dies. I am about to rebuild the server yet again but only take it to 10.6.2 this time. Maybe I will get another 10 days of trouble free fast server to get me through to the holidays!! I have just realised it has been crashing now for 2 terms. of frustration for our teachers and students.
  • 3. Re: Users losing connection to their afp share point on a daily basis
    Brett Thornsberry1 Level 1 Level 1 (20 points)
    Have you checked the console log for any ideas both on a user's machine and the server?

    Energy-Saver/sleep settings on both server and client?
  • 4. Re: Users losing connection to their afp share point on a daily basis
    Vern Dempster Level 1 Level 1 (20 points)
    I have moved mail to my reliable 10.6.2. web server and reinstalled a clean 10.6.2 on our xserve. And hope I get through the next 10 days till holidays- this problem has gone on 2 terms now. It did seem faster when I tested student logins but tomorrow will be the real test.
  • 5. Re: Users losing connection to their afp share point on a daily basis
    A.Epstein Level 1 Level 1 (0 points)
    We have a small, 8 node network of OSX 10.5.8 clients mounting AFP shares from an OSX 10.6.x server. Users report that when another person in the office finishes for the day and shuts their machine down, they lose their connection to the server. This is not an issue of Time Machine or clients falling asleep. The bumped user can simply reconnect but it's a significant annoyance. It seems a bit worse since the server was replaced with the current 10.6.x Mac Mini, but it used to happen, although less, when there was a Mac Pro (G4) server running 10.3.9. The only other recent change (besides the server upgrade), is that the 2 small daisy-chained switches were replaced by a 16 port switch. Same router, same wiring, same service.

    At first I thought there was some trick or operator error, but it appears that is not the case.

    What could cause other users to be bumped when someone shuts their Mac down? Otherwise, everything works well.


    _Stumped
  • 6. Re: Users losing connection to their afp share point on a daily basis
    Jamie Curmi Level 2 Level 2 (220 points)
    Are you sure AFP is actually "dying"?

    Are you using Calendar Server, and if so, do people have the same connection errors?

    I ask because we have this happen a lot, and we find that if we go to "Server Preferences", and click on "Users", and then click on each user's name, suddenly they can log back in. Can you see if that "fixes" the issue for you?
  • 7. Re: Users losing connection to their afp share point on a daily basis
    A.Epstein Level 1 Level 1 (0 points)
    The AFP is not 'dying' as often others are still connected.

    What happens is persons A, B, C are connected to 1 AFP share. A shuts down, B is disconnected from the share and C remains connected. B can immediately reconnnect and continues.

    We are not using Calendar server. In fact at this point we're only using AFP, SMB, Open Directory services.
  • 8. Re: Users losing connection to their afp share point on a daily basis
    Robert Carneim2 Level 1 Level 1 (115 points)
    I've been posting in other threads, trying to track down this issue. I'm having this problem, but I thought it was due to the 10.6.5 update. (I wasn't running a domain configuration on any Snow Leopard systems until the 10.6.5 update.)

    So, I have a domain account; I log in with this account from the client and create a mobile account; the share point containing the network home directories is automatically mounted; this share gets unceremoniously disconnected at some random time (usually less than an hour); I can open that connection again from the client with no problem, but the running apps can't handle the interruption (for example, my iTunes Media is on that share, but outside my home directory). Also, my TGT and the ticket for the server are intact.



    *Now, if I log in to the client with a local account and then connect to the server share with my domain credentials, the share stays connected just fine.*

    I'm going to have to live with this setup for a while I guess (this is what I was doing previously anyway), but I don't like having the separate local home directory that doesn't sync to the server (automatically).

    -Bob