Skip navigation

iphone deleting emails automatically after two days...why?

144275 Views 50 Replies Latest reply: Mar 6, 2014 6:11 AM by Cornilios RSS
1 2 3 4 Previous Next
k-dub-b Level 1 Level 1 (0 points)
Currently Being Moderated
Sep 17, 2010 1:37 PM
i've been receiving my emails in my pop account via outlook and on my iphone for a couple of years now. i have it set up so that if i delete one on my iphone it is NOT deleted in outlook/laptop. all of the sudden two days ago, everything that was in my inbox that was older than two days was deleted...over 100 emails. i checked my iphone trash folder and they weren't in there. what happened? now it's automatically deleting emails from tuesday and early wednesday. they're still in my outlook, just not staying in my iphone/inbox. i checked 'settings' and i still have it set not to delete up to 200 emails.
iPhone OS 3.1.3
  • Bob07860 Level 1 Level 1 (0 points)
    I have a similar problem. Twice, all email disappeared. Using imap and email was also deleted from server. Gone forever. iPhone 4. Anyone else?
    All, Other OS, Many Macs, Phones and PCs
  • nu2010RN Level 1 Level 1 (0 points)
    This has happened to me 3 times now. I have called ATT and apple support. Everyone is blaming the other side and no one can help me. Just happened today and approximately a month ago. Never had these issues with my Blackberry.
    HP, Windows Vista
  • MLadd Level 3 Level 3 (645 points)
    Try looking at the settings for the specific account. From Mail, Contacts, Calendar settings, tap on the specific account you are having a problem with. Then tap on the Account tab at the top (usually has your E-Mail address in there also). You should see your server information. Down at the bottom tap on Advanced.

    Go to Deleted Messages. I think you may have "Remove" set to Day. Change Remove to be never, or Week or Month.
    2.8 ghz MacBook Pro Core 2 Duo, iPhone4 32Gig, iPad:16G WiFi, 64G WiFi+3G, Mac OS X (10.6.5), Newton 2100, iPod 5G 30gig, iPodShuffle 1gig, Apple ][e
  • LarsC Level 1 Level 1 (0 points)
    Hi MLadd,
    I am sorry to say and I might be blind but I don't have that setting. I just wanted to check to make sure that nothing gets deleted. When I am in Mail, Contacs, Calendars then the Account, then Account (with Mailadress) I don't have the "Advanced" tap you said... can someone help me out?

    Best regards,
    iOS 4
  • jk2563 Level 1 Level 1 (0 points)
    Has anyone had any luck with this yet? I am having a similar problem that started just a month or two ago. However, not all emails are being auto-deleted, only those received from stores/companies, etc. Reminder emails I send to myself are not affected. Fortunatrly, my Outlook/Entourage keep emails there. I see the above-mentioned setting in one of my two email accounts. It is set as, NEVER, though.
    MacBook, Mac OS X (10.5.4), 2GB 667 MHz DDR2 SDRAM
  • azas76 Level 1 Level 1 (0 points)
    I am having the same trouble, it always deletes my yahoo mail. There is no setting for auto delete. either on the iphone or yahoo.
    becoming very annoying.
    please help someone!!
    iphone, iOS 4, email delete
  • Sam-Dog-Man Level 1 Level 1 (0 points)

    I also found the same problem.  turned off the auto delete after one week.  and found the deleted files in the trash.

  • abelsuk Level 1 Level 1 (0 points)

    Same here, been using imap protocol for my mail on iphone 4. Emails download ok to the inbox, moving to sub folders seem ok - they move and are there visible in the folders. Alas, only for a couple of days before the moved mails miraculously diappear, nowhere to be found. Ive searched my whole mail box (every folder individually) for the elusive mails... and nothing.

     

    Deleted my yahoo mail account and been manually using safari to access my inbox for a week no and voila no disappearing emails.

     

    Apple we would like a response to this please there are archived posts from 2007 with multiple users reporting this problem. Please help, at this moment in time (for me certainly) the mail app is just a waste of screenspace on the iphone.

  • Lihaha Level 1 Level 1 (0 points)

    IOS5

    Settings>>>Mail, Contracts, Calendars>>>Accounts(Mail)>>>Mail Days to Sync>>>Choose you want

  • abelsuk Level 1 Level 1 (0 points)

    This has been furnished as a solution in other forums, but is NO solution as there is no such option as "Mail Days to Sync".

     

    iOS 5.0.1 menu structure as follow

    ...>>Mail, Contacts, Calendars

                                 |--Accounts (select affected account)

                                 |    |--Account (eg. abc@yahoo.com)

                                 |    |      |--Name>>Txt field

                                 |    |      |--Address>>Txt Field

                                 |    |      |--Password>>Txt Field

                                 |    |      |--Description>>Txt Field

                                 |    |      |--Outgoing Mail Server>>Txt Field

                                 |    |      |--Advanced

                                 |    |             |--Mailbox Behaviours>>Drafts Mailbox/Deleted Mailbox

                                 |    |             |--Incoming Settings>>Use SSL/Authnetication/IMAP Path Prefix/Server Port

                                 |    |             |--S/MIME>>On/Off

                                 |    |

                                 |    |--Mail>>On/Off

                                 |    |--Calendars>>On/Off

                                 |    |--Notes>>On/Off

                                 |    |--Archive Messages>>On/Off

                                 |

                                 |--Mail>>Show / Preview / Minimum Font Size etc....

     

    Nowhere can I find a "Mail Days to Sync" option, Am I missing something obvious?

  • iBuyiPhones Level 1 Level 1 (0 points)

    Not sure if anyone else is noticing this but the disappearing only happens to me when I open mail app and quick view an email before the app finishes updating. It then vanishes while I'm reading the message once the iPhone completes its "push" update of the server emails.

  • callumfromlivingston Level 1 Level 1 (0 points)

    hello had the same problem just fixed it a moment ago what you need to do is dellete the account off the iphone for now and make it again but this time when it ask you like google mail yahoo hotmail all that jazz dont pick any of them pick other set it up then you will have the advanced option again and can change it to never so heres a run down

     

    settings

    mail,contacts,calenders

    account affected delete it

    add account

    then down to the bottom hit other

    add mail account

    enter your details hit done

    go to bottom in account just above delete is advanced

    onec in ther look for delete from server and select never

     

    and this was all due to the 5.0.1 update changing a few setings hope this helps everyone

  • iBuyiPhones Level 1 Level 1 (0 points)

    I hope you're right. I'm about to try it now. Thanks alot.

  • abelsuk Level 1 Level 1 (0 points)

    Thanks callumfromlivingston, good thought. Have thought something similar before, but been to sceptical to try it though. Wouldn't want to lose any more mails everything since sept has disappeared. Wonder if this date coincide with the 5.0.1 update...

     

    Can you please post if your solution works for definite and stops mails disappearing. If it does, sure I (and no doubt others) will happily follow your lead :-)

1 2 3 4 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.