Skip navigation

Stereo - no surround sound

59341 Views 77 Replies Latest reply: Feb 21, 2013 6:55 AM by mdominic70 RSS
1 2 3 ... 6 Previous Next
Phil McFarlane Calculating status...
Currently Being Moderated
Sep 30, 2010 5:30 PM
Hi gang,

Setup of my 2nd Gen ATV has gone very smoothly. Only one problem. All movies play as stereo, even when there is a 5.1 surround track. When I go into the Audio settings, if I turn Dolby Digital from Auto to On and then play a movie, my receiver say "Stereo Downmix". My ATV and receiver are connected by an HDMI cable.

Any ideas?

Cheers!
MacBook Pro, Mac OS X (10.6.1)
  • Skrocki Calculating status...
    Currently Being Moderated
    Sep 30, 2010 6:03 PM (in response to Phil McFarlane)
    If you are connected from ATV to TV then to your receiver, your TV may only be capable of outputting a stereo signal. This is the situation with my Samsung plasma TV. In order to get Dolby Digital, I have to connect from ATV directly to the receiver with the optical audio cable.
    Mac Pro 2.66 12gigs ram, 3.5 tb HD, 15" MacBook Pro 2.5GHz, Wacom Cintiq 20WSX,, Mac OS X (10.6.4), HP DreamColor Display, iPhone, Apple TV2
  • TRado Calculating status...
    Currently Being Moderated
    Sep 30, 2010 6:37 PM (in response to Phil McFarlane)
    I'm having the same exact problem. What is up with 5.1 surround. I've tried ATV > Receiver both with only HDMI, and also with HDMI plus SPDIF for audio. Both only play in stereo here to. Keep me posted if you find a fix.
    Black MacBook, Mac OS X (10.6.4)
  • J.R. Bookwalter Level 1 Level 1 (15 points)
    Currently Being Moderated
    Sep 30, 2010 8:42 PM (in response to Phil McFarlane)
    I had the same issue tonight but it magically corrected itself after I played an iTunes-purchased video with 5.1 audio -- in this case, the free series premiere of LAW & ORDER: LOS ANGELES. After trying that one and getting 5.1 sound, I went back to my own Handbrake-encoded movies and TV shows and lo & behold, suddenly the 5.1 audio is working on everything!

    Anyone else have any luck with that?

    JRB
    Late 2008 MacBook Pro 15", Mac OS X (10.6.4)
  • Mb1000 Calculating status...
    Currently Being Moderated
    Sep 30, 2010 9:15 PM (in response to Phil McFarlane)
    Try optical!
    Mac OS X (10.6.4)
  • Vassillios Calculating status...
    Currently Being Moderated
    Oct 1, 2010 6:38 AM (in response to Mb1000)
    "Try optical! "

    What a ridiculous statement. The whole point of HDMI is to carry video and multi-channel audio.
    Mac OS X (10.5.6)
  • TRado Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 1, 2010 7:56 AM (in response to Mb1000)
    I did (as I stated above) and it doesn't work.
    Black MacBook, Mac OS X (10.6.4)
  • BobPenn Calculating status...
    Currently Being Moderated
    Oct 1, 2010 9:36 AM (in response to TRado)
    I had the same problem. My 5.1 purchase of a TV show was coming in stereo. I went to the audio and video part of the menu and saw that the Dolby Digital was set to "auto." I reset it to "on" and 5.1 started working. I assume that the auto setting doesn't detect properly.
    iMac i7, iPad 3G, Mac Book Pro, Mac OS X (10.6.3), Apple TV 160GB
  • J.R. Bookwalter Level 1 Level 1 (15 points)
    Currently Being Moderated
    Oct 1, 2010 11:09 AM (in response to TRado)
    Interesting that this thread isn't getting more posts... I find it hard to believe that only a few of us aren't getting 5.1 audio playback!

    For those of you my earlier tip didn't work for: You might also try the following tip to enable 5.1 passthrough on your Mac via iTunes... I had actually done that first but it didn't change anything on ATV until I played an iTunes-purchased video and then suddenly all of my Handbrake videos also started playing 5.1, so I think one or the other must have jarred something awake on the ATV. (I should note that I am using only HDMI so I can't vouch for the optical audio out.)

    http://www.macworld.com/article/150554/2010/04/itunes_surround.html

    In any event, it seems that Apple may have some work to do in the next ATV update to correct this situation, but the above worked for me and it's continued to work even after unplugging the ATV and booting it back up, so it's worth a try...

    JRB
    Late 2008 MacBook Pro 15", Mac OS X (10.6.4)
  • J.R. Bookwalter Level 1 Level 1 (15 points)
    Currently Being Moderated
    Oct 1, 2010 11:19 AM (in response to J.R. Bookwalter)
    I think I've stumbled on at least one thing that makes a difference: When the audio language is set to English (ATV settings) I get stereo and no 5.1... when it's set to Default, I get 5.1. It also seems to help to switch the Digital Out from Auto to On as mentioned above...

    JRB
    Late 2008 MacBook Pro 15", Mac OS X (10.6)
  • MoBoarder Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 1, 2010 12:07 PM (in response to J.R. Bookwalter)
    I've switched around everything. Using optical, but still no 5.1...... argh
    Several, Windows Vista
1 2 3 ... 6 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.