Skip navigation

Itunes 10 homesharing not working

214163 Views 182 Replies Latest reply: Oct 24, 2013 5:28 AM by kcullinan RSS
1 2 3 ... 13 Previous Next
ediblecrayon Calculating status...
Currently Being Moderated
Sep 19, 2010 9:32 AM
Homesharing was working fine on my PC and laptop, and one day it just stopped working at all! I sign in to the same Itunes account on both computers, they are both authorized, and then when I click the 'done' button, the home sharing goes away, never to be seen again! I have both itunes opened on both computers at the same time, and still nothing. Dont know what to do! Please help!
Itunes 10, Windows XP
  • Jolly Giant Level 7 Level 7 (25,430 points)
    Currently Being Moderated
    Sep 19, 2010 10:09 AM (in response to ediblecrayon)
    have you seen this support article ?

    JGG

    27"iMac11,1/2,8GHz/12GB/i715"MBP3,1/2,4GHz/4GBMini3,1/2.26GHz/2GB, Mac OS X (10.6.4), TC 'sim-d' 500 GBAEBSn2x AX (b/g)ATV 40 GBTouch 2G iOS 4iPad wifi 16 GB
  • ladyofsalem Calculating status...
    Currently Being Moderated
    Oct 3, 2010 6:33 AM (in response to ediblecrayon)
    I have exactly the same problem! I use mac and my husband uses a windows pc, but we both have iphones. He wanted to put all his music on his own pc instead of using mine so we installed itunes 10 on the windows pc. I did this previously with his old pc with itunes 9 and it worked no problem, but now, as soon as he clicks done - its gone.
    I can see his list, no problem, but he can't access my library.
    We are using the same shared port, my permissions are set correctly for sharing, no firewalls are turned on. What seems to be happening is an itunes 10 thing, isn't it?
    Any help would be great!
    imac, Mac OS X (10.6.4)
  • Natilus13 Calculating status...
    Currently Being Moderated
    Oct 9, 2010 7:03 PM (in response to ladyofsalem)
    I'm having similar problems too and have been scouring the net for the past few hours with no luck in finding a solution. Right now on my home network I have 3 machines that have iTunes installed (all the latest version), my MacBook Pro running 10.6.3, my wife's Mac Mini running 10.6.4, and our HTPC running Windows 7 Ultimate 32-bit. My MacBook Pro and PC have no problem using Home Sharing but the Mac Mini refuses to co-operate. The only way I can get it to see any other libraries, or for it to share it's own library, is to turn on network sharing. This works, but it isn't as nice as Home Sharing (when Home Sharing works that is :P ) I've followed all the instructions listed on Apple's site to enable Home Sharing on all the machines. Obviously I've done something right as the MBP and PC talk fine. The only thing I can think of is that it has something to do with 10.6.4. If anyone has any suggestions I am certainly open to hearing them.
    Which one?
  • RickyRoma100 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 10, 2010 2:41 AM (in response to Natilus13)
    I've also experienced the same issue. I'm using the latest iTunes 10.1 on Windows XP. When I am in the process of activating Home Sharing in iTunes the Home Sharing catagory is visible in the left hand panel, however, as soon as I click 'Done' to complete the setup the Home Sharing catagory disappears from the left hand side panel.

    Please fix this ASAP Apple.
    Windows XP Pro
  • swiegel Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 14, 2010 8:35 PM (in response to ediblecrayon)
    same exact problem here
    Windows 7
  • jhwalker Calculating status...
    Currently Being Moderated
    Oct 16, 2010 9:08 AM (in response to swiegel)
    Same problem here - two wireless Mac laptops work correctly (i.e., show each other's libraries and the library of my Windows desktop), but the Windows desktop will not show the libraries of the two wireless Macs

    All on the same IP network, all working fine except for Home Sharing.
    Mac, Mac OS X (10.6.4)
  • AdWizard52 Calculating status...
    Currently Being Moderated
    Oct 16, 2010 5:03 PM (in response to ediblecrayon)
    Yeah.. this is ridiculous. That'll teach me to just upgrade without waiting to see all bugs that appear in a new version. I was using Home Sharing fine till I upgraded my itunes to the new version. 10.0.1. Now just as everyone else is saying the Sharing icon just disappeared and can't be found. Useless.
    G5, Laptop ibook
  • Kim-Khoi Tran Calculating status...
    Currently Being Moderated
    Oct 17, 2010 3:30 AM (in response to ediblecrayon)
    I have the same problem I wonder if we could go back to iTunes 9. Cause it was working good back then. My 2 Macs works fine but my Windows 7 does not show home sharing!
    Mac Book Pro
  • NJN1 Calculating status...
    Currently Being Moderated
    Oct 20, 2010 4:15 AM (in response to ediblecrayon)
    I think I might have found a work around for this issue,which I also had. Go to advanced and turn off home sharing,then turn it back on. Before clicking done, click on hide next to the sharing icon in the sidebar. The create a home share box should then close. Once it closes, unhide the home share icon in the sidebar.
    HPm480n, Windows Vista
  • NJN1 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 20, 2010 5:08 AM (in response to NJN1)
    Forget it...it showed but still didn't work...then I closed iTunes and reopened...and it was gone.
    HPm480n, Windows Vista
  • txfeinbergs Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 20, 2010 8:48 AM (in response to NJN1)
    Same problem here. Been pulling my hair out trying to get my Apple TV Gen 2 to work with Itunes 10.0.1, but it is a lost cause. I also can't get HomeSharing to work between my two Windows 7 machines. Both machines are in Home Groups and can share files / printers/ etc without issue. I was able to get earlier version of Itunes to work (sporadically).

    Obviously apple SW with regards to Windows Networking has a lot to be desired.

    I deleted Bonjour and reinstalled it, but that didn't solve anything.
    PC, Windows 7
  • Natilus13 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 20, 2010 1:53 PM (in response to Kim-Khoi Tran)
    OK, I believe I found the solution... at least this worked for my setup of my MacBook Pro, iPod Touch, Windows 7 box, and my wife's Mac Mini and iPod Touch. What I had to do was log into my iTunes account on each machine and deauthorize them. I then did the same using my wife's iTunes account. I then went back and authorized each machine again using both mine and my wife's account.. voila! Everything is showing up and working correctly. We can now access any library from anywhere in our home and play them by using the nifty little remote app on our iPods. This worked for me and hopefully it will solve the problems that at least a few other people out there are having.

    Cheers, and thanks Apple for helping us fix this :P
    Computer
  • txfeinbergs Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 20, 2010 2:16 PM (in response to Natilus13)
    What if you only have one Itunes "family" account for which multiple computers are authorized? i.e. I guess I would go and deauthorize my wife's computer, and my computer for our "family" Itunes account, and then reauthorize them. I will give it a shot.
    PC, Windows 7
1 2 3 ... 13 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (7)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.