Skip navigation
This discussion is archived

iChat File Transfer port issue (can't listen to port 5190 and 7777)

5117 Views 4 Replies Latest reply: Oct 13, 2010 4:20 AM by MouShindeiru RSS
MouShindeiru Calculating status...
Currently Being Moderated
Oct 6, 2010 8:17 AM
Greentings ladies and gentlemen,

I need help opening port 5190 and 7777 for ichat server file transfers. As for now, my situation can be described as below:

(1)I have a ichat server in a mac mini(2010, newest model as for today) running a fully updated version of MACOSX SERVER 10.6 inside a lab in my university.

(2)As for the ichat server itself, text, voice, video between 2 or more persons are all working great. As for clients the latest version of ichat and pidgin(text only) are being used. The only problem is the lack of file transfer between ichat clients.

(3)The server is behind a router (YAMAHA RTX 1200). I am 100% sure that the router is correctly configured to allow packets in and out of the port 5190 and 7777, among the other necessary ports. All the other ports are open and working correctly. I also manually disabled the firewall of a windows7 laptop and tested packet transfers on both ports and both worked fine.

(4)As I said before, the server is inside my university lab. I made sure that all ports between 1023~65535 are open in the univesity gateway/backbone network.

Bellow are firewall(IPFW) settings before flushing (tried configuring using both GUI and CUI, and both returned the same results)

sudo ipfw l

Password:
00001 allow udp from any 626 to any dst-port 626
01000 allow ip from any to any via lo0
01010 allow udp from any to any dst-port 5190
01030 allow tcp from any to any dst-port 5190
12300 allow tcp from any to any established
12301 allow tcp from any to any out
12302 allow tcp from any to any dst-port 22
12302 allow udp from any to any dst-port 22
12303 allow udp from any to any out keep-state
12304 allow tcp from any to any dst-port 53 out keep-state
12304 allow udp from any to any dst-port 53 out keep-state
12305 allow udp from any to any in frag
12306 allow tcp from any to any dst-port 311
12307 allow tcp from any to any dst-port 625
12308 allow icmp from any to any icmptypes 8
12309 allow icmp from any to any icmptypes 0
12310 allow igmp from any to any
12311 allow tcp from any to any dst-port 5190
12311 allow udp from any to any dst-port 5190
12312 allow tcp from any to any dst-port 5222
12313 allow tcp from any to any dst-port 5223
12314 allow tcp from any to any dst-port 5269
12315 allow udp from any to any dst-port 5297,5678
12316 allow tcp from any to any dst-port 5298
12316 allow udp from any to any dst-port 5298
12317 allow udp from any to any dst-port 16384-16403
12318 allow udp from any to any dst-port 5060
12319 allow tcp from any to any dst-port 7777
12320 allow tcp from any to any dst-port 8008
12321 allow tcp from any to any dst-port 8443
65535 allow ip from any to any


And after flushing

sudo ipfw l

Password:
65535 allow ip from any to any

In either case ports that are being listened are listed below.
netstat -na | grep LIST

tcp46 0 0 *.5269 . LISTEN
tcp46 0 0 *.5223 . LISTEN
tcp46 0 0 *.5222 . LISTEN
tcp4 0 0 127.0.0.1.5347 . LISTEN
tcp46 0 0 *.5900 . LISTEN
tcp4 0 0 *.88 . LISTEN
tcp6 0 0 *.88 . LISTEN
tcp4 0 0 *.311 . LISTEN
tcp4 0 0 192.168.2.96.53 . LISTEN
tcp4 0 0 *.3659 . LISTEN
tcp4 0 0 *.106 . LISTEN
tcp4 0 0 *.3659 . LISTEN
tcp4 0 0 *.106 . LISTEN
tcp4 0 0 127.0.0.1.54 . LISTEN
tcp4 0 0 127.0.0.1.53 . LISTEN
tcp4 0 0 *.749 . LISTEN
tcp4 0 0 *.389 . LISTEN
tcp6 0 0 *.389 . LISTEN
tcp4 0 0 *.22 . LISTEN
tcp6 0 0 *.22 . LISTEN
tcp4 0 0 *.548 . LISTEN
tcp6 0 0 *.548 . LISTEN
tcp4 0 0 *.625 . LISTEN
tcp4 0 0 127.0.0.1.631 . LISTEN
tcp6 0 0 ::1.631 . LISTEN

As you can see my firewall settings are not being reflected on the actual server firewall.
Is there any way I could just force the server into listening the port?
If necessary I can post screenshots of every ichat server/firewall configuration tab from the Server Admin GUI.
Thanks in advance for any help/support.
Custom Desktop, vaio laptop, Windows 7, Windows@home, mac@work
  • Camelot Level 8 Level 8 (45,670 points)
    First off, realize there is no association between your firewall rules and netstat.

    Just because your firewall is letting traffic in that does not mean it will appear in your netstat.

    netstat -a will show you a list of ports that are in use - i.e. there is some process listening to (or writing to) that port. That is independent of whether the firewall permits the traffic (e.g. the firewall could well allow traffic in on 5190, but unless there's a process listening to 5190 you won't see it in the netstat).

    Secondly, IIRC iChat file transfers are client-to-client therefore it might not be your server, or your server's firewall or your server's network that's the issue - the
    client will need to have a firewall configured to allow incoming traffic from other iChat clients.

    Does that help shed some light on things? (it isn't clear whether your post is referring to the server or the client side of things).
    Mac OS X (10.6.4)
  • Tim Harris Level 4 Level 4 (1,460 points)
    Hello,

    I think you will get more success if you post your question here:

    Mac OS X v10.6 Snow Leopard > iChat and iChat Sharing

    Tim
    Mainly xserve's and mac mini's, Mac OS X (10.4.11)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.