Skip navigation

External Drive UNMOUNTING On Its Own...

70017 Views 125 Replies Latest reply: Mar 7, 2014 11:11 AM by marrlin RSS
1 2 3 ... 9 Previous Next
howwow Level 4 Level 4 (3,485 points)
Currently Being Moderated
Sep 29, 2010 7:55 PM

I have a quite-brand new Iomega External Drive FireWire 800 2TB, bought recently to replace my old failed drive, to be a Time Machine Drive for my iMac.

For the past few days I have observed something very very strange: This TM Drive will for no reason, unmount itself from the Desktop; Sometimes I will be at the computer and that usual warning window message about not unmounting your external drive properly will appear. But sometimes when I get back to my iMac, the ext drive has already unmounted, not sure for how long since the icon is not there anymore.

I just have to turn off and on the drive again to get it mounted.

Before this strange thing, there was a couple of times when TM failed to back up, but it was nothing serious, I just back up again and it is fine. There was once prior to this, that I re-format the drive again (GUID partition) and TM all over again.

I ran Disk Utilities and it says the drive is OK and need no repairs.

So what went wrong here? I have doubts that the drive is faulty because I just got it recently as a new replacement to a previous dead drive. Could it be the iMac itself? The OS? Or the physical FW800 port itself?

Need some advice and help, thanks and cheers
iMac Intel 20" (2007), Mac OS X (10.6.4), iPhone 3GS 32G (iOS4) | iPad 64G 3G | MBP 13"
  • dbsneddon Level 4 Level 4 (1,525 points)
    Currently Being Moderated
    Sep 29, 2010 8:04 PM (in response to howwow)
    Try a different cable.

    iMac 27", Mac OS X (10.6.4), , MacBook (10.6.4), iBook G3 (10.4.11)
  • vloh Calculating status...
    Currently Being Moderated
    Oct 2, 2010 7:45 AM (in response to howwow)
    I have the same problem with my 2nd internal HD, it just got unmounted - usually when TM back up kicked in. Error message showed up stating "device removal!"

    G5, Mac OS X (10.5.8)
  • Pondini Level 8 Level 8 (38,710 points)
    Currently Being Moderated
    Oct 2, 2010 8:07 AM (in response to vloh)
    See my response in your other thread. Please don't double-post.
    24" iMac 9,1 2.66 GHz; 4gb; 640 gb, Mac OS X (10.6.4), dual-band AEBS v. 7.4.2
  • Pondini Level 8 Level 8 (38,710 points)
    Currently Being Moderated
    Oct 6, 2010 5:47 AM (in response to howwow)
    howwow wrote:
    . . .
    *Can temperature/heat be a cause for external drives to unmount suddenly? It was rather warm the past few nights and the external drive is very hot to the touch.*

    I've never heard of it, but the drive may have a thermal protection, just as your Mac does. You might want to check with Iomega -- it's possible there's something wrong with it, even if it is brand-new.

    *Is there such a thing as overtaxing the entire bus ports of FW400, FW800 and USB ports?*

    I don't think so.

    *Do they share the same power?*

    It all comes from the same power supply in your Mac, but I think USB and F/W are separate. Your Mac will disconnect a USB port that's drawing too much power. I've never seen a post with a message about a F/W doing the same, but if the drive is drawing too much power, there's clearly something wrong with it.
    24" iMac 9,1 2.66 GHz; 4gb; 640 gb, Mac OS X (10.6.4), dual-band AEBS v. 7.4.2
  • François J. Perreault Level 2 Level 2 (175 points)
    Currently Being Moderated
    Oct 7, 2010 5:46 AM (in response to howwow)
    I had this exact strange problem a while back with a new external drive I was using as an Airport Disk to throw Time Machine backups on over the network:

    I turned out that the "one" physical drive/box, actually had two drivers in it (in RAID 0 I guess) so things would only start failing after enough backups had been made so as to fill the first one and start using the second one (which was faulty)!

    Perhaps you can check the Console utility for error messages though what gave me a clue at the time was that the manufacturer's own "RAID Utility" would cause the drive to unmount/fail as well.

    Have the drive checked by the vendor and/or replaced by your supplier.
    MacBook 2.4 Aluminum/Backlit, Mac OS X (10.6.4)
  • Pondini Level 8 Level 8 (38,710 points)
    François J. Perreault wrote:
    I had this exact strange problem a while back with a new external drive I was using as an Airport Disk to throw Time Machine backups on over the network:

    You need to know, backing-up that way, even to a "plain" external HD, is "iffy" and +*not supported by Apple.+* See: [Using Time Machine with an Airport Extreme Air Disk|] (or use the link in *User Tips* at the top of this forum).
    24" iMac 9,1 2.66 GHz; 4gb; 640 gb, Mac OS X (10.6.4), dual-band AEBS v. 7.4.2
  • Andrew Zimmerman Calculating status...
    Currently Being Moderated
    Nov 9, 2010 4:25 PM (in response to howwow)
    I have also experienced this behavior with both a Western Digital external drive hooked up via FW800 to a 2008 MBP and a NewStack v3 connected to a 2009 Mac Mini via FW800. I have replaced both cables within the past month and still experience this behavior.

    I don't recall this behavior before 10.6.4 although I cannot assign a cause.

    I have this behavior when Time Machine is not set for either drive.
    2009 Mac Mini/2008 MBP, Mac OS X (10.6.4)
  • Jonathan Phillips Calculating status...
    Currently Being Moderated
    Nov 14, 2010 1:20 AM (in response to howwow)
    Out of interest this has recently started happening to me too. I have and Iomega drive I have been using successfully for time machine for 2 years or more. Recently it just unmounts. This happens regularly but not consistently and when it is successfully mounted it works fine.

    I wonder if something in a new OS update has caused it.

    imac flat screen, Mac OS X (10.6.5)
  • Andrew Zimmerman Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 14, 2010 5:07 AM (in response to Jonathan Phillips)
    I have no idea if it is a coincidence, but I noticed that after unmounting, iTunes had lost the library location in preferences. That is, there was no location set for the iTunes library which had been set to the external drive.
  • abstruse Calculating status...
    Currently Being Moderated
    Nov 17, 2010 2:04 PM (in response to howwow)
    I've been having the same problem with an external drive that I designated as my Time Machine drive. I had a G-Tech 1TB external drive that would unmount from the desktop after I got messages from my system about an improperly ejected drive (I had not ejected the drive). This would happen at first after waking my computer from sleep, but then it would happen spontaneously and randomly while the computer was awake and in use. My initial response was to shut down the external drive and then turn it back on, after which it reappeared on my desktop, but the strange behavior returned a few days later. In my case, I contacted the drive's manufacturer because the drive was still covered by a warranty. The manufacturer told me that the drive was causing the system to send me warnings and that the drive was subsequently disappearing from the desktop (dismounting) because the drive had a faulty controller board. The manufacturer told me to return the faulty drive and it was replaced with an identical drive, but the replacement drive also failed - it also dismounted and sent warnings about improper drive ejection. I am now waiting for yet another replacement drive to arrive. The first failed drive was about a year old, and the replacement failed after one week.
    Is it possible that your Iomega external drive has a faulty controller board, too?
    MacBook Pro 15", Mac OS X (10.6.5)
  • pherous Calculating status...
    Currently Being Moderated
    Nov 18, 2010 10:57 PM (in response to abstruse)
    Over the last few days, I have noticed this behaviour (external drive unmounting itself), but I have a 2TB Western Digital USB2 My Book Mac Edition drive that has been working fine with Apple's Backup program since I bought the drive exactly one month ago. The Backup files have now half-filled the drive, and when Backup is attempting to save a new file the drive unmounts and the backup fails. Hers is the backup log from Console for the last couple of days (Cassini is the name of the WD external drive):

    2010-11-18 11:54:05.080 Backup[22672:8537] debug: unable to test mount disk image {
    "image-components" = (
    "/Volumes/Cassini/Backups/Phobos - 2010.11.18-"
    "shadow-file" = "(null)";
    "system-entities" = "(null)";
    2010-11-18 11:54:05.107 Backup[22672:8b03] unable to gzip /Volumes/Cassini/Backups/Phobos - 2010.11.18- file does not exist
    2010-11-19 08:42:53.803 Backup[22672:bb9f] debug: unable to rename disk image {
    "image-components" = (
    "/Volumes/Cassini/Backups/Phobos - 2010.11.19-"
    "shadow-file" = "(null)";
    "system-entities" = "(null)";
    2010-11-19 08:42:53.848 Backup[22672:9e3f] unable to gzip /Volumes/Cassini/Backups/Phobos - 2010.11.19- file does not exist
    MacPro 2 x 2.8 GHz Quad-Core Xeon, Mac OS X (10.5.8)
1 2 3 ... 9 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (5)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.