1 2 3 4 Previous Next 53 Replies Latest reply: Feb 27, 2012 4:03 AM by Rdamorange Go to original post
  • 15. Re: Poor sound quality when using iPhone 4 in car via aux lead
    blastbark Level 1 Level 1 (0 points)
    So I went to the Genius bar in apple today, and apparently all iphone 4 will produce this background sound... We tried two demo phones, the staff person's and all of them duplicate this sound.

    Apparently they all use new parts vs the 3G/3GS for the aux output so there's not going to be a software/firmware fix
  • 16. Re: Poor sound quality when using iPhone 4 in car via aux lead
    ivorte Level 1 Level 1 (0 points)
    I am seeing the same issues. Sounds like a constant high pitched noise, makes it unusable in the car

    I hope this is not another antenna like issue with the iPhone 4. As a long term Mac and Apple user so far the iPhone 4 has been nothing but trouble, nice display though
  • 17. Re: Poor sound quality when using iPhone 4 in car via aux lead
    dedonajr Level 1 Level 1 (0 points)
    I had the same issue as mentioned above in my BMW. The Genius bar offered to swap out my phone, but after doing so I still had the static. After doing more research in other cars and online I determined it was a issue with the car and not the phone. I found some discussion that it might be a issue with grounding of a wire in the radio unit. I went ahead and ordered the PAC SNI-1/3.5 Minijack Ground Loop Noise Isolator from Crutchfield and am happy to say that there is no more static noise when using the phone in the car. I have not noticed any reduction in sound quality either. The isolater cost me $18.89, but was worth the price to have clear sound once again. Hope this helps out others who are having the same problem.
  • 18. Re: Poor sound quality when using iPhone 4 in car via aux lead
    Geraldoh Level 1 Level 1 (0 points)
    Same problems in my 2007 335xi and iPhone 4 (bought about 2 weeks after release) -- but the good(?) news is that yesterday I tested it on a friend's iPhone 4 (that she got in Aug) and there was no hissing.

    I started noticing this a few weeks ago. Mostly loud hissing with other noises. At first I thought it was a BMW problem. The local dealer had it for 3 days and couldn't replicate it, though they did a bunch of updates to the car while they had it.

    Initially I thought it was happening to both my Nano (4th gen) and iPhone 4. But in hindsight, I think when it was happening to the Nano, it was 'leftover' hissing from when I disconnected the iPhone 4 and connected the Nano right away. I've also tried 3 different 3.5 mm mini stereo cables (2-Belkin, one generic from monoprice.com). Hissing happens even when Nano or iPhone 4 is not being powered by the car.

    iPhone 4
    2007 BMW 335xi (Harman Kardon / Logic 7 audio is standard), Premium package, no ipod kit. Audio in through AUX 3.5mm mini stereo jack in glove box.
  • 19. Re: Poor sound quality when using iPhone 4 in car via aux lead
    Shaheryar Level 1 Level 1 (0 points)
    ok guys i know wot the problem is not yet figured out the solution okay now wot is going wid me is i have 3g and for ryt now in my handx my 3g was working absolutely fine and then i got my iphon4 oh wot the **** i bearly can hear vocals from my iphone 4 in aux in mode oh **** wot the **** is it wid me my iphone is defected and wot if i m not in canada america or other places where they launch because i m from pakistan and i am using it in pakistan now back to the real story i updated my 3g to 4.0 remember my ip4 is on 4.1 so when i updated my 3g and put the same songs ip4 have and wot the **** my 3g is giving the same voice quality on aux lead so conclusion is there is sumthing with software nothing with ur iphones now when i called from my iphones they both sounds flawless on same speakers with same aux lead so there must be a problem with eq or idont know wot so guys check them and temme wot is it plxxxx
  • 20. Re: Poor sound quality when using iPhone 4 in car via aux lead
    Iphone4_AUX-VICTIM Level 1 Level 1 (0 points)
    I think you might be wrong with you finding. Because i made several tests with different devices, different firmware versions and different AUX-cables. The result was, that the failure belongs to iphone 4 and not to the firmware version. I took different iphone4 devices, 2 of them were brand new with FW 4.0 and 4.1 - the same result -. At least i picked my old 3GS with FW 4.01, and guess what, the sound is clear like playing a CD.
    Maybe an another antenna bug. I'm still waitin' for the SNAPIN-Adapter, this one should be available in december.
    Did someone examined this Griffin Noise Reducing AUX cable?
  • 21. Re: Poor sound quality when using iPhone 4 in car via aux lead
    Ceylan Level 1 Level 1 (0 points)
    I had the same problem.Annoying hiss on the backgroud which rise up when iphone4 's volume decreases.When I pause it the hiss continues with cracks then stops.

    I also drive a 2010 320d, I'm not sure if this is about BMW sound system,but I didn't have any problems on my car with 3gs.I tried different aux cables from gold plated to normal , nothing changed. Then I saw Belkin's TuneBase Direct with Handsfree for İphone.

    http://store.apple.com/us/product/TY247LL/A

    I tried this product and Bam! "It solved my problem". I'm using My Iphone 4 on my BMW Professional radio without any hiss or cracks.The sound is crystal clear.

    I tried to use inbox aux cable without the unit and the hiss is there again.I think Belkin's unit stops the interference because the aux is not connected to Iphone 4 directly.

    You can also use it as a handsfree set and you can go between the tracks without even looking at your iphone using the big button on the unit....
  • 22. Re: Poor sound quality when using iPhone 4 in car via aux lead
    macBMW Level 1 Level 1 (0 points)
    I am using a Fiio apple connector to 3.5mm in my 325i completely eliminates the hiss

    In fact sound quality exceeds normal 3.5 to 3.5

    kind regards
  • 23. Re: Poor sound quality when using iPhone 4 in car via aux lead
    Arto2010 Level 1 Level 1 (0 points)
    Hi

    Exactly the same problem on my 2008 335i. Interestingly I did not have the problem with my 2006 325i that has the same Logic 7 sound system.

    I tried my wife's 3GS and the sound is crystal clear. Put my 4, and hiss/pop. Very frustrating. My second big gripe with the iphone 4. The first is the nasty echo problem when using handsfree with aux...

    I'm thinking about the noise canceller, but not sure what that will do to the sound dynamics...
  • 24. Re: Poor sound quality when using iPhone 4 in car via aux lead
    KenSacto Level 1 Level 1 (0 points)
    I received a FiiO L3 Line Out Dock for iPhone/iPod in the mail today and gave it a try in my Z4. I first used a standard cable, and the hiss and squeal were still there. Plugged in the L3 and at least 95% of the hiss and all the squeal disappeared. It also allowed me to turn the AUX output setting down, which seemed to help even more. The BMW dealer didn't have an answer, but this sure seems to be it (fuller sound from my iPhone 4, too). It was $13.49 at Amazon and appears to be a simple and total fix.
  • 25. Re: Poor sound quality when using iPhone 4 in car via aux lead
    AmazinglySmooth Level 1 Level 1 (0 points)
    I have an iPhone 4 that worked ok until 4.2.1 was installed. Now the hiss is so high that I can barely listen to anything. It is better to just use the internal speakers than plug it into my 2007 MINI. I plugged in an older iPod and it sounds great, so I know that the AUX and cable are fine. Since it changed significanly with 4.2.1, I'm hopeful there is a software fix for this. I've also noticed that if I exit the audio applications, the hiss quits in a repeatable way so there is something to debug there.

    Usually, with these types of problems, the issue is impedance. I suspect the BMW input impedance is different from headphones, which is what the iPhone expects to see. I hope Apple works on a fix.
  • 26. Re: Poor sound quality when using iPhone 4 in car via aux lead
    David Goodman1 Level 1 Level 1 (25 points)
    I use a kensington 2-11 charger it gives you a line out connector for the aux input in the car. Works great in my 325i. I've used it with Ipod touch, iPhone 3G and iPhone4.
  • 27. Re: Poor sound quality when using iPhone 4 in car via aux lead
    Wgreene63 Level 1 Level 1 (0 points)

    I have a 2008 BMW 550i. Have the same problem discussed here. However, I'm not sure the problem is with the iPhone 4. My BMW dealership thinks the problem is with the software in the car. I had my car in for service twice and had them troubleshoot this problem. Once I got a rental, Mustang, and used the Aux jack with my iPhone 4 and had no issues. The next service they gave me loaner, a 2011 328i. Used the iPhone 4 with no feedback/noise at all. My dealership was hopeful that BMW would have a software update for the audio system in my car. He checked and they didn't. I was going to have the iPod adapter installed but was concerned that noise would continue and BMW wants to charge $450 to install the adapter. Yikes. I bought a used glovebox CD changer to be installed in the car and found out one dealership would not install it because I did not purchase it from them. Another dealership would install it but wanted to charge 3 hours labor when it simply slides into the slot. I would install it myself but can't seem to find the cable. Kinda tight in there. They want to charge 2 hours to install it and another hour to program the computer to recognize it. Again $450. Yikes. I realize I drive a BMW and it costs more but I decided to just use the Aux input which leads me to this discussion.

    So I'm not so sure it's the iPhone because I have used my Iphone 4 in other vehicles, including another BMW and there was absolutely no noise.

  • 28. Re: Poor sound quality when using iPhone 4 in car via aux lead
    jglenton Level 1 Level 1 (0 points)

    Same problem here too, I have a Mini Cooper 2008 and been using an ipod nano and ipod touch fine with the AUX cable. Went to use my new iPhone 4G (got it in July 2011) and get the hissing too behind the music. Strangely though, it starts doing it a couple of minutes after I connect it up.


    Anyway, from reading these posts, looks like it is BMW / Mini related.


    May look into one of these noise isolators I saw suggested in an earlier post.

     

    If anyone knows of any other fixes (cables, etc) please post

     

    Thanks

  • 29. Re: Poor sound quality when using iPhone 4 in car via aux lead
    TomFr Level 1 Level 1 (0 points)

    I encountered the same issue on a BMW.

    I bet it's coming from the electronic handling the 4 "pin" 3.5mm connector of the Nano.

    I solved the issue by inserting first a belkin "iPod shuffle headset adapter" http://www.belkin.com/IWCatProductPage.process?Product_Id=496831

    It leverage the enhanced Nano capability of being remoted on the cable and at the same time covnerts to 3 "pin" 3.5mm female connector were you can connect your 3.5mm connector cable.