Skip navigation

My Macbook keeps disconnecting itself from the internet

282825 Views 275 Replies Latest reply: Mar 11, 2014 8:34 AM by oharb99 RSS
  • Ikus Level 1 Level 1 (0 points)
    My mid-2009 MacBook Pro 13" disconnects from the wireless network and after a few seconds reconnects by itself. It is excruciatingly annoying and it's something I simply can't believe is happening on my Mac. My sister's PC never disconnects, and when I'm in Boot Camp running Windows 7 it never disconnects either.

    Why is my Mac disconnecting and reconnecting to my wireless network? It seems to happen when it's been idle for a while some times an hour, some times several. I'd like an answer from Apple, considering this is a problem their product presents.
    MacBook Pro 13" (Mid 2009), Mac OS X (10.6.4), Boot Camp 3.1 - Windows 7 Ultimate (64-bit)
  • w.breger Calculating status...
    - I got the same issues when my computer does run Mac OS X 10.6.x with D-Link Access Points and try to solve the issue with the D-link support guys now since 10 months.

    - no issue with D-Link Access Points when running my MacBook Pro with Windows 7

    - There is no issue with Mac OS X 10.6.x when my MacBook Pro does connect to Apple Access Points. AirPort Express, AirPort Extreme and Time Capsule tested.

    - does some got any information about the Apple developer team knows about the issue and working on a solution ?
    MacBookPro5,3, Mac OS X (10.6.4), Windows 7 64Bit
  • Upwind Calculating status...
    I too am having this problem.

    My access point is an SMC2555W-AG configured for A/G only (no B). This AP only provides a single SSID for both radios and I do have G devices but prefer to use A when possible so need both radios active. Unfortunately my MBP will always select G over A, even when just a few feet from the AP.

    There are times where I could go for several hours (almost all day) without any problem but other times I will get disconnected fairly quickly. I do have many G/N (2.4GHz) routers/APs in 'view' normally (4-8 typically as seen by my MBPs Airport). This is why I prefer 802.11a, being the only AP on this frequency.

    As a temporary test I have disabled the G radio on my AP, forcing my MBP to use A. So far (2 days) I have not had a single disconnect but I do not consider that anywhere near long enough to be conclusive.

    Using Kismet I have actually found as many as 16 APs within range over the course of a few hours, all 2.4GHz. I am wondering at the moment if the airport radio in my MBP is not so proficient at holding onto a given AP to which it is already associated when there are other APs on the same channel within range.
    Mac OS X (10.6.4)
  • ripples Calculating status...
    I too have a Mac Book Pro 15" purchased Sep 2008. It worked fine using BT wireless 6MB connection speed, until last month (August 2009). The Airport says I am connected to the internet. But the web pages do not load, Skype drops out too. I have tried reloading software and still it drops out. It does not drop out for my iPad or my iPhone or my Blackberry, or my very old MacBook Pro 13 inch or my IBM Laptop.

    I see so many people struggling with this and with so many different networks when will Apple fix this?
    MacBookPro, Mac OS X (10.5)
  • Zizabiz Calculating status...
    My computer is at least four years old. It is updated to Snow Leopard, however. My MacBook Pro keeps disconnecting itself from the Internet...it only stays connected for up to three seconds and then it's gone. Only if I restart my computer or wait a long time will it detect any signal at all or try to connect. I know it's not my router, as I am using wifi from my school. I am having to do all of my Internet work through my iPhone!

    I called Apple Care and they said that I needed to remove my airport interface and re-add it. Could anyone tell me how?
    MacBook Pro, Mac OS X (10.6.4)
  • Cavezzi1456 Calculating status...
    I have a BRAND NEW Macbook Pro 15" wiht an i5 processor. Since I opened it out of the box, it is experiencing the same issue as everyone else's. I initially restored it from a previous backup (on an external hard-drive from my previous white 13" Macbook via Time-Machine), and began having this problem. After having been on the phone with Apple on 4 separate occasions on Sunday, they had me try the following things:

    1) Delete the source files within my Library->SystemConfiguration folders, and then restart my computer. This did not work.

    2) Delete the Airport from my Network Settings, then add it again. This ALSO did not work.

    3) Tried Pinging the Apple website, of course by this point, I had troubleshot myself the airport, and got it working at this point, so it worked.

    4) At this point, I thought it might be something with my backup that I had restored, perhaps some setting from my previous machine had tracked over. Although I was running Snow Leopard 10.6.4, and everything was completely updated. But I tried it anyway. After erasing the hard drive, it STILL had the issue.

    The interesting fact through all of this is that I kept my old Macbook on and running throughout this, and it never had a SINGLE issue with internet connectivity. Which would lead me to believe it was the Airport card. But this was only tested at my home residence.

    I have been at work for 10 hours now, and my new Macbook Pro has not disconnected from the internet a SINGLE time. Which leads me to believe it is the internet service. But since it seems I am NOT the only one with this issue, I am led to believe it is a software issue. Because I am Ethostream internet service, which is being broadcast by the apartment building, and I am the only one having these issues.

    WILL APPLE PLEASE SOLVE THIS ERROR AND COME UP WITH A SOLUTION?! Only time will tell...
    Macbook Pro 15" i5, Mac OS X (10.6.4), Purchased 10/12/2010
  • Douglas68 Calculating status...
    I am writing this on behalf of a friend who just bought his macbook pro barely a month ago. He is also suffering from this issue of airport dropping the wifi signal and even worse causing the whole machine to crash and forcing frequent restarts! He is travelling in Turkey now and we try to skype every day but within a few minutes of chatting his mac will lose connection and hang his whole machine. Reading all the comments here, this cannot be an isolated event. As he is travelling round the globe for the next month he won't be able to return it to the Apple shop here in Singapore where he bought it for it to be replaced until December. I have asked him to seek a replacement for a new set as a brand new machine should not be creating such anguish especially when one is travelling. He got the macbook pro precisely cos of its ease of connectivity and now its given him nothing but headaches. He is a first time Apple user and he is sorely disappointed. I hope that Apple is listening as this a major problem...in a way silence means acquiescence?
    IMac desktop 2008, Mac OS X (10.6.4)
  • w.breger Level 1 Level 1 (0 points)
    I would suggest to run a permanent ping from the client to the access point ip-address.

    I assume that some access points are not able to recognize a client to lan traffic across the AP. So the AP does not see any traffic from the connected client and drops the connection. This means that some access points expect packets addressed to the AP-ip from the client-ip.

    Did anyone see a dropping connection while a permanent ping to the AP-ip was running ?
    MacBookPro5,3, Mac OS X (10.6.4), Windows 7 64Bit
  • JScullin Level 1 Level 1 (0 points)
    Yea. Mine will drop when I'm in the middle of uploading, streaming music, video or just browsing and having an IM client open.

    Putting the computer to sleep, then waking it, will reestablish the connection. Going into the Network Preferences and clicking "Assist Me..." and choosing "Diagnostics" will show the first 3 options green lit and anything after yellow or red. But if you go through with the diagnostics it will reconnect and say it appears to be fine.
    17" Macbook Pro i7, Mac OS X (10.6.3), 500Gb 7200rpm BTO HDD
  • Nels81 Calculating status...
    I'm so fed up of my issue - I reformated and rebuilt but same problem. Also booted from the OSX CD and encountered same issue in the setup (you can click the Airport icon whilst in setup and Apple say if it doesnt work in this mode it has to be hardware)

    So back to the shop it goes.......sorely disappointed.
    MBP 2010 13", Mac OS X (10.6.3)
  • deltadawnpdx Calculating status...
    I was having similar problems. Connected to my home network, but no internet over a wireless connection. Did have internet through ethernet tho. I noticed my iPhone was having the same problem. Called AppleCare but hesitated about paying the $50 for help. The (lovely) guy on the line suggested it might be our Windows (ugh) laptop on the same network. Turned that computer off. Rebooted everything. Voila! The problem is that WINDOWS machine. Microsoft must've changed something in the last 24 hours. Blah!
    MacBook Pro, Mac OS X (10.6.4)
  • shfle Calculating status...
    Currently Being Moderated
    Oct 29, 2010 11:45 AM (in response to suzyz)
    I'm having the exact same problems. New MBP purchased in May takes an age to connect to network after being left for any period of time and also drops connection regularly whilst in use. I have an iMac and Powerbook that do not have any of these issues on the same network. Not happy!
    iMac 20" 2.4Ghz, Mac OS X (10.6.1)
  • bill billybob Level 4 Level 4 (1,035 points)
    I have been trying different settings on my airport express the last week or so (while having my AEX set on the 802.11n only 5 ghz setting) and I have found that unchecking the box "Set Time Automatically" (under the Base Station setting) has helped to not have me get kicked off the network with my macbook. I am not sure how many users with this same problem have an airport express but might be worth a try
    Mac Pro (quad) 2.66 6 Gig ram 1900 XT, 8800 GT, Mac OS X (10.5.7), Macbook 2.2 4 gig ram 10.5.7
  • EdgarAllenHoopoe Calculating status...
    Same problem for me. I will be using the internet when, suddenly, pages stop loading, my conversations on Skype end, yada yada yada.

    Airport shows a full-strength connection, which adds even more annoyance to the issue. I have to manually turn Airport off then back on. This happens every 5-10 minutes.

    Why is this still a problem?
    MacBook Pro, Mac OS X (10.6.4)
  • alcapowen Calculating status...
    I've been having the same problem. I opened a terminal window and pinged my router and left it running in the background and it hasn't dropped connection once. Maybe its some power saving option that disables the wireless network card or something. Its annoying to say the least. Apple need to sort out this issue ASAP. However I have been using my MBP for a few hours now and have not lost connection to my network once. Maybe its worth a try folks. Hope it works out for you.
    Mac Book Pro 15", Mac OS X (10.6.4)
1 ... 8 9 10 11 12 ... 19 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (7)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.