1 2 3 4 Previous Next 49 Replies Latest reply: Apr 14, 2012 4:54 AM by cap_n
OSU-Mac Level 1 Level 1 (10 points)
After recently installing iLife '11, my iPhoto Library became unusable. When I OK'd iPhoto to "upgrade" my library, it started the process and then presented an error message "iPhoto is unable to open this Library".

I couldn't rebuild the Library either. So I was able to "downgrade" back to iPhoto '09 and restored my Library from an older backup (a couple days old). I simply moved iPhoto '11 to the desktop, deleted iPhoto prefs, and reinstalled iPhoto '09 from disc. My intention was to use iPhoto '09 to rebuild the library and then upgrade again. After reinstalling iPhoto '09, I can open my iPhoto library just fine. Appears to be normal. However, when I try to "rebuild" the library, iPhoto instantly quits. No error messages or anything. Just quits.

I downloaded iPhoto Library Manager hoping that it may allow me to rebuild the library. When I try to do that, it prompts me to use iPhoto 9.0 ('11) to upgrade the library before I rebuild. It appears that my Mac (at least iPhoto Library Manager) still thinks iPhoto 9.0 ('11) is installed. I'm positive that iPhoto 8.1 is installed, and that's what's in my Applications folder. That's what is successfully opening my iPhoto library. Any ideas on how I can rebuild this Library in '09 so that I can try to "upgrade" again?

Running on new iMac with 10.6.4 installed.

Mac Pro, MacBook Pro, iPhone, iPod Video, Mac OS X (10.6.4)
1 2 3 4 Previous Next