Skip navigation

Numerous problems with iPhoto '11

190058 Views 460 Replies Latest reply: Sep 23, 2013 9:06 AM by Old Toad RSS Branched to a new discussion.
  • Kenny and his Imac Level 1 Level 1 (5 points)
    Currently Being Moderated
    Oct 23, 2010 3:31 PM (in response to Richard Tanner)
    I experienced some of the problems listed in this thread.

    My photo library has ~60,000 images in it - just under 200GB in size.

    With iPhoto '09, I noticed iPhoto performance degrading as the library grew from 40,000 photos to 60,000, to the point that I have recently been thinking about splitting the library into multiple libraries.

    Here is my experience with the upgrade, starting around 8 pm on Friday.

    1) The installation of iLife '11 including iPhoto '11 itself went fine (I have not yet spent much time with iMovie '11 as my iPhoto '11 problems have been all-consuming since then). The update of the library took over 2 hours. Once it was complete I confirmed that all my photos were still there, but then noted several problems.

    2) Most of my Smart Albums were gone. These were each previously inside of Folders. It does not appear that I lost any Photos, Albums, Projects, or Slideshows.

    The strange thing is that the Folders that previously contained the missing Smart Albums still displayed the photos that were previously in the Smart Albums in each folder. So it appears the library is partially corrupted.

    3) Next I noticed what others have noted - that creating calendars is now missing. I find this a shockingly poor decision by Apple as it is one of my family's favorite things to do with iPhoto, and the holidays are approaching - the most popular time to buy and give calendars as gifts.

    4) Performance was very very poor. Switching between events, selecting images for editting, etc. all just crawled. iPhoto was unusable at this point.

    One thing I continue to wonder as all this plays out below is whether iPhoto is having to rebuild thumbnails and other reduced size images of the photos, and that is what is making it run so slowly.

    5) So next I decided to rebuild the library (alt+command & start up iPhoto). The first time I did this I accidentally selected all the check boxes including rebuild from Time Machine backup which I did not intend to do. Luckily I was able to quit iPhoto while it was still initiating this process. I have no idea how the process would have proceeded, so I was happy I could stop it. So I then restarted it, selecting to rebuild the library and also the photo thumbnails. I forget now, but I don't think I asked it to rebuild the other size images.

    This process proceeded incredibly slowly and after 2 hours I went to bed around 1 am. When I got up this morning, it had still not completed, and the status bar did not appear to be moving at all - it had rebuilt the library and was stuck at about 45% complete making the thumbnails. So I Force Quit iPhoto and started it all over again with identical settings. I went away and returned about 5 hours later. This time the rebuild process was complete. The process found 1 photo that it recovered into a Recovered Album. But when I checked the Event, the photo was already there as well.

    6) iPhoto now seems to be running better, but I would say it feels 20% slower (hard to guess) than iPhoto '09.

    7) Regarding the changes in the User Interface, some of the decisions like deleting the Split Event button are just bizarre. The idea of full screen is great, but the details seem to have missed the mark. I'll give it all a few days before passing judgement, but the changes seem overly extensive and frankly gratuitous.

    8) AND FINALLY THE BIGGEST PROBLEM IN MY MIND - AND IT HAPPENED WITH IPHOTO '09 ALSO...The upgrade process makes changes in the library obviously. Either those changes are incredibly extensive, or Time Machine is brain dead when dealing with an iPhoto update. A complete backup of the iPhoto library (200GB) is now underway. This is an incredible waste of space on my 1TB Time Capsule, and will push it to over 85% full. Once I convince myself that my photos are all still in the iPhoto library and nothing strange is going on with the overall system, I am going to reformat my Time Capsule and start the backups over from a clean Time Capsule. I shouldn't have to do this - now a second time - with both iPhoto '09 and iPhoto '11.

    Apple develops incredible products and I love all of them including iPhoto on most days, but the iPhoto upgrade process is more typical of the junk developed by Microsoft.
    iMac 2.4 GHz Intel Core 2 Duo, Mac OS X (10.6.4)
  • loveapplebutunhappyilife Calculating status...
    Currently Being Moderated
    Oct 23, 2010 3:56 PM (in response to Photojourney)
    I was very unhappy to find out that after upgrading one month ago to iLife '09 (which I waited to buy as not sure was a big improvement over previous) that iLife '11 has just been announced (Canada). You would have thought someone would have mentioned to me that a new version was just around the corner.

    Called Apple to mention my situation and told that nothing could be done.

    When I saw all these comments about iLife '11 it has confirmed why I hesitate to buy a new releases. Maybe this is why they don't want to help me in this situation as they have so many issues with this release.
    iMac, Mac OS X (10.6.4)
  • Gurudgo Calculating status...
    Currently Being Moderated
    Oct 23, 2010 4:01 PM (in response to Richard Tanner)
    Same issues.

    Rebuild my entire library every time I reopen the app.

    Slow or completely unresponsive when trying to import images from my Canon 5d, Rebel TI2 or iPhone

    Freezes my entire system can't even force quit until iPhoto lets it go.

    VERY BAD RELEASE AVOID UNLESS YOU LIKE PROBLEMS>
    A.
    G5 TwinTurbo, Mac OS X (10.6.4), Processor Name: Dual-Core Intel Xeon Processor Speed: 2.66 GHz Number Of Processors: 2 Total
  • Ham66 Calculating status...
    Currently Being Moderated
    Oct 23, 2010 6:39 PM (in response to Old Toad)
    How is this a font issue? It was a basic software upgrade. It simply never actually upgraded the database and simply deleted the majority of my library.

    thanks
    mac pro 2007, Mac OS X (10.6.4), quad core 4 drives
  • chester4444 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 23, 2010 6:45 PM (in response to Ham66)
    I agree, I tried disabling custom fonts and it didn't do anything.
    Mac OS X (10.5.4)
  • Adam Woodhams Level 1 Level 1 (30 points)
    Currently Being Moderated
    Oct 23, 2010 7:03 PM (in response to chester4444)
    - Zoom isn't working as a keyboard shortcut & the zoom slider is now gone. So it is now impossible to do any sort of quality selection between images.

    - Batch-change has now gone from the right-click menu, the right-click menu is now in fact a shadow of its former-self.

    - Editing panes are now fixed not floating, thats a big deal when you have lots of edits to do on a 27"
    27" 2.8ghz i7, 3.06ghz intel c2d 24" iMac 4g ram, 2ghz 13" Uni B MacBook, Mac OS X (10.6.4)
  • chester4444 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 23, 2010 9:03 PM (in response to Richard Tanner)
    I reinstalled just iPhoto '11 from the iLife disk and upgraded the library and it had no effect. It still wants to upgrade the library again after opening it time after time.

    I did notice a large iPhoto and iPhoto library folder in my trash. I didn't put it there but my original iPhoto library was still in its location...?

    I have no idea anymore, tried everything!
    Mac OS X (10.5.4)
  • M Mollison Calculating status...
    Currently Being Moderated
    Oct 24, 2010 5:41 AM (in response to chester4444)
    iLife 11 has been a nightmare. It would not work on two of our macs and I eventually gave up on the whole thing and am now back to iLife 09 and all's good. Its pretty time consuming but this is what I did.

    1. Deleted the iLife 11 programs. Just trash them from the applications folder...and deleted the iphoto library in the pictures folder (only do this if you have time machine setup and have done a recent backup)
    2. Reloaded iLife 09, and then did all the updates, using Software update.
    3. Downloaded "iphoto library manager" (its free, just google the name), then ran "apply permissions now" using the options function on the far RHS of the window in iphoto library manager.
    4. Opened iphoto (now 09) and recovered photos from time machine using the file/browse backups commands within iphoto.

    The old files were returned to me...thank goodness! Am back to where I was before the iLife 11 fiasco began.

    I'm not game to try iLife 11 again...I'll wait for the next version as this one clearly has not been adequately tested. Getting rid of it and recovering my photos has taken all weekend to do/crack.
    MacBook Pro, Mac OS X (10.5.6), 2008 MacBook Intel
  • Brick82 Calculating status...
    Currently Being Moderated
    Oct 24, 2010 9:20 AM (in response to Richard Tanner)
    I have the same problem: it asks to upgrade the photo library each time and then hangs on the turning gear forever. I hope there will be a fix for this very soon.
    iMac, Mac OS X (10.6.4), 2.93 GHz Intel Core 2 Duo 4 GB 1067 MHz
  • Chuck Radda Calculating status...
    Currently Being Moderated
    Oct 24, 2010 9:39 AM (in response to mach0u)
    I was angry because I just upgraded to 10 at the Apple store where no one said "hey, wait a week." Now I'm glad they didn't. You're right--iPhoto 11 a nicely packaged Beta version, very Windows-worthy.

    For what it's worth, iPhoto Library Manager handles lots of iPhoto glitches, at least with 10

    And though I sympathize with you, I appreciate the warning too.
    iMac, Mac OS X (10.6.4)
  • Schizzo Jo Calculating status...
    Currently Being Moderated
    Oct 24, 2010 10:11 AM (in response to Chuck Radda)
    You're are the only one in the world with iLife 10....
    iMac 27 (mid 2010) quad core i7 2,93ghz 8 giga ram 2 tera HD, Mac OS X (10.6.4), Time Capsule 2010 2 TB, iPhone 3gs 16GB, iPad 3G + WiFi 32GB, iPod Classic 80GB
  • MulderDSM Level 1 Level 1 (5 points)
    Currently Being Moderated
    Oct 24, 2010 5:58 PM (in response to Schizzo Jo)
    Spent most of the weekend trying numerous suggested solutions to no avail.

    I finally got iPhoto to launch without trying to keep updating database on my main account on another user account can't get loop of wanting to upgrade on every launch to stop.

    When I try to create a new book or card iPhoto crashes when the carousel launches.

    Checked fonts ok.
    Booted in safe mode still doing same thing.
    Tried on different user accounts.
    Did permission repair from boot install disc.
    Trashed permission files.

    Nothing seems to work. I'm a long time Mac user and have never seen such bad Apple software. Their QA department needs some help. It's very embarsssing to brag about Apple and then have this happen. I'm recommending friends not install or buy iLife 11 till this is addressed. Forums are full of these issues.
    iMAC 24", Mac OS X (10.6.4), MacBook, iPad and iPhone 4
  • Just add alcohol Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 25, 2010 12:29 AM (in response to Richard Tanner)
    Oh my god
    what is it 24 hours later I finally got the projects working for me

    Opened iPhoto whilst holding the option key which opened a 'which directory did you want to use', i selected the default folder

    open iPhoto11 and now it works

    but I cant buy photo's? keeps saying 'store is temp unavailable'

    am I paranoid or is it just me that cant buy?
    imac, Mac OS X (10.4.4)
  • NiKapa Level 1 Level 1 (5 points)
    Currently Being Moderated
    Oct 25, 2010 3:08 AM (in response to Richard Tanner)
    I wonder if this is a real problem or internet mud about the new iLife '11. I wanted to upgrade but after reading about the problems I put that on hold.

    However I see that all the users who having problems are new users or just registered users (checked also a similar thread in macrumors forum, all new users and a word by word same post by a user) and many doesn't even bother to read the thread from the very start, not even returning any feedback about the old toad's solution.

    So what is going on here? Haters are hating again?
    Macbook white unibody 2009, Mac OS X (10.6.4)
  • Iemke Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 25, 2010 3:30 AM (in response to NiKapa)
    Nitro912gr,

    I noticed your comments. I am not a new user nor a just registered user. I don't post that much that true. But if I post I have a real problem which I can not solve by myself and would like some assistance from this community. Most of the time, the suggestions are helpful. Sometimes you post the same thing in different fora to get a quick solution from different angles of view.

    I view Apple as a top notch company. Most of the time they put out well thought trough products. Sometimes a product didn't work as was expected. This was the case with aperture and it look likes if it is the case with iphoto from ilife.

    rgds
    Iemke
    Mac OS X (10.6.4)
1 2 3 4 5 ... 31 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.