Skip navigation

Itunes 10 won't connect to Apple TV with Airplay

100837 Views 79 Replies Latest reply: May 18, 2013 12:28 AM by Owen_B RSS
  • mogg851 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 28, 2010 9:18 PM (in response to Shane Scott)
    Turning off IPv6 worked for me. Thanks Shane.
    Mac OS X (10.6.4)
  • elvo86 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 6, 2010 11:54 AM (in response to whistlerdan)
    Had the same problem. My iMac was wired to my linksys router (with dd-wrt on it), but my ATV2 was connected via wi-fi.

    Put my iMac on wi-fi, and it works fine.

    Might have to see if dd-wrt is blocking the traffic between the wireless and wi-fi networks.
    iMac 5.1, Mac OS X (10.6.4), ATV2
  • HulkaBigToe Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 12, 2010 2:57 PM (in response to Shane Scott)
    Thanks Shane! I was trying to figure out what was going on for hours today.

    You'd think with an iMac + Apple Router + wired AppleTV2 there wouldn't be any problems since all of these devices are from the same company.
    iMac i7, Mac OS X (10.6.4)
  • Mark Crandell Level 1 Level 1 (35 points)
    Currently Being Moderated
    Nov 12, 2010 9:01 PM (in response to whistlerdan)
    I'm still having no luck. Everything works fine, watching videos/music on the Apple TV using the apple TV remote, until I go to the computer and try to stream to the "Apple TV" using the airplay feature of iTunes 10.1.

    I've completely disabled the firewall on both private and public settings. I've tried unplugging the Ethernet cable from apple TV, unplugging the Ethernet cable from the computer. And I've tried turning off ipv6 in the Ethernet adapter settings.

    I'm starting to think it could be a router issue, but since everything seems to work fine except airplay using my mouse & itunes 10.1 I'd like to believe this is just some software issue with iTunes or Apple TV. (plus I don't really want to buy a new router)

    Anyone come up with any different solutions?

    (I've also removed all firewall settings, uninstalled all apple software and reinstalled iTunes 10.1)
    Windows 7, D-Link wi-fi g/n router DIR-655
  • jason202 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 13, 2010 7:16 AM (in response to whistlerdan)
    I had the same problem immediately after upgrading to 10.1 on Windows 7 x64.

    My solution was to unplug the Apple TV and then plug it back in, to re-boot it. After doing this, the remote speaker feature under the AirPlay menu item in settings on the Apple TV was turned off. I turned it back on, and everything has been working fine since then.
    Apple TV 2010, Windows 7
  • Mark Crandell Level 1 Level 1 (35 points)
    Currently Being Moderated
    Nov 13, 2010 9:10 AM (in response to jason202)
    Unplugging the Apple tv so it reboots finally fixed it for me. Thanks!
    Windows XP Pro
  • m7hammond1 Level 1 Level 1 (0 points)
    I am having the same problem that iTunes 10.0.1 won't see my ATV2. Both devices are wireless through a Linksys N router. I've disabled IPv6 on the iMac. Netflix works fine on the ATV2. Streaming from my iMac to my son's MacMini in FrontRow works fine. Remote on my iPad can see the ATV2 w/o a problem. I just can't see my iMac's Home Sharing library in the ATV2.
    27" imac, 3.06ghz Dual Core, intel mac mini, g4 mac mini, apple TV, iphone, 4 ip, Mac OS X (10.6.2)
  • m7hammond1 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 14, 2010 8:38 AM (in response to m7hammond1)
    Friends,

    I found there was an update for iTunes this morning, to 10.1 (54). I applied the update and my ATV2 works fine now. Hopefully it sticks, and you all have the same luck I did.
    27" imac, 3.06ghz Dual Core, intel mac mini, g4 mac mini, apple TV, iphone, 4 ip, Mac OS X (10.6.2)
  • DelegatorNH Level 1 Level 1 (5 points)
    Currently Being Moderated
    Nov 20, 2010 7:37 AM (in response to m7hammond1)
    The issue for me was resolved by unplugging the hard wired connection on my macbook and just using witi. This makes no sense, because my main router is an airport extreme base station. So, somehow an all-apple solution won't work if it's wired?
    MacBook Pro, Mac OS X (10.6.1)
  • Paulsk66 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Nov 24, 2010 5:56 AM (in response to mogg851)
    I have been playing around with the settings for the past week trying to sort this out
    My configuration is as follows
    Windows XP
    iTunes 10.01
    Apple TV 2 (upgraded to 4.1) wifi connected
    Ipad 4.2 (remote app)
    iPhone 4 4.2 (remote app)

    Ensure you turn on home sharing on all devices PC,Apple TV, IPad and iPhone
    Login with the same apple ID
    Turn on Airport on Apple TV

    Ensure IP address is allocated automatically if not make sure each device has unique IP address

    You should be able to play the contents off your iTunes library on the PC speaker, Apple TV or both
    From your iPad or IPhone you should be able to play via IPod menu your music collection on the Apple TV
    via the remote app you should be able to play the contents of your iTunes library on your PC to your apple TV
    via your apple TV you should be able to see the contents of your iTunes library and play it on your TV

    Originally I had my PC hard wired to my router via an Ethernet cable, for some reason I could see the computer name on the Apple TV and Remote App on IPad and IPhone however kept getting the spinning wheel searching the library

    After moving the PC to wireless everything works seamlessly , intact I have 3 apple TV's and can stream music to them all at the same time via iTunes on the PC

    The remote App can see and control them all, I can select why one I want to play music on from my IPad and IPhone

    You can also stream YouTube to the desired apple TV via IPhone and IPad

    Display iPhone and iPad pictures via Apple TV

    Still can't display video taken on iPhone to apple TV, feature not supported
    Windows, iOS 4, Other
  • pj737 Level 1 Level 1 (0 points)
    I'm having the exact same issue as whistlerdan... but not only does "connecting to Apple TV" just hang... it knocks my computer off the internet as well. I'm using a D-Link router, wired to my broadband modem. APTV2 is not hard wired to the router but located about 10 feet away in another room.

    I have my settings correct on the APTV2 (Airplay ON). The airplay symbol appears at the bottom right in iTunes when I turn the APTV2 on... but if I try to connect (even using the "multiple speaker" option) it just hangs there, bumps my computer off the router and I am forced to disconnect the connection by turning Airplay "OFF" on APTV2 through my television. I also have to reset my D-Link router as well... so that I can reconnect my computer to the internet.

    I followed Shane Scott's advice (i.e. Set the "Configure IPv6" field to Off), but to no avail. I reset the APTV2 several times by unplugging from power and plugging back in. I even shut down iTunes twice... and restarted my computer twice. My router and broadband modem was reset several times as well. Firewall is off and I updated iTunes.

    I do not have home sharing enabled because I am a one-computer household and purchased the APTV2 for two purposes - Netflix and streaming audio wirelessly from my MBA to my Onkyo receiver and speakers in my living room. But my understanding is that home sharing is not necessary unless I want to share my content with other computers.

    My thoughts are that maybe there is a compatibility issue with the router? I can't think of anything else unless someone knowledgable can tell me what I'm doing wrong. I hope it's not the router because I already had to get rid of a perfectly functioning 24" Samsung LCD monitor because the VGA to mini display port was not compatible with it. This switch to mac has been extremely painful so far...
    MB Air 2010, Mac OS X (10.6.5), 2.13GHz/4GB/256GB SSD
  • waveofpositivity Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 5, 2011 7:06 AM (in response to SchmuFoo)
    I opened up this port and I can confirm this does work. Tried other things like disabling IPv6 but this definitely worked for me. For Windows 7 users:

    Go to start, network
    Right click on network and go to properties
    click on Windows firewall in bottom left
    Click on Advanced settings
    Click on Inbound rules
    Click on new rule (on right side of screen)
    Select port and hit next
    Select UDP, Specific local port: 6002, hit next
    Allow the connection, hit next
    Select only private, hit next
    Call it Apple TV and finish.

    That should do it!
    Dell, Windows 7
  • natibird Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 13, 2011 1:11 PM (in response to whistlerdan)
    Hi all,
    I have been reading quite a few articles relating to WIN7 inability to connect to APPLE TV (gen2). My mac can homeshare no problem, but at first I could not get my Win7 PC to connect, until today. I tried everything previously mentioned, TCP/UDP ports allowed, also disabled the firewall, and rang technical support with no luck. My Mac could view the library on my PC, but my PC could not also view the Mac with homeshare. Eventually I was able to homeshare my main WIN7 PC (latest iTunes 10.1) with my Apple TV by the following:
    1. in iTunes on the very bottom bar on the very right are three icons, middle one is the "genius" icon, right "hides or shows task bar icon", and the very left one allows you to choose which speakers to connect with.
    2. Click on the icon to "choose which speakers to connect with" as mentioned above.
    3. On there you should have "my Computer" "multiple speakers", and hopefully "Apple TV". Select Apple TV.
    4. Now boviously ensuring homesharing is setup and the same on PC and APPLE TV, you should now see it in your library.

    I was able to connect my WIN7 64bit PC to apple TV this way only!

    Hopefully this helps as I almost took it back after 8 days. Good luck.
    Self built, Windows 7, 64bit, AMD
  • newagemac Level 2 Level 2 (240 points)
    Currently Being Moderated
    Jan 13, 2011 1:33 PM (in response to natibird)
    That's not Home Sharing. That's using the Airplay feature from iTunes to the Apple TV. Quite different.
    Unibody Macbook Pro | 2010 Mac Mini | iPhone 4 | Apple TV 2G, Mac OS X (10.6.5)
1 2 3 4 ... 6 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (5)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.