5 Replies Latest reply: Nov 7, 2010 12:09 PM by CorkyO2
Kiggavik Level 1 Level 1 (0 points)
While attempting to export a version of photo all I noticed all of my export presets have disappeared. All that is left is one jpeg version called "Untitled". A search of the forum showed a solution of

1) quitting Aperture
2) Go to User/Library/Preferences/
3) Move com.apple.Aperture.plist to desktop
4) Restarting Aperture.

That didn't work, and I also tried restarting the computer before restarting Aperture.

Anyone know what has happened, and how to fix it, apart from going in an adding a whole suite of export presets on my own.

MacPro 2X2.8 Quad Core, Mac OS X (10.6.4), Aperture Version 2.1.4
  • 1. Re: Export presets have disappeared
    CorkyO2 Level 4 Level 4 (1,290 points)
    Your best bet would be to go into a backup (e.g., Time Machine) and copy the 'Export Presets.plist' found in '~/Library/Application Support/Aperture' folder from the backup to the same location on active system. You will want to copy the file from a point in time when you last had the presets available

    Without a backup, you will need to recreate the export presets.

    Hope this helps.

    Edited to correct file name, procedure and location.
  • 2. Re: Export presets have disappeared
    Kiggavik Level 1 Level 1 (0 points)
    Thanks CorkyO2. I went back in Time Machine and restored that file. I went back further than when I knew my export still worked. Unfortunately that didn't do the trick. I still have only one Export preset there. Is there something I'm missing?

    The export presets: Jpeg fit in 1024X1024, Jpeg fit in 50X50 etc. etc.? Are they found in that preference file? The reason I'm wondering is, before I did this restore, I named the "untitled" preset, and modified it slightly. It remains the same after the restore.
  • 3. Re: Export presets have disappeared
    CorkyO2 Level 4 Level 4 (1,290 points)
    In AP3, the file I mentioned holds the export presets.

    I am not sure what Apple might have changed between 2.1.4 and 3.0 (I would not have thought they had changed the preference file in this case, but they may have).

    In AP3, the default export presets are as follows:

    1 - JPEG - Original Size
    2 - JPEG - 50% of Original Size
    3 - JPEG - Fit within 1024 x 1024
    4 - JPEG - Fit within 640 x 640

    If this list is different than what you are seeing, then it may be that Apple has changed the way this is handled and my advice may be inaccurate for your case.

    I apologize if this is case.

    Did you remove any file named 'Export Presets.plist' prior to restoring the backup? If not, you might try moving an existing file to the desktop prior to replacing it with a backup to insure the data is not merged or overwritten is some strange way.

    If you launch Aperture after moving the file to the desktop and you don't see the 'Untitled' export preset (or any other custom presets you might have made), then this would indicate that the file contains the custom export presets and that Apple has kept the functionality and preference files the same between versions

    Other than that, I have no better suggestions.
  • 4. Re: Export presets have disappeared
    Kiggavik Level 1 Level 1 (0 points)
    Thanks again. Those are some of the presets in 2.1.4 as well, in addition there are more, such as TIFF with the same parametres. They are all gone.

    I couldn't find any file called Export Presets or anything similar. I hadn't removed the preferences file to the desktop when I restored from Time Machine, just chose the "replace" option. However I just did it again, putting the old file on the desktop first, and ended up with the same result. Only one custom preset, none of the others are there.

    I guess my only option will be to build my own as I need them.

    Thanks again.
  • 5. Re: Export presets have disappeared
    CorkyO2 Level 4 Level 4 (1,290 points)
    Kiggavik wrote:
    Thanks again. Those are some of the presets in 2.1.4 as well, in addition there are more, such as TIFF with the same parametres. They are all gone.



    Sorry, I did not list the others, but AP3 has a few TIFF, PNG and PSD options as well.


    I couldn't find any file called Export Presets or anything similar. I hadn't removed the preferences file to the desktop when I restored from Time Machine, just chose the "replace" option. However I just did it again, putting the old file on the desktop first, and ended up with the same result. Only one custom preset, none of the others are there.



    The Export Presets.plist file is created when you create custom export presets and they are saved by Aperture to that file. Otherwise, you won't see one if you just use the default presets included with the program.


    I guess my only option will be to build my own as I need them.



    Since your default presets are not there, I suspect something else is going on. It could be a missing file from the application package, but I am not really sure where Apple keeps the default export preset file.

    Depending on how important it is to you, you can obviously create your own and you should see that file created once you create them and they are saved.

    If you want to go further, you could try the basic troubleshooting steps if you have not already tried them:

    http://support.apple.com/kb/HT2945

    Suggest you copy your library file to a backup location prior to running those procedures to protect against any issues that might arise.

    Hopefully someone else will stop by who knows where the default export settings file resides and can steer you in the right direction to replace that if you want to have those. Obviously a reinstall would do that, but that is a bit of a radical solution at this point.

    Sorry I did not have better information for you.