1 2 3 Previous Next 127 Replies Latest reply: Jun 22, 2014 1:27 PM by Larry the O
howwow Level 4 Level 4 (3,485 points)
Hello.

I have a quite-brand new Iomega External Drive FireWire 800 2TB, bought recently to replace my old failed drive, to be a Time Machine Drive for my iMac.

For the past few days I have observed something very very strange: This TM Drive will for no reason, unmount itself from the Desktop; Sometimes I will be at the computer and that usual warning window message about not unmounting your external drive properly will appear. But sometimes when I get back to my iMac, the ext drive has already unmounted, not sure for how long since the icon is not there anymore.

I just have to turn off and on the drive again to get it mounted.

Before this strange thing, there was a couple of times when TM failed to back up, but it was nothing serious, I just back up again and it is fine. There was once prior to this, that I re-format the drive again (GUID partition) and TM all over again.

I ran Disk Utilities and it says the drive is OK and need no repairs.

So what went wrong here? I have doubts that the drive is faulty because I just got it recently as a new replacement to a previous dead drive. Could it be the iMac itself? The OS? Or the physical FW800 port itself?

Need some advice and help, thanks and cheers

iMac Intel 20" (2007), Mac OS X (10.6.4), iPhone 3GS 32G (iOS4) | iPad 64G 3G | MBP 13"
  • 1. Re: External Drive UNMOUNTING On Its Own...
    dbsneddon Level 4 Level 4 (1,525 points)
    Try a different cable.

    Dave
  • 2. Re: External Drive UNMOUNTING On Its Own...
    howwow Level 4 Level 4 (3,485 points)
    Hi

    Changing the cable "seems" to work... until just a while ago. The drive just "disappeared" from the Desktop and unmounted itself. There was an error message regarding Time Machine, either it did not complete the backup or couldn't find the drive.

    *How do I test/know whether if the drive is faulty?*

    My previous TM drive did not "died" like that, TM just didn't work properly anymore so I thought it was the drive that was going to die... now perhaps *I should "suspect" maybe it's the FW800 port??*

    Thanks and cheers
  • 3. Re: External Drive UNMOUNTING On Its Own...
    vloh Level 1 Level 1 (0 points)
    I have the same problem with my 2nd internal HD, it just got unmounted - usually when TM back up kicked in. Error message showed up stating "device removal!"

    Help
  • 4. Re: External Drive UNMOUNTING On Its Own...
    Pondini Level 8 Level 8 (38,720 points)
    See my response in your other thread. Please don't double-post.
  • 5. Re: External Drive UNMOUNTING On Its Own...
    howwow Level 4 Level 4 (3,485 points)
    Hi. Here's an update...

    After I "suspected" that maybe my iMac's FW800 port may be faulty; I reformatted my external Iomega Drive (again), check through with Disk Utilities, and this time I connect with FW400 port, so far so good, only the backup is significantly slower.

    So far so good, no "mysteriously unknown sudden un-mounting"... until last night. The drive "decided" to disappear from the Desktop in a flash, with that pop-up window message about not properly unmounting an external device.

    *Can temperature/heat be a cause for external drives to unmount suddenly? It was rather warm the past few nights and the external drive is very hot to the touch.*

    *Is there such a thing as overtaxing the entire bus ports of FW400, FW800 and USB ports? Do they share the same power?*

    Thanks and cheers



    -
  • 6. Re: External Drive UNMOUNTING On Its Own...
    Pondini Level 8 Level 8 (38,720 points)
    howwow wrote:
    . . .
    *Can temperature/heat be a cause for external drives to unmount suddenly? It was rather warm the past few nights and the external drive is very hot to the touch.*


    I've never heard of it, but the drive may have a thermal protection, just as your Mac does. You might want to check with Iomega -- it's possible there's something wrong with it, even if it is brand-new.

    *Is there such a thing as overtaxing the entire bus ports of FW400, FW800 and USB ports?*


    I don't think so.

    *Do they share the same power?*


    It all comes from the same power supply in your Mac, but I think USB and F/W are separate. Your Mac will disconnect a USB port that's drawing too much power. I've never seen a post with a message about a F/W doing the same, but if the drive is drawing too much power, there's clearly something wrong with it.
  • 7. Re: External Drive UNMOUNTING On Its Own...
    howwow Level 4 Level 4 (3,485 points)
    Hi all,

    Pondini, I think you are right. Haiz. A new drive can be defective.

    Just this evening, a while ago when I start up my mac, my Time Machine drive, this "problem" drive, refuse to mount on the DEsktop, Disk U can "see" it, at the 1st level drive name, the 2nd level (I named it) is grey out, attempting to repair the drive.

    There is a similar drive daisy chain to this one, which I use SuperDuper to clone my iMac, whenever, before I do a software update (Yes, I have 2 back ups), and that one mounted just fine, even it was placed as a 2nd drive to this one, which directly connects to the iMac.

    Yeap, looks like I "have no good fate" with external drives, this one seems a goner. The trouble is having to bring it to a service centre for servicing... and I need to find out where.

    Cheers and thanks
  • 8. Re: External Drive UNMOUNTING On Its Own...
    François J. Perreault Level 2 Level 2 (175 points)
    I had this exact strange problem a while back with a new external drive I was using as an Airport Disk to throw Time Machine backups on over the network:

    I turned out that the "one" physical drive/box, actually had two drivers in it (in RAID 0 I guess) so things would only start failing after enough backups had been made so as to fill the first one and start using the second one (which was faulty)!

    Perhaps you can check the Console utility for error messages though what gave me a clue at the time was that the manufacturer's own "RAID Utility" would cause the drive to unmount/fail as well.

    Have the drive checked by the vendor and/or replaced by your supplier.
  • 9. Re: External Drive UNMOUNTING On Its Own...
    Pondini Level 8 Level 8 (38,720 points)
    François J. Perreault wrote:
    I had this exact strange problem a while back with a new external drive I was using as an Airport Disk to throw Time Machine backups on over the network:


    You need to know, backing-up that way, even to a "plain" external HD, is "iffy" and +*not supported by Apple.+* See: [Using Time Machine with an Airport Extreme Air Disk|http://web.me.com/pondini/Time_Machine/Airport.html] (or use the link in *User Tips* at the top of this forum).
  • 10. Re: External Drive UNMOUNTING On Its Own...
    Andrew Zimmerman Level 1 Level 1 (0 points)
    I have also experienced this behavior with both a Western Digital external drive hooked up via FW800 to a 2008 MBP and a NewStack v3 connected to a 2009 Mac Mini via FW800. I have replaced both cables within the past month and still experience this behavior.

    I don't recall this behavior before 10.6.4 although I cannot assign a cause.

    I have this behavior when Time Machine is not set for either drive.
  • 11. Re: External Drive UNMOUNTING On Its Own...
    Jonathan Phillips Level 1 Level 1 (75 points)
    Out of interest this has recently started happening to me too. I have and Iomega drive I have been using successfully for time machine for 2 years or more. Recently it just unmounts. This happens regularly but not consistently and when it is successfully mounted it works fine.

    I wonder if something in a new OS update has caused it.

    J
  • 12. Re: External Drive UNMOUNTING On Its Own...
    Andrew Zimmerman Level 1 Level 1 (0 points)
    I have no idea if it is a coincidence, but I noticed that after unmounting, iTunes had lost the library location in preferences. That is, there was no location set for the iTunes library which had been set to the external drive.
  • 13. Re: External Drive UNMOUNTING On Its Own...
    abstruse Level 1 Level 1 (0 points)
    I've been having the same problem with an external drive that I designated as my Time Machine drive. I had a G-Tech 1TB external drive that would unmount from the desktop after I got messages from my system about an improperly ejected drive (I had not ejected the drive). This would happen at first after waking my computer from sleep, but then it would happen spontaneously and randomly while the computer was awake and in use. My initial response was to shut down the external drive and then turn it back on, after which it reappeared on my desktop, but the strange behavior returned a few days later. In my case, I contacted the drive's manufacturer because the drive was still covered by a warranty. The manufacturer told me that the drive was causing the system to send me warnings and that the drive was subsequently disappearing from the desktop (dismounting) because the drive had a faulty controller board. The manufacturer told me to return the faulty drive and it was replaced with an identical drive, but the replacement drive also failed - it also dismounted and sent warnings about improper drive ejection. I am now waiting for yet another replacement drive to arrive. The first failed drive was about a year old, and the replacement failed after one week.
    Is it possible that your Iomega external drive has a faulty controller board, too?
  • 14. Re: External Drive UNMOUNTING On Its Own...
    pherous Level 1 Level 1 (0 points)
    Over the last few days, I have noticed this behaviour (external drive unmounting itself), but I have a 2TB Western Digital USB2 My Book Mac Edition drive that has been working fine with Apple's Backup program since I bought the drive exactly one month ago. The Backup files have now half-filled the drive, and when Backup is attempting to save a new file the drive unmounts and the backup fails. Hers is the backup log from Console for the last couple of days (Cassini is the name of the WD external drive):

    2010-11-18 11:54:05.080 Backup[22672:8537] debug: unable to test mount disk image {
    "image-components" = (
    "/Volumes/Cassini/Backups/Phobos - 2010.11.18-00.30.22.847.backXX/Contents/Contents/Backup.sparseimage"
    );
    "shadow-file" = "(null)";
    "system-entities" = "(null)";
    }
    2010-11-18 11:54:05.107 Backup[22672:8b03] unable to gzip /Volumes/Cassini/Backups/Phobos - 2010.11.18-00.30.22.847.backXX/Contents/backup.log: file does not exist
    2010-11-19 08:42:53.803 Backup[22672:bb9f] debug: unable to rename disk image {
    "image-components" = (
    "/Volumes/Cassini/Backups/Phobos - 2010.11.19-07.36.08.399.backXX/Contents/Contents/311805478.972355.sparseimage"
    );
    "shadow-file" = "(null)";
    "system-entities" = "(null)";
    }
    2010-11-19 08:42:53.848 Backup[22672:9e3f] unable to gzip /Volumes/Cassini/Backups/Phobos - 2010.11.19-07.36.08.399.backXX/Contents/backup.log: file does not exist
1 2 3 Previous Next