Skip navigation
This discussion is archived

Serious printing issue after 10.6.5 update

45207 Views 108 Replies Latest reply: Jan 8, 2011 3:18 PM by mlblacy RSS
  • hys Calculating status...
    Currently Being Moderated
    Nov 15, 2010 4:16 AM (in response to PanixP)
    ok everybody who work with freehand dont replaced the cups...
    ich have installed now the 10.6.5 combo and freehand work now again but
    i cant print landscape in adobe...
    Mac OS X (10.6.5)
  • Nastypsychoboy Calculating status...
    Currently Being Moderated
    Nov 15, 2010 6:04 AM (in response to PanixP)
    Poor show Apple!

    This is disgusting, Apple release an update which affects the software on their machines and they blame it on the third party (Adobe), but the only thing that has changed on my system is the Mac OS. Why should Adobe now have to write a fix to this error Apple have created? When will Apple wake up and realise their product and Adobe's products are the industry standard so there is no point them fighting they're only hurting/frustrating their loyal customers?

    puissance wrote: "This was a great help as the landscape printing problem had me tearing my hair out for a week. It was enough to drag the pstops file from a 10.6.4 backup to the 10.6.5 filter folder, have to enter password to make the replacement, fix group-permisions, shut down and restart. Printed landscapes correctly from Photoshop CS5. Thank you Gerrit."
    Puissance: Where did you find your 10.6.4 pstops file? And what 10.6.5 location did you drag it to? Where is the 10.6.5 filters folder? Thanks

    I can’t believe the users are even having to do/come up with these fixes when it should be Apple testing their software updates to see if they affect any other systems/software BEFORE they release them. I think it's just because they like creating errors or problems between themselves and Adobe and then blame it on Adobe, it pains me to say it because I love Apple products but if I had to lose one out of the two id say goodbye to Apple not Adobe, I can buy more hardware but I can’t learn new software.

    What happened Apple we used to be friends? Sort it out and release another update which fixes the printing problems!
    Mac Pro Quad-Core Intel Xeon, Mac OS X (10.6.5)
  • qarto Calculating status...
    Currently Being Moderated
    Nov 15, 2010 10:12 AM (in response to PanixP)
    Thanks Gerrit for your help…
    But when in step ((4b) sudo ./configure --with-archflags="-arch i386 -arch x86_64" )i get this message:

    carlos:cups-1.4.4 carlos$ sudo ./configure --with-archflags="-arch i386 -arch x86_64"
    checking for gawk... no
    checking for mawk... no
    checking for nawk... no
    checking for awk... awk
    checking for gcc... gcc
    checking for C compiler default output file name...
    configure: error: C compiler cannot create executables

    I have installed dev tools etc…
    Any suggestion?

    TIA

    Message was edited by: qarto
    mac pro, Mac OS X (10.6.5), 2*3 GHz Quad-Core Intel Xeon - 5 Gb of Ram
  • puissance Calculating status...
    Currently Being Moderated
    Nov 15, 2010 4:27 PM (in response to Nastypsychoboy)
    The locations of the files are given in Gerrit's post, above. I had a backup, on an external disk, of my previous system, 10.6.4 which used Cups 1.44. The updated OS X 10.6.5 uses Cups 1.45. I just dragged the pstops file from the backup drive to one running 10.6.5. I use an old Tektronix 740 which is a cmyk color laser postscript printer which has an old, non-supported driver.

    corrected a typo
    Message was edited by: puissance

    Message was edited by: puissance
    Mac OS X (10.6.5)
  • appleaka Level 1 Level 1 (20 points)
    Currently Being Moderated
    Nov 15, 2010 5:04 PM (in response to PanixP)
    I did not have that issue exactly but i have a PIXMA MX870 and i wouldn't work at all when upgrading, so since this is a upgrade problem i just readded the printer and it workes fine
    iMac Late 2009, Mac OS X (10.6.4), iMac, iPod Touch 2nd Generation w/ OS 3.1.3, iPod Nano 3rd Generation
  • Steve Dutton Level 2 Level 2 (360 points)
    Currently Being Moderated
    Nov 15, 2010 9:41 PM (in response to appleaka)
    Drag & Drop worked for me as well. Thanks!!
    17" MacBook Pro, Mac OS X (10.6.3)
  • hys Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 16, 2010 12:52 AM (in response to PanixP)
    hey,

    at home i havent a problem with my printer.
    i work at home with a imac 24" and a hp printer.
    but at work with the mac pro and lexmark i cant printing landscape.
    or if i fixed the problem with gerrits solution i cant use freehand.
    this is awful.

    i must choose freehand or landscape printing... it is sad.
    maybe we get a update....

    Message was edited by: hys
    Mac OS X (10.6.5)
  • branfordman54 Level 1 Level 1 (90 points)
    Currently Being Moderated
    Nov 16, 2010 8:03 AM (in response to Steve Dutton)
    Steve: This InDesign solution also worked for me, which is a huge relief. I was ripping my hair out since I have to print out 35 11" x 17" pages for a presentation. This happened another time when Apple released and update like this. That time, I remember, there was not a solution. Anyway, thanks for posting your solution!
    2.66 Quad-Core Intel Xeon Mac Pro, Mac OS X (10.6.5), 8 GB RAM
  • tjgrayling Calculating status...
    Currently Being Moderated
    Nov 16, 2010 10:29 AM (in response to PanixP)
    I'm having the same problem. Using the fix of changing my paper size from "defined by printer" to the actual paper size paper only gives a partial fix. The document will print landscape, but it will no longer duplex (print 2-sided)! This is killing me--I print tri-fold brochures almost daily. Yes, I can make pdfs and print them, but there are other issues with pdfs, including that they print much slower.

    Anybody got another fix? If not, how do I undo the update? Thanks
    27" imac, Mac OS X (10.6.5)
  • DonnieC Calculating status...
    Currently Being Moderated
    Nov 16, 2010 11:54 AM (in response to PanixP)
    I'm just trying to print pdf documents.. nothing fancy.. to a HP J4680.... starts print job then goes to "pause" and then crashes..

    Tried accessing the printer utility -- and the communication fails and crashes..

    need help..
    Donnie C
    MacBook, Mac OS X (10.6.5)
  • Scott Aronian Level 1 Level 1 (30 points)
    Currently Being Moderated
    Nov 16, 2010 11:55 AM (in response to PanixP)
    We have a several printers using Adobe Postscript and thankfully only one computer, mine, was upgraded to 10.6.5.

    Logic points to Apple not testing the combination of 10.6.5 + Adobe Products + Postscript printers. Anyone else find this a stunning oversight?

    Easiest temporary fix was to revert the "pstops" file as mentioned by Gerrit DeWitt. Thanks Gerrit!

    I used Go to Folder: /usr/libexec/cups/filter/

    Selected "pstops"

    Entered Time Machine and restored the 5/6/10 version.

    Photoshop, Illustrator and Acrobat are all printing Tabloid Landscape correctly again.
    MacBook Pro 15 (MB471LL) 4GB RAM, Mac OS X (10.6.5), 320GB (WDC WD3200BEKT)
  • vrh2 Calculating status...
    Currently Being Moderated
    Nov 16, 2010 11:56 AM (in response to puissance)
    Many thanks to Gerrit and puissance!!

    I was experiencing the same landscape printing issues as described above.
    Backdating the pstops file solved all the printing issues. Time Machine just came in really handy (again).
    FYI: The date stamp on the old pstops that I brought forward is <6/10/10 6:17 PM>. I'm using InDesign printing to an older Xerox WorkCentre Pro 2128. All printing preferences that were setup in InDesign appear functional.
    Mac Pro, Mac OS X (10.6.5)
  • office_nut Calculating status...
    Currently Being Moderated
    Nov 17, 2010 7:50 AM (in response to PanixP)
    Same here. At 9:00 I printed 80 booklets on to the bizhubC650 using InDesign's booklet settings. At 9:40 after I updated to 10.6.5, I printed 90 more of the same EXACT document but the booklets had all of the images rotated 90º counter clockwise. I thought, "OK, that's what you get for not testing a print first", but it was true about everything I tried to print using the same preset, etc.

    So I moved the document to my G5 and no problem. This is not a fix by no means. Why on earth do we upgrade our computers and software if this ** happens!
    macbook pro, Mac OS X (10.5.2), G5 tower at work
  • Gerrit DeWitt Calculating status...
    Thanks for the feedback, guys. Glad this has helped.

    Thanks to puissance for the correction. In step 5 (Option B), that last chmod command should be:

    *sudo chmod 0555 /usr/libexec/cups/filter/pstops*

    And, it's also a good point that you can simply drag-and-drop a 10.6.4 version of this from a backup to the /usr/libexec/cups/filter folder. If you do that, be sure to also change the owner and permissions on the pstops file correctly. These two commands will do that:

    *sudo chown root:wheel /usr/libexec/cups/filter/pstops*

    *sudo chmod 0555 /usr/libexec/cups/filter/pstops*

    Also, running Disk Utility's Repair Permissions (not Repair Volume) command will, on a system with a complete set of receipts, make that permission adjustment for you. Note that repairing permissions will fail if you've wiped out the com.apple-labelled Bill-of-Materials (BOM) files from /var/db/receipts.

    I actually haven't tested Freehand. I'm not even sure if there's a version of Freehand that's "supported" on 10.6, but I'd check the permissions of the pstops filter by running Repair Permissions.

    --Gerrit
    Apple Certified System Administrator, License to Apple via Sec. 2.10. of Terms; CC 3.0/Attribution to Everyone Else
  • hoomhom Calculating status...
    Hi Gerritt,

    Thank you so much for your solution to this problem. Worked perfectly for me. However, now I notice that Microsoft Office 2004 programs aren't opening at all now. Could this be related? I click on the icons in the dock, each program bounces once and then stops. Doesn't open. Does this make sense?

    I'm a designer, not a programmer, and so am completely clueless when it comes to making Terminal changes.

    Best, George
    iMac i7, Mac OS X (10.6.5)
1 2 3 4 5 ... 8 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.