Skip navigation

Can not log in after upgrading to snow leopard 10.6.5???!! help!!!!!

19147 Views 56 Replies Latest reply: Jun 3, 2012 11:50 AM by bugracakir RSS
  • Rockdoctor Calculating status...
    The other issue is that the "Other" account remains in my list, and I don't know how to hide/delete it.
    It doesn't appear in the list in the "Preferences->accounts" window.
    Mac Mini, Mac OS X (10.6.5)
  • Mcmini Calculating status...
    Hi all,

    I have found a fix to this this the first time I ve made a post apologises if my terminology isnt that clear. I updated to 10.6.5 and I lost my admin and user accounts. I had a time machine backup so I thought I'd try and mess about with possible fixs as I thought worse case I can brick my system and start a fresh. I tried a few options but the one that worked for me was to do the following what is mentioned on this link http://www.hackmac.org/hacks/how-to-create-a-new-administrator-account/

    But note I didn't follow all the steps I set the admin account as a "new" user but I used the same user name and password as my account that had disappeared and when I logged in all my data was there and my system
    was as I had left it before I shut it down after the update.The only items that I had to reconfigure where my mobile me sync as I keep mountable copy of my iDisk but this was there but appeared as a sparse bundle in a folder and IDisk appeared as a new mountable drive and synced again.this left me with 2 copies of my data and I deleted the old one.

    By no means am I a expert and please only try this if you have a back up of your data but note this worked for me and I thought as I always read and take from these forums its only fair I add my own two pence worth.

    Hope it works for you (fingers crossed)
    Macbook, Mac OS X (10.6.5)
  • Mcmini Level 1 Level 1 (0 points)
    Forgot to add I followed all steps upto number 7 only and I then did the opposite to what it said and used the same user name and password.

    Hope it's a little more simpler to follow
    Macbook, Mac OS X (10.6.5)
  • llude Calculating status...
    Hi,

    I had this exact problem. I installed the 10.6.5 update and when I finally rebooted several days later, all non-system users on my machine were deleted. Only "Other" showed up in the login screen. While the users were removed from the Directory Services, their data was still intact though, as their home directories in /Users were unchanged. This is of course a big relief...

    After reading this thread and the pages mentioned here, I came up with the following solution. Please replace "username" with the short (Unix) name of your user account (i.e. the one without spaces).

    1. Start the computer in Single-User Mode, by holding down Command+S as it boots up. You end up in a terminal as the root user.

    2. As suggested on the screen, do the following to check and mount your filesystem:

    /sbin/fsck -fy
    /sbin/mount -uw /

    3. Find out which accounts have been deleted (here I assume 'username' is one of them):

    defaults read /Library/Preferences/com.apple.preferences.accounts

    4. Convince yourself that the user data is still safe:

    ls /Users/username

    5. I noticed that the 10.6.5 update made backups of the Directory Services and shadow passwords in /private/var/db as the xar archives 'dslocal-backup.xar' and 'shadow-backup.xar', respectively. If you also have these files, you are in luck! Restore the settings for each deleted user, as well as all shadow passwords, as follows:

    cd /private/var/db
    xar -xf dslocal-backup.xar dslocal/nodes/Default/users/username.plist
    xar -xf shadow-backup.xar

    6. For good measure, remove the record of deleted users (not sure if this is necessary, but seemed like a good idea at the time):

    rm /Library/Preferences/com.apple.preferences.accounts

    7. Restart the computer:

    shutdown -r now

    I restored the settings for all deleted users in Step 5, and everyone was back after the reboot. The great thing is that all settings are restored the way they were, including the password, user GUID (which should prevent Time Machine from redoing a full backup as mentioned in this thread) and the login picture (which was stored in the JPEGPhoto field in the plist file and would have been lost otherwise).

    Of course, this solution might not apply to your specific problem, so please take care when you tamper with system settings via Single-User Mode.
    iMac 27", Mac OS X (10.6.5)
  • Brian Stroud Calculating status...
    A big thanks to llude for your input. Got the accounts back except for the one that I created after the dslocal-backup was taken.

    Now to try and understand what caused this disaster, before my customers fall into the same trap.

    I wonder, can any of the users here that experienced this problem relate to any of the following

    a) Installed the Mac OSX update Combo 10.6.5 update rather than Mac OSX update 10.6.5.
    b) Successfully manage to use the updated system for a period of time after updating to 10.6.5
    c) Install office 2011 after updating to 10.6.5
    d) Install the office 2011 14.0.1 update after updating to 10.6.5
    d) Create a new user after updating to 10.6.5

    Lets see if we can work this out.
  • cpmacg Calculating status...
    I too had a similar experience after installing 10.6.5, I used the system for a few hours before I lost all user accounts, then after recreating them I had the same thing happen again several days later.

    Hard as it seems to believe, what I noticed was that the problem was caused by USB drives.

    It's very easy to replicate. I don't even need to be logged in (although I can be and it will still happen).

    If I'm not logged in, I can insert a USB drive at the login window, after a few seconds I remove the drive, the system then gives an error saying I didn't eject the drive properly, the login screen is then refreshed and you will immediately notice that any user account not currently logged in has been removed).

    If I am logged in and I inset a USB drive it doesn't matter whether I eject the drive properly or not, as soon a I remove the drive any user account not currently logged in will be removed. It's just you won't notice it until you either try switching users or logging out/in again.

    The only work around is to either (a) leave ALL user accounts logged in or (b) shutdown the system before removing a USB drive.

    Apple needs to sort this out real quick!!!
    iMac, Mac OS X (10.6.5)
  • jmanikas Calculating status...
    I am a system Admin at a K-12 school. Our faculty use aluminum MacBooks. About 1 1/2 years old and I have about 110 in service. Of those 110, I had 4 that lost their user account. I am passing this on because it is the same problem that has been talked about in this thread but doesn't fit the pattern. In fact I can't find a pattern. In the of one of the 4 computers, the user was upgrading to 10.6.5 (pattern as described here). In the case of the other three computers, they were running 10.6.4 and the uses said they had not updated or loaded any software. The only thing I can find in common is that they had all either were restarting their computer or starting up after being shut-down.
    Aluminum MacBook, Mac OS X (10.6.4)
  • BrendanClay Calculating status...
    Thank you, Ilude.

    The same issue happened to me, which caused me some stress (as you can imagine, given that I'd not activated Time Machine).

    I followed these steps, and recovered everything.

    My two accounts re-appeared, and I went to bed a very happy man!

    (Can't see that I would have slept a great deal, otherwise!)

    Thanks again!
    MacBook Pro 13" 2.53 GHz, Mac OS X (10.6.5)
  • Kirby Krieger Level 6 Level 6 (11,570 points)
    .** THANK YOU **.

    Boom. Lost my admin user account at 4:56p today. Long-time Mac user, regularly help others, never saw this particular failure before.

    Followed llude's excellent directions (skipped #6) ... everything is restored; so far no problems.

    Most appreciate the thorough, literal, instructions.
    MacBook Pro 13", Mac OS X (10.6.5), 4 G / 500 G internal / 4 TB external / NEC 2490 / ColorMunki Photo / Sony a850
  • Tumildo Calculating status...
    Macbook Pro 13' 2,53Ghz iPhone 4 32G, Mac OS X (10.6.5), 320G
  • Roger_Marlow Calculating status...
    Hi, this sounds like the same problem as discussed on another thread. See my posting here for how I (ok, Apple Care in the UK) solved it without having to resort to reinstalling the O/S etc.

    http://discussions.apple.com/thread.jspa?messageID=12715290&tstart=0

    Basically, if you get dumped out of the login sequence back to the login screen then one of the applications in that account's login sequence doesn't like the OS upgrade. So boot the machine in Safe Mode (restart while holding down the shift key), login to the offending account and remove all the items from the login sequence in the System Preferences->Accounts->Login Items dialog. Put them back one at a time to find out which one was causing the problem (if you really need the login items that is).
    Mini, Mac OS X (10.6.5), MBP, iMac
  • connectionfailure Calculating status...
    llude is the winner! Thank you, I have been trying to figure out how to re-create my three accounts
    manually.
    First I made sure it wasn't a corrupt directory or bad permissions... also tried reapplying 10.6.5 combo update. None worked.
    I know dscl is the way to go, and I could have removed AppleSetupDone and created at least one of the accounts with Apple's scripts- I've done this before- they don't kill your data but it is wise to backup your user folder(s) before doing this.
    Anyway, this is a serious bug. Here's some proof:

    http://forums.cnet.com/7723-6126_102-505918.html?refresh=1291852001273
    http://discussions.apple.com/thread.jspa?messageID=12723879&#12723879 - this one mentioned the USB disk unmounting, with user alicantemacman mentioning that their console had entries such as:
    ManagedClient6023 MCXCDeleteAccount(): Trying to delete user id = 83
    ManagedClient6023 -xaDiskDisappeared error attempting to delete empty home account '_appowner'. localUserMCXRecords count = 75

    Curiousgene also sees this
    http://curiousgene.com/?paged=2 and http://curiousgene.com/?p=47

    Linc Davis from these forums also knew about the xar backups:
    http://discussions.info.apple.com/thread.jspa?messageID=12483682

    It might be sensible for us to disable External accounts until this is resolved- thanks Charles at Krypted-
    http://krypted.com/mac-os-x/disable-external-accounts/
    Mac 512Ke, Mac OS X (10.5.7), System 6.0.8 rules!
  • ulberbast Calculating status...
    connectionfailure wrote:
    It might be sensible for us to disable External accounts until this is resolved- thanks Charles at Krypted-
    http://krypted.com/mac-os-x/disable-external-accounts/


    So if I disable external accounts generally, there is a chance that my accounts wont be deleted again until an update from apple?

    regards

    ulberbast

    Message was edited by: ulberbast
    iMac 21,5" Late 2009, Mac OS X (10.6.5)
  • allos Calculating status...
    llude solution also solved my problem -- Only "Other..." user showing at the login screen. Thank you, llude!

    Like cpmacg and the users in this thread

    http://discussions.apple.com/thread.jspa?messageID=12723879&#12723879

    I encountered this problem with 10.6.5 and after using, ejecting and unplugging my external USB hard disk, which I use for Time Machine backups.

    I hope Apple sees that there are several other threads with this problem and fixes this soon before their reputation is tarnished. Even though llude very clearly described what need to be done, most users encountering this problem may never even find the solution or may not be comfortable doing what llude describes.

    To help clarify things for others who come along later, the issue/fix suggested by Roger_Marlow is quite different, and I believe, unrelated to the problem I and others in this thread have encountered.

    Message was edited by: allos
    2010 Macbook 13.3", Mac OS X (10.6.5)
  • mjmphoto Calculating status...
    I have just encountered this problem too on my new iMac quad core i5. No USB hard drive at moment as back is via Firewire800 Drobo, but yesterday I did update software for a Wacom Tablet. At present all external devices have been disconnected.

    I have confirmed that both my user accounts have been deleted on 2010-12-28 08:19:00 which is probably the moment I switched on my machine.

    I tried following the steps set out by llude but when I enter +Is /Users/username+ I get +Is: command not found+.

    I also do not understand what to do in step 5, as when I enter +xar -xf....username.plist+ I get +No files matched extraction criteria.+ A simplified or more complete description would be much appreciated as I am not too familiar with working in Terminal.
    MacBook Pro 15"., Mac OS X (10.6.5)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.