Skip navigation

Birthday and Anniversary are one day of in hotmail after syncing

5062 Views 10 Replies Latest reply: Feb 11, 2012 12:06 PM by Tgara RSS
Michael T 1 Calculating status...
Currently Being Moderated
Nov 27, 2010 4:30 AM
I know that there are plenty of posts out there with the same or a similar problem. Here, I try to describe the problem in a way, where everyone could reproduce it.


First, I will describe my current setup on my iPhone and then my problem:

My Calendar, Contacts, eMail are all synced with my Windows Live Account through an Exchange Account.

Exchange Account Setup:
- Server: m.hotmail.com
- Domain: <leave it empty>
- Username: <your Windows Live ID>
- Password: <your Password>

iPhone Timezone: Zurich, Switzerland (GMT +1)


Problem:
After editing one of my contacts (new or existing one) and sync it back to my Windows Live Account, the birthday and anniversary are one day off in all other Applications (on hotmails web page, Windows Live Mail, ...).

To reproduce this Problem, you have to set the iPhone timezone (Settings->General->Date & Time) manually to a timezone with a positive shift against GMT Time (Zurich with GMT +1 will do the trick). All other timezones (Lodon GMT +0, Cupertino GMT -8) are working as expected.

*My conclusion:*
There seems to be a Bug in the Exchange protocol with respect to the birthday and anniversary fields and the used timezone information.


@Apple: Please fix this Bug.


Everyone with the same problem (as well those with another Exchange Server), please post a replay.


Best
Michael

Corrected some typos
iPhone, iOS 4, iOS 4.2.1

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.