Skip navigation

MBA can't find preferred network after sleep mode

36548 Views 81 Replies Latest reply: Jan 28, 2014 12:23 PM by gmara RSS
1 2 3 ... 6 Previous Next
Simon Catton Level 1 Level 1 (0 points)
Currently Being Moderated
Nov 20, 2010 1:27 PM
Hi
Not sure if this is a MacBook Air problem, but I can't connect to my preferred wireless network when 'waking-up' from sleep. Will connect automatically on restart.
Not a problem with my old 07 MY MacBook.
Is this a fast start-up from sleep mode SSD memory issue ?
MacBook Air 11", Mac OS X (10.6.5), 128GB SSD 4GB DDR3
  • William Rivas Level 5 Level 5 (4,225 points)
    Simon Catton wrote:
    Hi
    Not sure if this is a MacBook Air problem, but I can't connect to my preferred wireless network when 'waking-up' from sleep. Will connect automatically on restart.
    Not a problem with my old 07 MY MacBook.
    Is this a fast start-up from sleep mode SSD memory issue ?


    Not s problem here.

    iMac i7 2.8iMac i7 2.93MacBook Air 2.13 (2)iPhone 3GS 32GB, Mac OS X (10.6.5), iPhone 4 32GBiPod Classic 160GB iPod Touch 32GB
  • William Rivas Level 5 Level 5 (4,225 points)
    Simon Catton wrote:
    Hi
    Not sure if this is a MacBook Air problem, but I can't connect to my preferred wireless network when 'waking-up' from sleep. Will connect automatically on restart.
    Not a problem with my old 07 MY MacBook.
    Is this a fast start-up from sleep mode SSD memory issue ?


    Did you try a permission repair, verify disk and reset PRAM?

    iMac i7 2.8iMac i7 2.93MacBook Air 2.13 (2)iPhone 3GS 32GB, Mac OS X (10.6.5), iPhone 4 32GBiPod Classic 160GB iPod Touch 32GB
  • macintoshforlife Level 1 Level 1 (0 points)
    I'm having the EXACT same problem. You're not alone. Just upgraded to a MacBook Air from a 2007 black MacBook.

    I never had trouble connecting to my preferred networks on my old mac. But with the Air it takes a about 30 - 45 seconds to connect to my internet. And I have to keep refreshing my homepage until it finally loads up.

    I feel it has to do with the instant start up. Maybe the computer turns on so fast that the airport doesn't connect to the web in time. But it seems so silly, Apple is better than that.

    I look forward to hearing a resolution.
    MacBook Air, Mac OS X (10.5.6), 2.16 Intel Core 2 Duo 4GB RAM 256gb HD
  • kn7671 Calculating status...
    I've found that when resuming from sleep (lid closed), that my MacBook always wants to fall back to first Preferred Wireless network stored and listed under the AirPort Advanced Settings. This happens even if prior to Sleep Mode I had chosen another wireless network at my house, as I have three to choose from.

    I suggest taking a look at the AirPort Advanced Settings and confirm that the wireless networks are listed in the correct order, and that you haven't selected any optional settings to adversely affect your wireless startup.
    MacBook Air 13, Mac OS X (10.6.5), 2.13 GHz - 256 GB SSD - 4 GB RAM
  • Pastor John Calculating status...
    What fixed it for me seemed to be a combination of:
    - downloading the firmware update via the Apple site, not the Software Update
    - updating my Airport Express router
    - allowing the computer to run all chron scripts over a week

    Not that I know anything about this sort of stuff! But I experienced the same issue when I first got my MBA, and after doing the above, the issue has not returned, and the computer is 100% reliable.
    MBA 2.13/4gb/256gb, Mac OS X (10.6.5)
  • wifiguru Level 2 Level 2 (230 points)
    Next time you connect to the network hold the Option key down and click on the AIrPort Menu Extra and note the RSSI value.

    A good RSSI is usually between -35 and -75. Anything lower than -80 and you are really at the edge of the network and there are other factors that come into play when you attempt to connect to the network.
    Try moving close to the AP and then sleep wake a couple times and verify. Move the network you want to join to the top of the Preferred Lists.
    Also which channel is this wireless network on ?
    Pick channels 36-48 if you are in 5 Ghz mode. Also make sure your network is not hidden as it sometimes complicates things.
    Mac OS X (10.6.4), 11"/13" MBA, 13"/15" 2010 MBP, All iOS devices
  • MeltingSnowtime Calculating status...
    This just happened today out of the blue. Reconnection has worked for months ( a year and a half) but this morning I closed the lid and left the house for a couple of hours then opened the lid and no reconnect to my hidden, but preferred network.

    I seem to have fixed it as follows:

    Turn off Airport, remove my preferred network from Network Preferences - Advanced - Airport tab, remove the corresponding airport network password entry from Keychain access (find that under Applications - Utilities folder), turn on Airport, no connection since it is a hidden network, click "Join other network" from "Airport Menu bar item", enter hidden network name, choose WPA2 (for my setup), enter password, check "Remember this network", click "Join", enter system password when asked.

    This recreated the "Preferred networks" entry in the Network Preferences. I dragged it to the top of the list again. It also recreated the Keychain entry.

    Turn off Airport, then turn on again. Reconnect worked!
    Close lid, then open lid again. Reconnect worked!

    What made it stop? Who knows! maybe closing the lid at the precise moment that keychain is being accessed by some other application maybe? My Time Machine icon showed a failure. Maybe it was starting up at the moment that I closed the lid. Maybe it just failed because the Airport didn't reconnect. I don't know. YMMV
    MacBook Pro, Mac OS X (10.5.6)
  • MeltingSnowtime Level 1 Level 1 (0 points)
    UPDATE: My profile wasn't quite up to date. The OS version could be relevant. I'm running 10.6.5, not what was tagged in previous post.
    MacBook Pro 4,1, Mac OS X (10.6.5)
  • gear_man Calculating status...
    Thank you, I was having this problem with my MacBook Air as well and your steps resolved this issue. I have a hidden network (WPA Personal) at home and after closing the lid I would have to turn Airport off, then on again to join my home network. By removing the network AND the associated keychain entry, then rejoining the network, my computer now automatically joins my home network upon opening the lid.
    MacBook Pro and MBA, Mac OS X (10.6.6)
  • nickbailey Calculating status...
    "Makes me think it was a problem with that specific wireless modem.
    But then again that would not explain why it worked with the 2007 MacBook running 10.6.5"

    Nope! It's not going to be your router or your wireless netowrk. There is some deep firmware/driver/OS issue with the MBA that is clearly not working.

    Don't let Apple bully you into thinking it's your network that's the problem when they need to get off their backsides and sort this out.
    MBA 13" (late 2010), Mac OS X (10.6.5), 2 gig RAM
  • hawleyrw Level 3 Level 3 (625 points)
    I've seen issue with this also, but it just hasn't been enough of a problem to bring up here, but since someone else did....
    the only issue I've had is this...and it started a few weeks after I had the system. I just recently rebuilt the system from the USB flash (because of an Aperture/Final Cut Exp. issue -to prove a point), and I haven't had it happen since....

    We'll see.
    iPad WiFi/3G, MBA 13" (2010), Mac OS X (10.6.6)
  • StacyStarStar Calculating status...

    Thank you so much, MeltingSnowTime! My computer had been finding my hidden network just fine until one day when the battery died, at which point I had to type everything in again to find my hidden network every time I put my computer to sleep or turned off my Airport! Your solution was finally the one that got it to find my hidden network again!

1 2 3 ... 6 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.