Skip navigation

emailing photos as attachment files

64709 Views 46 Replies Latest reply: Aug 16, 2013 12:25 PM by Angelaont RSS
1 2 3 4 Previous Next
nellohswake Calculating status...
Currently Being Moderated
Jun 12, 2010 12:09 PM
How do I attach an iphoto as a jpeg file attachment to an email that can be opened and managed by a pc windows user? All my email photos show as actual photos imbedded in the email and can't be taken out of the email by the pc user.
iMac, Mac OS X (10.6.3)
  • MadisonP Level 5 Level 5 (4,485 points)
    Currently Being Moderated
    Jun 12, 2010 1:26 PM (in response to nellohswake)
    Welcome to Apple discussions,

    I assume you are using the built in "Email" feature of iPhoto to send your images. While the Mail window shows the images as if they were part of the body of the message, the pictures are still attached just like any other email. I use this feature to send pictures to those of my relatives that use Windows all the time.

    If the person you are sending to says they do not see the pictures you can do the following (Note: This is not necessary for using Windows machines but if the person says they can't see it's all I can suggest.):

    1.) Make a new folder on your desktop (File > New Folder)
    2.) Highlight the pictures you are going to send to the person
    3.) Go to File > Export > File Export and export the pictures into that new folder
    4.) Click on the folder on the desktop and go to File > Compress
    _This will create a .ZIP file with the same name as the folder.
    _You can drag this .ZIP file into your email message and send it.
    NOTE: If the images are too large the file will not send. Most email providers will not let you send send attachments over 10 MB. To see how big the ZIP file is, click on it once and then go to File > Get Info and note the size. If it is over 10 MB you might want to send several smaller emails with fewer pictures or when you use the File > Export feature of iPhoto change the "Size" to something smaller.

    Finally, If you are a MobileMe member you could make a Web Gallery of your pictures and send that to the Windows user.

    Hope that helps.
  • Terence Devlin Level 10 Level 10 (121,725 points)
    Currently Being Moderated
    Jun 12, 2010 11:39 PM (in response to nellohswake)
    In Mail, send Plain Text emails. (Mail -> Format Menu: Make Plain Text).

    Regards

    TD
    MacBook Pro 15 2.4 C2D / iMac 20" 2.66 C2D, Mac OS X (10.6), 4 gig RAM/ 4 gig RAM
  • TC Jim Calculating status...
    Currently Being Moderated
    Jun 23, 2010 3:39 PM (in response to Terence Devlin)
    I purchased new Mac Mini recently and have experienced the same problem. When emailing photos directly from iPhoto, the photos show up on a Windows PC (such as my office computer) embedded in the email text. That means there is no way for a PC user to save any of the photos as jpeg files. This was never a problem with my old Mini (which ran OS 10.4). Why does this happen with the new OS? I'd prefer to not take the extra step of exporting to a desktop folder and then attaching it to an email; the "old" method was wonderfully simple. Is there a Preferences setting that I can change to fix this problem?
    Mac Mini, Mac OS X (10.6.4)
  • Terence Devlin Level 10 Level 10 (121,725 points)
    Currently Being Moderated
    Jun 23, 2010 11:25 PM (in response to TC Jim)
    This is a setting in Mail, not iPhoto.

    As I said above:

    In Mail, send Plain Text emails. (Mail -> Format Menu: Make Plain Text).


    Regards

    TD
    MacBook Pro 15 2.4 C2D / iMac 20" 2.66 C2D, Mac OS X (10.6), 4 gig RAM/ 4 gig RAM
  • jhrichmond Level 1 Level 1 (10 points)
    Currently Being Moderated
    Jun 24, 2010 4:10 PM (in response to Terence Devlin)
    Hi
    I have set my mail preferences to send as plain text as suggested by Terence.
    Here is what happens

    I select a photo in iphoto and click the Email icon at the bottom right of the screen. The email program opens and the photo appears embedded in the email rather than attached. When I send this to a friend using outlook on Windows, the email arives with the photo embedded in the body of the email, not as an attachment

    However, if I export the photo to my desktop, then open the Mail program, create a new email to my friend and ATTACH the photo from my desktop, then whilst it still looks like the photo is embedded in the text from my Mac end, when my friend receives it in Outlook, the photo is attached in the expected way, not embedded in the text

    Is there a way to make the "Email" icon in Mail work the same way - i.e. to attach the photo as an attached file rather than embed in the text of the email?

    I ask because I send photos for people to save in original size and format so they can print - embedded photos in the text are no good for this
    iMac 2.66Ghz 4GB 640GB (Sep 2009), Mac OS X (10.6.2), iPhone 3G
  • Terence Devlin Level 10 Level 10 (121,725 points)
    Currently Being Moderated
    Jun 24, 2010 11:15 PM (in response to jhrichmond)
    What's happening here is that Mail is making a Rich Text email from the one sent from iPhoto. Why it does that for you I don't know (it doesn't for me) but i would ask that on the Mail forum as it's a Mail issue.

    Regards

    TD
    MacBook Pro 15 2.4 C2D / iMac 20" 2.66 C2D, Mac OS X (10.6), 4 gig RAM/ 4 gig RAM
  • doichuck Calculating status...
    Currently Being Moderated
    Aug 25, 2010 3:38 PM (in response to nellohswake)
    If you don't want to change the Mail pref to 'plain text' you can:
    1. after you email from iphoto and it opens in Mail, copy the image and compose a new message with some text in the body of message and then paste image after that text; or
    2. from mail click on 'iphoto button' in top right and search for the image. You will still have to put text in the body of message before placing photograph. Also in doing this the photograph is same size as original in iphotp library.

    The catch is that the image arrives as an attachment not an image.

    Apple need to reconfigure iPhoto email so it places a the file name before the image to solve this and they should also look at the Mail software for a fix to having to have text before an image.
    Macbookpro/Imac Intel, Mac OS X (10.6.1), Imac intel
  • markosaben Calculating status...
    Currently Being Moderated
    Oct 14, 2010 1:01 PM (in response to nellohswake)
    I too am struggling with this issue and would like a native solution for sourcing emails from inside of iphoto.

    If a new email is created in mac mail and i drag the photo from iphoto windows machines get a file attachment as desired. Mac Maill is set for /mail/edit/attachments/'always insert attachments at end of message'. However, if i highlight a photo inside iphoto and click on Mail (the same mail engine) the windows machine gets the photo in the body of the message.

    Is anyone aware of a fix for the iphoto to mail defect? BTW, not interested in plain text email.

    ...marko
    imac, Mac OS X (10.6.4)
  • bythecshore Level 1 Level 1 (25 points)
    Currently Being Moderated
    Nov 29, 2010 6:09 AM (in response to markosaben)
    I too am having this problem, as when I got to work I saw (on my Windows computer) an email I had sent from my home Mac, an email with a jpeg embedded in the text, and I couldn't open or work with it.

    A quick Google search found this advice: To tell Mail to use Windows Friendly encoding for all new messages, choose Edit > Attachments > Always Send Windows Friendly Attachments. (Although this command appears on a menu, it's actually saved as a preference.) Oddly, this command is disabled when composing a new message.

    I'll try this tonight when I get home but thought it might be useful meantime for others to try.
    iMac 2.46 GHz Intel Core 2 Duo, Mac OS X (10.6.4), iPhone 4, Dell laptop at work w. Windows 7
  • Terence Devlin Level 10 Level 10 (121,725 points)
    Currently Being Moderated
    Nov 29, 2010 6:15 AM (in response to bythecshore)
    If this is the problem:

    an email with a jpeg embedded in the text, and I couldn't open or work with it.


    then this

    Edit > Attachments > Always Send Windows Friendly Attachments.


    is not the solution. All this does is strip the resource fork from files (that have one) and which can confuse Windows into showing the file as two files.

    To solve the problem of the embedded photos simply send Plain Text emails as detailed above.

    th
    MacBook Pro 15 2.4 C2D / iMac 20" 2.66 C2D, Mac OS X (10.6), 4 gig RAM/ 4 gig RAM
  • tsbee Calculating status...
    Currently Being Moderated
    Dec 2, 2010 8:50 AM (in response to nellohswake)
    If you attach the photos and then two finger click (right click) then select view as icon. This makes image turn to jpeg file.
  • Terence Devlin Level 10 Level 10 (121,725 points)
    Currently Being Moderated
    Dec 2, 2010 9:04 AM (in response to tsbee)
    It just displays what's a;ready a Jpeg as an icon instead of as embedded. It only affects the display on your Mail app on your machine. It makes no difference to the receiver's email.


    Regards

    TD
    MacBook Pro 15 2.4 C2D / iMac 20" 2.66 C2D, Mac OS X (10.6), 4 gig RAM/ 4 gig RAM
  • Bush-Man Calculating status...
    Currently Being Moderated
    Jan 3, 2011 9:43 AM (in response to nellohswake)
    I've finally solved this problem once and for all - it certainly worked for me!

    Open: Applications>Utilities>Terminal and type (without the inverted commas):

    "defaults write com.apple.mail DisableInlineAttachmentViewing -bool yes"

    That will make every attachment you send act like an attachment instead of a pretty unusable decoration.

    If you decide this isn’t what you’re looking for, to restore inline attachment viewing type (again, without the inverted commas):

    "defaults write com.apple.mail DisableInlineAttachmentViewing -bool false"

    Restart Mail and you’re back to normal.

    I found this solution on the following site (this guy is a genius and deserves to be thanked!):
    http://micahgilman.com/play/disable-mac-mailapp-inline-image-attachments/comment -page-2/#comment-3029
    iMac, Mac OS X (10.5.8)
  • biz870 Calculating status...
    Currently Being Moderated
    Jan 29, 2011 1:15 PM (in response to Bush-Man)
    AWESOME! This is the first solution that actually works the way that many users want to. After typing "defaults write com.apple.mail DisableInlineAttachmentViewing -bool yes", Apple Mail simply attaches the photo, instead of embedding it in the mail.

    THANKS Bush-Man!
1 2 3 4 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.