Skip navigation

iOS 4.2 Still NO Fix for USB Car Audio (AVN726E)

12077 Views 21 Replies Latest reply: Mar 27, 2011 8:24 PM by ok88 RSS
1 2 Previous Next
Shane2231 Calculating status...
Currently Being Moderated
Nov 23, 2010 1:47 PM
With the Release of iOS 4.2.1; I rushed to update hoping that it would fix my USB to Car Audio, but it doesnt, what exactly is Apple trying to accomplish by removing functionality..

I own an Eclipse AVN726E which I've come to learn is also the system that Toyota/Lexus uses in some of their vehicles..

Granted I can play audio through the Bluetooth Audio selection but then the devices doesnt charge..

I plug in my iPhone 4 and it just hangs on "Reading..."

Does anyone have any ideas or anything that I can try to make this work..
Or is this all in the hands of Apple..
MBP 13' | iPhone 4, Mac OS X (10.6.5)
  • sn4p2k Level 4 Level 4 (1,215 points)
    Currently Being Moderated
    Nov 23, 2010 2:20 PM (in response to Shane2231)
    unfortunately its all in the hands of apple theres no known fix for this outside of apple fixing there software
    macbook pro 17 inch - iPhone 4, Mac OS X (10.6.4)
  • gomac54 Calculating status...
    Currently Being Moderated
    Nov 23, 2010 2:42 PM (in response to Shane2231)
    Our Kenwood unit was doing the "Reading..." hang. Googleing the problem, we found that resetting the unit (pressing a small button with a paper clip) cleared the problem. Just a thought...
    Mac Pro, Mac OS X (10.4.10)
  • Johnathan Burger Level 6 Level 6 (14,430 points)
    Currently Being Moderated
    Nov 23, 2010 3:02 PM (in response to Shane2231)
    It's not Apples responsibility at all.
    They did not make the stereo.

    Ask whoever madecthe stereo how or when they will fix their product to be iOS 4.2 compatible.
    20" iMac Core 2 Duo 2.66Ghz;4GB RAM;Nvidia 9400, Mac OS X (10.6.4), 4G iPhone-Mac Mini Core2 Duo 2Ghz; 2GB RAM Eyetv w/USB HYbrid
  • Jeep Watson Calculating status...
    Currently Being Moderated
    Nov 23, 2010 10:15 PM (in response to Shane2231)
    I've got a Kenwood KDC-MP345U and had the "Reading" hang problem after doing the 4.2.1 update. This worked for me...

    I simply did a full restore using the Restore button in iTunes. It will ask you if you want to back up your phone first -- cancel out and do it! Then hit the Restore button again. This will restore the iPhone to factory settings. The phone then will update itself to the latest operating system (4.2.1). Finally, restore your own settings from your last backup. When I plugged in the phone into the MP3U, I got the "Reading" message for about 2 seconds and then everything went back to normal. Also, all my settings on the phone are exactly as before -- don't skip the backup immediately before the Restore.

    Hope this helps someone else...
    Mac Pro Quad 2.66GHz, Mac OS X (10.5.6)
  • Seymourp Calculating status...
    Who is this fool Johnathan Burger? The interface between our Stereos and Iphones was working well in ios 4.0.1, and the genius Apple software team has managed to remove this functionality, and some halfwit suggests that we ask the stereo manufacturers to fix this? Has Apple done this in an attempt to extract more licence fees, or are they just incompetent?
    Dell, Windows 7
  • dmjones Level 1 Level 1 (10 points)
    Currently Being Moderated
    Nov 24, 2010 6:55 AM (in response to Seymourp)
    Ditto...

    When you have a ton of car manufacturers with this problem after 4.1 (when everything worked fine before) then Apple change something to cause the problem. Apple needs to address it.
    iOS 4
  • johninsj Level 1 Level 1 (70 points)
    Currently Being Moderated
    Nov 24, 2010 7:34 AM (in response to dmjones)
    As I posted in the other Volvo car dock thread, 4.1 broke Nissan dock compatibility, and 4.2.1 restored it. They changed something, and changed something else, and now a different subset of car audio docks do and don't work.
    ip4, iOS 4, can also use other OSes
  • TheDabbo Calculating status...
    J. Berger= Apple Fanboy. If the car stereo worked with every OS update in the last 3 years (like mine did), and it suddenly won't recognize the iPhone, my money says Apple changed/screwed something up. But I digress- I reset my stereo (remove the faceplate and find the reset button) and.... It worked. That is the first time I have had to do that in order to get the USB input to work.
    Old, iOS 4
  • p Nicholas k Level 2 Level 2 (205 points)
    Currently Being Moderated
    Nov 26, 2010 6:34 AM (in response to Shane2231)
    I have a Volvo with USB connection and I have never had problems playing the iPod or other audio applications through the car's system... until now. When I connect the iPhone to the car, the car stereo displays "loading iPod", then it says, "Unreadable."

    I think there is no question that this is on Apple, because one the the enhancements that Apple lists in in the description of 4.2 is "Improves audio playback to car stereos via USB."

    So far, my improvement is that the feature went from working perfectly, to not working at all. I drive a lot for my business and listen to Podcasts and music through my iPhone. I cannot believe that Apple could let something like this slide through.
    15'MBPi5, MBair1.6, Mini2.66C2D, Mac OS X (10.6.5), iPhone 4 & Nano - TC and AiExtreme n & Express
  • Seymourp Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 26, 2010 11:52 AM (in response to p Nicholas k)
    I have tried all the suggestions - still cant get any connection going. The really annoying thing is that the customer contempt centre thinks this is funny and will not allow us to regress to 4.0.1, even though this would solve the problem.
    Dell, Windows 7
  • Soapworld Calculating status...
    did u get this to work on your volvo?
    Sony Vaio
  • SK42 Calculating status...
    I also have a 2010 Volvo and upgraded my iPod Touch 4 to OS 4.2 My iPod no longer works in the car. Is there a way to go back to the previous OS?
  • Maarten Van Den Hoek Calculating status...
    Currently Being Moderated
    Nov 29, 2010 9:34 AM (in response to SK42)
    jup there is, look in the thread here and you will find sites with old images and the procedure to roll back

    http://discussions.info.apple.com/thread.jspa?threadID=2657752&start=90&tstart=0
    ipod iPhone ios 4.2, iOS 4, Downgrade volvo ios 4.2 Apple ipod iphone
  • Macnbaish Calculating status...
    Currently Being Moderated
    Nov 29, 2010 9:37 AM (in response to Shane2231)
    I have a Pioneer DEH-P5200HD head unit. This is less than a year old. It worked fine with iOS 3.X, but since 4.0 is released it has problems connecting to my iPhone 3G. 4.2 improved the situation some, but it's still very flaky. Often I have to reboot the iPhone before it will connect and start playing. Other times I have to plug and unplug multiple times before it finally syncs and starts working. Rarely does it work correctly on the first try. It seems to me that when the phone is under any kind of load it does not respond to the head unit fast enough, which causes everything to get messed up. Apple needs to somehow dedicate processing to this functionality to fix this problem, in my opinion.
    3G, iOS 4, 4.2.1
1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.