Skip navigation

can't edit events on ical

12432 Views 20 Replies Latest reply: Nov 14, 2012 10:03 AM by kwh_tyro RSS
1 2 Previous Next
loebtmc Calculating status...
Currently Being Moderated
Oct 19, 2010 11:27 AM
all edit and other menus pop up behind the calendar and can't be accessed (discovered when I displayed all open files and cd then see the edit window- but couldn't bring it front)

HELP? can anyone advise?

thank you
mac osx 10.5.8, Mac OS X (10.5.8)
  • MadisonP Level 5 Level 5 (4,485 points)
    Currently Being Moderated
    Oct 19, 2010 11:32 AM (in response to loebtmc)
    Welcome to Apple Discussions,

    Check to make sure your Region is set to your country rather than "custom".
    Apple Menu > Language&Text > Formats > Region > Your Country (Like United States)

    __Test iCal

    Make an iCal backup, File > Export > Archive.

    Remove the following to the trash and restart your computer:
    Home > Library > Caches > or ical
    Home > Library > Calendars > Calendar Cache, Cache, Cache 1, 2, 3, etc. (Do not remove Sync Cache or Theme Cache)
    Home > Library > Preferences > (There may be more than one of these. Remove them all.)
    __NOTE: Removing these files will remove any shared (CalDAV) calendars you may have access to. You will have to re-add those calendars to iCal > Preferences > Accounts.

    Hope that helps.
  • Randy Stankey Calculating status...
    Currently Being Moderated
    Oct 21, 2010 11:13 AM (in response to MadisonP)
    I seem to have the same problem.

    Can add and delete items to events/calendars or to-do lists but, once initially entered, I can not edit them. The only way to change any item is to delete it and re-add it.

    My region is set to United States, as it should be.

    I have backed up to an iCal archive and deleted all the files from ~/Library/Caches/... ~/Library/Calendars/... and ~/Library/Preferences/... as instructed above.

    I do not see any change.

    Your help would be apprecieated!
    Mac Pro 2 x 2.8 GHz Quad-Core Intel Xeon, Mac OS X (10.6.4), Memory 6 GB 800 MHz DDR2 FB-DIMM
  • Randy Stankey Level 1 Level 1 (60 points)
    Currently Being Moderated
    Oct 21, 2010 11:51 AM (in response to Randy Stankey)
    More info:

    Have repeated the process described above. Emptied the trash and rebooted.

    Unpublished all my calendars.
    Deleted all my calendars.
    Re-imported all my calendars from the above-mentioned archives.
    Unpublished, deleted and trashed everything a second time.
    Re-entered items into an empty incarnation of iCal, by hand.

    All with negative results.

    Can enter new Events/To-Dos.
    Can change anything that has a pop-up, a check box or a date field.
    Can add/delete invitees.
    Can edit Location field.

    CAN NOT edit the title field.
    The only way to change it is to delete the entire event/do-do and re-enter a new one.

    This creates two problems:

    1) Can't correct misspellings or make changes to the title. If you published calendars, you can not correct them and have the corrections propagate to your subscribers unless you delete the event and re-enter it by hand. IF you have other data such as invitees, descriptions, attachments, etc. ALL this data needs to be re-entered by hand. This creates a lot of work when all you want to do is update a mistake or make a minor change in the title.

    2) If you publish your calendars and you auto-update them, the auto-update feature closes the event/to-do for editing every time it updates. Once that initial edit-entry session has closed, you can NOT re-edit.
    So... IF you are entering a new item, auto-update shuts you out and you can not re-edit. You have to delete the item and re-enter it from the beginning.

    Otherwise, you have to shut off auto-update and hope you don't make a mistake in typing, double check and triple check your work BEFORE you close the initial edit-entry session. Then you have to turn auto-update back on then pray that nobody comes along and wants you to make changes.

    Very inconvenient...
    Mac Pro (2.8 GHz) 8-Core., Mac OS X (10.5.6)
  • MadisonP Level 5 Level 5 (4,485 points)
    Currently Being Moderated
    Oct 22, 2010 9:30 AM (in response to Randy Stankey)
    _Export each local calendar out as it's own ics file by clicking on each one one at a time to highlight and then going to File > Export > Export.
    _Delete all the calendars but one - Edit > Delete
    _Add a new calendar - File > New Calendar
    _Delete the remaining old calendar
    _Try adding / changing events -- does it work?

    If so close and re-open iCal to ensure the old calendars do not come back.

    _Now add each of the calendars back in by opening up each ics file you created 1 at a time and added to a "New Calendar".
  • Randy Stankey Level 1 Level 1 (60 points)
    Currently Being Moderated
    Oct 23, 2010 10:31 PM (in response to MadisonP)
    Nope... Sorry.

    Exported all calendars.
    Deleted all calendars.
    Created a new blank calendar, leaving it the only one in the list.

    Can create new event.
    Can edit its title in the INITIAL edit session but, once the item closes for editing, it can not be re-edited.

    e.g. - Create item Enter a title such as "My Event."
    Click outside the items bounds. Item is closed for editing.
    Double-click inside item to bring up its information balloon and click "edit."

    All items but the title can be edited: Note, URL, Attachments, Invitees, Alarm, Calendar, Show As, Repeat, From, To, All-Day and Location. Simply click in the field and type or select from the list.

    Can not click on the title, "My Event" to edit. The field box highlights white but you can not select text or type in the box.

    You must delete the item. Add a new one to replace it and be sure to type it correctly, the first time. Once it is closed for editing, it is "frozen."
    Mac Pro (2.8 GHz) 8-Core., Mac OS X (10.5.6), iCal 4.0.3
  • MadisonP Level 5 Level 5 (4,485 points)
    Currently Being Moderated
    Oct 24, 2010 7:33 PM (in response to Randy Stankey)

    What happens in a new user on the same computer?
  • Randy Stankey Level 1 Level 1 (60 points)
    Currently Being Moderated
    Oct 24, 2010 11:48 PM (in response to MadisonP)
    Create a new user and it works all right.

    For any already-existing user, it does not work.

    Repaired permissions and rebooted with negative results.
    Mac Pro (2.8 GHz) 8-Core., Mac OS X (10.5.6)
  • kterbo Calculating status...
    Currently Being Moderated
    Oct 28, 2010 9:09 PM (in response to loebtmc)
    Come on Apple.. there is a malfunction in ical all coming around the same time...
    I have this problem too and it just happened two days ago. Virus maybe to new software some people uploaded??
    What is going on? I can't edit anything in the calender but I can post to do notes on the side. I dod not change any of the settings, it just locked down.........
    mackbook pro, Mac OS X (10.5.8)
  • Randy Stankey Level 1 Level 1 (60 points)
    Currently Being Moderated
    Oct 29, 2010 1:40 PM (in response to kterbo)
    I'm going to have to jump on that bandwagon, too.

    I have not used iCal very much in the past because I have been using other apps that do almost the same thing. However, I decided to try iCal again because I wanted better consolidation of e-mail, address book, calendar and to-do lists. I am disappointed to find that iCal does not work as expected, when I expect it to work.

    Do I think it's due to a virus or something? No!

    Do I think Apple is behind the ball? Yes!

    I would very much like to, at least, hear that somebody is paying attention to the problem and that a solution is in the works if not forthcoming.

    Somebody needs to get in front of the ball! I needed iCal to work "yesterday." I do not want to have to take the time to undo all my work in iCal and redo it, once again, using another solution. I do not have time to trifle with such details.

    I just need it to work.

    Thank you in advance.
    Mac Pro (2.8 GHz) 8-Core., Mac OS X (10.6.4)
  • mlamar Calculating status...
    Currently Being Moderated
    Nov 2, 2010 3:04 AM (in response to loebtmc)
    I'm having a similar problem. I double click an event on my calendar and the event editor does not appear. If I hit the F10 key, the editor comes forward, but it disappears when I lift my finger from the F10 key. When I choose Hide Others from the iCal menu, the editor window does not show. Also, I must delete the event and re-enter it to edit its name, as others in this thread have noted. It's not just a problem with being able to edit. I can't even bring the editor window out to read it unless I depress and hold the F10 key. I haven't tried any of the fixes that have been suggest because it seems that they didn't help. Any other suggestions??
    macbook 2.16 GHz, intel core 2 duo, Mac OS X (10.5.8), 12" powerbook HD in enclosure
  • Emily Kessler Level 1 Level 1 (35 points)
    Currently Being Moderated
    Nov 26, 2010 10:30 AM (in response to mlamar)
    I'm also having the same problem. I've tried everything that's been suggested in this post and others (i.e. deleted cache files and preferences, removed duplicate fonts from Font Book, etc) but I still cannot edit any text in existing iCal events. I can add events without issue, and can change the time of existing iCal events. But, no text editing is possible.
    MacBook Pro & iPhone 4, Mac OS X (10.6.5)
  • c_estus Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 29, 2010 8:04 PM (in response to loebtmc)
    OS 10.6.5-

    I'm also in the same boat- I deleted all caches, and pref files, etc. as mentioned and it worked fine lat night, but tonight, I'm back in the same place. I get a message- "This calendar was created by Mail." yadda yadda yadda.

    I am only able to add events through either iPhone, iPad, or my Mobile Me. NOT from my desktop, which is where I would like to add them.

    Apple? Anyone listening?
    iMac G4, Mac OS X (10.6.5)
  • Emily Kessler Level 1 Level 1 (35 points)
    Currently Being Moderated
    Nov 30, 2010 8:44 AM (in response to c_estus)
    I was able to solve my issue. It was a duplicate fonts problem. Font Book wasn't even recognizing that I had an issue with Lucida Grande. I reinstalled Snow Leopard from the original disks. Then ran software updates. The new install found the duplicate font problem and that solved the issue for me.
    MacBook Pro & iPhone 4, Mac OS X (10.6.5)
  • Steve St James Calculating status...
    Currently Being Moderated
    Dec 15, 2010 8:20 PM (in response to loebtmc)
    The edit function works but is strangely limited. I can edit many aspects of a repeating event on the iPad, but I can not edit the end date, the option does not exist
    iPad, Mac OS X (10.4.1)
1 2 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (1)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.