Skip navigation

Can't send MMS on O2, 4.2.1 - iPhone 4

39320 Views 17 Replies Latest reply: Oct 23, 2011 3:25 PM by lisa-jayne3 RSS
1 2 Previous Next
JamesRene Calculating status...
Currently Being Moderated
Nov 30, 2010 6:11 AM
I am having problems with my iPhone 4 not being able to send MMS, on contract with O2. It is only less than 2 months old.
The guys at O2 have no idea why this is happening as all my settings are correct, even the Apple tech guys are at a loss... could this be a bug in the update? Or something to do with the O2 carrier settings?
Any help would be much appreciated

J.
iMac 3.06GHz, MacBook Pro 2.66GHz, Mac OS X (10.6.4), iPhone 4 16GB, iPhone 3G 8GB, Powerbook G4, 1.67 GHz, iPod 8GB Classic
  • ke11111y Level 1 Level 1 (105 points)
    Currently Being Moderated
    Nov 30, 2010 8:47 AM (in response to JamesRene)
    Hi, my Dad had a similar problem on his and it turned out he had the mms switch turned off. You've probably already checked this but I thought it was worth a mention. Settings/messages/mms messaging.
    iPhone 4, iOS 4
  • Stinkycheeseman Level 1 Level 1 (15 points)
    Currently Being Moderated
    Nov 30, 2010 8:56 AM (in response to JamesRene)
    My wife and I are having the same challenge, as are others who have posted in the O2 support forum. Still no solution though. Hope it's sorted ASAP as I use MMS a lot.
    iMac, Mac OS X (10.6.4), iPhone 4 32GB Time Capsule 500GB
  • sarush Calculating status...
    Currently Being Moderated
    Nov 30, 2010 12:54 PM (in response to JamesRene)
    I updated my iPhone 3GS to 4.2 last night. This morning, I couldn't select MMS from the photo library or go into my texts and select the camera icon. After doing a few quick searches all I found were posts like these.

    Oddly enough, I don't have an MMS option in my messaging settings...it seems preposterous Apple would turn off MMS or make such a weird error in an OS update...and then I thought, duh, restart your phone. I always forget to do that when updating my iPhone.

    So, just restart the phone. All the normal MMS options showed up. Hope it works and you all aren't experiencing some other issue.

    Message was edited by: sarush. Screwed up the MMS acronym.
    iMac, Mac OS X (10.5.8)
  • Jon Coley Level 2 Level 2 (200 points)
    Currently Being Moderated
    Dec 18, 2010 11:09 AM (in response to JamesRene)
    I'm having the same trouble with my iPhone 4 on o2 as well. Although, it only seems to be a problem with pictures taken on the phone. When I've tried to MMS an image copied from Safari, it sends no problem so I can only think it's something to do with the MB size of the image taken by the iPhone but I was led to believe that the iOS 4 update allowed MMS messages of up to 2mb to be sent.

    Another thought is, should I have a good 3G connection in order to send a largish MMS? Where I live, there is no 3G reception.

    Jon.
    Dual 2.3 GHz PowerPC G5, Mac OS X (10.5.5), MacBook Black, Quicksilver G4, Mighty Mouse, iPhone 4 16gb, iPod 3rd Gen
  • Peter Gillespie Level 6 Level 6 (10,760 points)
    Currently Being Moderated
    Dec 18, 2010 1:09 PM (in response to JamesRene)
    There does appear to be a problem with the latest O2 carrier settings
    O2 recommend until sorted
    Settings>General>Network>Mobile Data Network>MMS
    reset ......MMS max Message size to 307200

    This has worked for most people reporting issue on the O2 User Forum

    although as usual initial issues raised had the Usual O2 response ....Oh its Apples problem
    they have now it appears worked out it is their carrier settings causing a timeout on sending
    a MMS up to the size allowed by the original setting
    Dell XPS 420 /Dell 8250, Windows 7, iPod 3G, Ipod 5G 80 video ,iPhone 3G ,iPhone4, 2gen Shuffle
  • Stinkycheeseman Level 1 Level 1 (15 points)
    Currently Being Moderated
    Dec 19, 2010 1:01 PM (in response to Peter Gillespie)
    Great! That worked for me!
    iMac, Mac OS X (10.6.5), iPhone 4 32GB Time Capsule 500GB
  • Jon Coley Level 2 Level 2 (200 points)
    Currently Being Moderated
    Dec 20, 2010 4:10 AM (in response to Peter Gillespie)
    Doesn't work for me unfortunately, when I hit reset the Max Message size stays at 2097152. However, my theory of it needing a 3G connection seems to hold water. I tried to send a photo from my phone this morning and had a good 3G connection from work and it sent without a hitch but I have to disconnect any wifi connection for this to work.
    Mac Pro Quad Core, Mac OS X (10.6.5), MacBook Black, Quicksilver G4, iPhone 4 16gb, iPod 3rd Gen
  • Peter Gillespie Level 6 Level 6 (10,760 points)
    Currently Being Moderated
    Dec 20, 2010 4:37 AM (in response to Jon Coley)
    You are not saving it
    Look here the issue is the size set by O2 carrier settings .
    http://forum.o2.co.uk/viewtopic.php?f=3&t=56353

    Once you actually change size it should work
    Dell XPS 420 /Dell 8250, Windows 7, iPod 3G, Ipod 5G 80 video ,iPhone 3G ,iPhone4, 2gen Shuffle
  • killhippie Level 3 Level 3 (580 points)
    Currently Being Moderated
    Dec 20, 2010 7:28 AM (in response to JamesRene)
    I had that issue but it seems to have gone now, mms also had been disabled at O2's end after the update somehow. Anyway its working now, maybe O2 got things sorted.
    iMac 21.5" 8GB ram, i5 3.6 ghz, 32GB iPhone 4, Mac OS X (10.6.5)
  • philg1824 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 22, 2010 11:05 AM (in response to Peter Gillespie)
    Many thanks!! Worked for me. Phil
    Mac OS X (10.6.1)
  • Peter Gillespie Level 6 Level 6 (10,760 points)
    Currently Being Moderated
    Dec 22, 2010 12:56 PM (in response to philg1824)
    Cheers
    Dell XPS 420 /Dell 8250, Windows 7, iPod 3G, Ipod 5G 80 video ,iPhone 3G ,iPhone4, 2gen Shuffle
  • can\'t send mms without 3g area Calculating status...
    Currently Being Moderated
    Jan 15, 2011 3:50 AM (in response to JamesRene)
    I recently purchased a i phone 4 out off the 02 shop and i had problems sending message at 1st and then i just kept mucking about with it then when there was a 3g signal on my fone the mms messages were sending ok, but i've not known u must have a 3g signal before u can send a message to a network?

    so you must have a 3g signal in the area ur in to send a mms!
    iOS 4
1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Incoming Links

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.