Skip navigation

USB Ethernet Adaptor

40836 Views 33 Replies Latest reply: Feb 14, 2014 11:53 PM by smiledoc3212 RSS
1 2 3 Previous Next
Madam Calculating status...
Currently Being Moderated
Oct 23, 2010 11:05 PM
I purchased an Apple USB Ethernet Adaptor MB442Z/A to use with my MacBook Air 11". On the right hand USB it worked a couple of times. On the left-hand USB it won't work at all. Now it works on neither. I've checked and it is visible in System Profiler, however in the Network settings it says Cable Unplugged. The left hand USB works fine with 3 other devices I've tested. Any ideas?

Message was edited by: Madam
MacBook Pro 15-inch Aluminum (Mid 2010), MacBook Air 11" (late 2010), Mac OS X (10.6.4), iPhone 3GS iOs 4.01
  • wifiguru Level 2 Level 2 (230 points)
    Currently Being Moderated
    Oct 24, 2010 12:31 AM (in response to Madam)
    So it says cable unplugged when you have the ethernet cable plugged into the USB ethernet adapter and connected on the other side to a router ?
    Connect the USB adapter to the USB port. Launch the Terminal app. and type in
    syslog

    Paste the last 30 lines you see in the output here. ( If you have some other place where you can copy paste the whole output do that and paste the link here). The logs sometimes have some useful info. to help point out if its something simple.
    iPad, iPhone Macbook, Macbook Pro, Mac Mini, Time Capsule, Mac OS X (10.6.4), 11" Macbook Air, 13" MBP, iPHone4, Apple TV 2010
  • DrVenture Level 2 Level 2 (180 points)
    Currently Being Moderated
    Oct 24, 2010 7:05 AM (in response to Madam)
    Do you have another Mac you can try with the USB to Ethernet Adapter? It might be worth a shot to see if the adapter is bad. It sounds suspect that other USB devices can work in either port on the new MBA, just not the USB to Ethernet Adapter.

    Do you have another other USB devices you can try with your MBA's USB ports, to see if they come up?

    Have you considered calling Apple Care?

    In any event, WiFi Guru has a good suggestion about collecting logging and pasting it here. It might point to something else.

    Good luck and let us know how it goes.

    Message was edited by: DrVenture

    Message was edited by: DrVenture
    Many Models, Mac OS X (10.6.4)
  • davberk Calculating status...
    Currently Being Moderated
    Oct 29, 2010 6:52 PM (in response to Madam)
    I'm getting the same problem with TWO different USB ethernet adapters that were known to be good before, using TWO different ethernet cables on TWO different Macs. The only common thread, aside from OS X 10.6.4, is the same Airport Extreme base station unit, but it works fine when connecting my MacBook Pro and my Mac Pro directly via the same network cables.
    Mac Pro 2.66 8x512MB, Mac OS X (10.5.7)
  • davberk Level 1 Level 1 (35 points)
    Currently Being Moderated
    Oct 29, 2010 6:57 PM (in response to davberk)
    OK, the solution seems to be to go into Advanced... from the USB ethernet adapter in Network (System Preferences) and then click Renew DHCP Lease.
    Mac Pro 2.66 8x512MB, Mac OS X (10.5.7)
  • signaldecay Calculating status...
    Currently Being Moderated
    Nov 4, 2010 11:47 AM (in response to davberk)
    But what if you need to use a static IP? Are you just screwed?

    I'm having the same problem: cable is "disconnected" but it bloody well is not.
    Macbook Air 11-inch
  • signaldecay Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 4, 2010 11:58 AM (in response to signaldecay)
    OK, when I applied my static settings, the cable was declared "connected". The issue here seems to be one of poor messaging from the network control panel. The cable is not unplugged, but it says that it is.
    Macbook Air 11-inch
  • JasonFear Level 5 Level 5 (4,935 points)
    Currently Being Moderated
    Nov 4, 2010 1:53 PM (in response to signaldecay)
    Unsure if it's the same issue but on my previous generation MBA, whenever I would plug in my USB-to-Ethernet adapter I had to restart the machine. Only off a fresh restart would it be problem free, yet that same adapter works fine on my Mac Mini and a first generation MBA.

    I'd be curious if that resolves your issue. My 11" MBA works fantastic with the same previously problematic adapter so I'm not convinced that the issue is adapter specific.
    13" MacBook Pro (2.4GHz/4GB/250), Mac OS X (10.6.4)
  • MrJPH Calculating status...
    Currently Being Moderated
    Nov 6, 2010 5:27 PM (in response to Madam)
    I just got the USB Ethernet Adapter today from my local Apple store... I got it pretty much solely for a faster transfer speed using Migration Assistant, versus the nearly five hours it would take for me to transfer 38+ Gb of stuff from my iMac to the Air via AirPort. Brought it home, plugged it in to both computers, and it said the transfer time would now be over FOURTEEN HOURS long! What the - ?! That was plugged into the right (display port and card reader side) USB port, and didn't try the left (power adapter side).

    Plus, I didn't know if it would or not, but also tried to see if I could connect to the internet through the adapter, and couldn't either, as the USB port has it's own IP address or something.

    So, I find the adapter pretty useless and without a point to having it, and will be returning it.

    I'll be glad to finally have my Air up and running and all ready to go.

    Message was edited by: MrJPH: Forgot to specify that the nearly five hour transfer time, was from doing so via an AirPort transfer
    iMac 27" 3.06 GHz Intel Core Duo / Macbook Air 13", 1.86 GHz Intel Core Duo, Mac OS X (10.6.4)
  • juliap2151 Calculating status...
    Currently Being Moderated
    Nov 19, 2010 2:15 AM (in response to Madam)
    i am having the same problem with my ethernet adapter.
    it is connected and i am sure everything is working but the system tells me that its not connected.

    whats the solution for this problem??
    MacBooc Air 13', Mac OS X (10.6.5)
  • DrVenture Level 2 Level 2 (180 points)
    Currently Being Moderated
    Nov 19, 2010 6:52 AM (in response to juliap2151)
    Did you buy the ethernet adapter along with the Mac? Is it an Apple USB to ethernet adapter?

    When you plug the USB to ethernet adapter in does it ever show up in System Prefs - Network or in /dev/?
    Many Models, Mac OS X (10.6.4)
  • SurfBoy Calculating status...
    Currently Being Moderated
    Nov 19, 2010 8:31 AM (in response to DrVenture)
    I have issues with this as well.

    Brand new MacBookAir3,2 but the Apple USB Ethernet adapter was bought when I had the older MacBookAir2,1. Plugged it in, and nothing even shows up in System Preferences.

    Disappointing.
    MacBook Air, Mac OS X (10.6.5), 4 GB RAM, all the latest stuff ...
  • juliap2151 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 23, 2010 6:05 AM (in response to DrVenture)
    yes it is a brandnew apple usb to ethernet adapter.
    it worked with the macbook pro of my collegue, immediately it recognizes the adapter, but with my new macbook air it doesnt do anything. it says its not connected.
    i did the "DHCP-lease renewing thing" and it didnt help.
    what should i do?
  • anpwq Calculating status...
    Currently Being Moderated
    Nov 30, 2010 5:31 PM (in response to juliap2151)
    I can replicate this on my new 13 MBA. I also have a new adapter and the ethernet connection fails by the MBA on either port ("Cable unplugged. Either the cable for USB Ethernet is not plugged in or the device at the other end is not responding.").

    The adapter is recognized, and works, with my MacBook Pro. The other end of the ethernet cable is a DLink gigabit router running as a switch but it hasn't exhibited problems with USB adapters, including this one, in the past.

    Message was edited by: anpwq
  • anpwq Level 1 Level 1 (65 points)
    Currently Being Moderated
    Dec 1, 2010 6:07 PM (in response to anpwq)
    Solved. I brought both the MBA and ethernet adapter to the Genius Bar today and lucked out on who helped me. The guy there figured it out very quickly based one something he's seen before. Create a new location in the Network preferences. Plug the ethernet cord into the adapter, wait a second or two, then plug the adapter into the MBA. Open a page in Safari and keep refreshing it until it loads. It should recognize the adapter and get a network connection within a minute or two. This fix seems to be a one time thing - I didn't have to do this when I connected at home later.

    He's seen problems with the default "Automatic" location in the past on other models too. Perhaps it is something in the install process. Using a new location seems to resolve the problem. If you really want a location named Automatic, delete the default one and rename your new location to Automatic.

    Message was edited by: anpwq
1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.