Skip navigation

Intermittent AirPrint connection with new HP D110 and iPad

28074 Views 60 Replies Latest reply: Jun 15, 2013 1:17 PM by Marcel K RSS
1 2 3 ... 5 Previous Next
jwrightstudio Level 1 Level 1 (0 points)
Currently Being Moderated
Dec 2, 2010 8:15 AM
So I got a brand new HP D110 with ePrint yesterday, set it up on my Time Capsule/Airport network, followed all the directions given by Apple and from this discussion board. However, the printer only shows up on my iPad or iPhone about half the time. At first it didn't show up at all, then after turning the printer on and off multiple times it shows up. I print something in safari, switch to mail (after printing completes) and then the printer disappears when I try to print.

Anyone else seeing the printer disappear half the time? My network is at full signal and everything else work great with the printer. Pretty frustrating experience and there are not any tools to figure out the problem.
Macbook Pro, Mac OS X (10.6.5), and 3G iPad
  • OSgnostic Calculating status...
    I have the identical problem. New HP D110 printer and new iPad. I can print and scan from Windows XP. I have only been able to print once from the iPad. All other times I get "No Printers Found". I started with a Linksys router using WEP security. I have since switched to WPA with no better results. I installed the HP iPrint Photo 3.0 but it does not see the printer even with file sharing turned on.
    iPad, iOS 4
  • rbii Level 2 Level 2 (345 points)
    You can use the free ZeroConf browser on your iPad to check whether the printer is visible to your iPad.
    iOS 4
  • rbii Level 2 Level 2 (345 points)
    Here's the link to the free app:

    http://itunes.apple.com/us/app/zeroconf-browser/id316741416?mt=8

    It will show all of the devices on your network advertising via Bonjour. Your printer should be listed by this app under "Internet Printing Protocol". Determining whether it is reliably listed there can help narrow down your problem
    iOS 4
  • igmackenzie Level 4 Level 4 (2,275 points)
    I (and others) have the same problem with shared printers on Airprint. Sometimes they are there, and sometimes they are not!
    Seems to affect some users and not others. Weird.
     iPhone 3GS 32Gb iOS 4.2.1,  iPad 32Gb 3G iOS 4.2.1
  • ArnieAZ Level 1 Level 1 (35 points)
    I've found if the printer/scanner (C310a) has been turned off, it's difficult to require.
    I do a reset network settings followed by reentering router password and they come back.
    If I let the printer just sleep, then everything stays connected.

    Also, check for updates on the printer. I had two and everything is running better now.
    Also, you can enter the printer IP address in safari's address bar and access all the printer settings via safari.

    Very happy here
    iBook G4, MacBook 2.0 (white), iMac 24" 2.8 iPhone 8GB, Mac OS X (10.5)
  • NoMoPC Calculating status...
    Just spent an hour online chat with HP Helpdesk. They could not figure out why my iPad could not locate my new hp d110. They are going to work on it and email me some suggestions. One commonality with another poster....I do have a qwest D1000 modem. We'll see this proves to be the issue.
    I've tried everything in all the posts and on the website for apple and hp. The printer is wonderful and inexpensive for everything it does. It is pretty slick to print using the eprint option and will be outstanding once I can use the AirPrint. Printer was 69.99 delivered on amazon.
    Ipad, iOS 4, iPad only!
  • HP Mac Architect Level 3 Level 3 (530 points)
    One troubleshooting step is to restart everything (the router, the iOS device, and the Printer). Even better if you can power-off the Printer and Router. Upon bringing everything back up, things should work. If you're still having problem with your D110, please post back your firmware version on the D110, which router you are using, and the configuration of your iPad (or other iOS device).

    One other trouble shooting tip you can try is since you already have the sharing solution working, setup a shared queue for the D110 through your Mac as well and see if the problem goes away. Let me know the results.

    Just trying to help.

    Andrew
    MacBook Pro, Mac OS X (10.6.5), iPad 3G, iPhone 4
  • bourkee9 Calculating status...
    I am having the exact same problem with the HP D110 and my iPad and iPhone 4. Tried turning everything off and starting it back up again but still get the inconsistent printer detection for both iPhone 4 and iPad.

    I have updated to the latest HP firmware for the D 110 which btw helped the problem but certainly did not fix. Prior to the update I would detect the printer from iPad 1 in 10 tries, now since it's like 1 in 4 tries.

    I can print no problem from my laptop. I have a linkskys WRT 610N router with the latest firmware installed.

    I hope HP and apple fix this soon as it's a waste of time trying to get it to work.
    iphone 4, iOS 4
1 2 3 ... 5 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.